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Introduction

This document explains the essential skills needed to author Impromptu reports, set up 
drill-through between Impromptu reports, and customize reports to highlight important 
information.

Each step-by-step lesson focuses on one or two features. It culminates in the production of a 
report that matches one of the samples installed in the Reports folder. 

For more information about using this product, visit the Cognos Global Customer Services Web 
site (http://support.cognos.com). For information about education and training, click the Training 
link from this site. 

This document is available as an online book.

Our documentation includes user guides, tutorial guides, reference books, and other materials to 
meet the needs of our varied audience. An annotated list of other documentation, the 
Documentation Roadmap, is available from the Windows Start menu or the Impromptu Help 
menu.

Online Help
All information is available in online help. Online help is available from the help button in a Web 
browser, or the Help menu and help button in Windows products. You can also download the 
online help from the Cognos Global Customer Services Web site (http://support.cognos.com).

Books for Printing
The information in each online help system is available in online book format (PDF). However, 
the information from a given help system may be divided into more than one online book. Use 
online books when you want to print a document or when you want to search the whole 
document. 

You can print selected pages, a section, or the whole book. Cognos grants you a non-exclusive, 
non-transferable license to use, copy, and reproduce the copyright materials, in printed or 
electronic format, solely for the purpose of providing internal training on, operating, and 
maintaining the Cognos software. 

Online books are available from the introduction to the online help for each component. 

You can also read the product readme files and the installation guides directly from Cognos 
product CDs.
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Chapter 1: Opening a Catalog and a Report

Each catalog contains all the information that Impromptu needs to generate a particular set of 
reports from the data in your source database. As such, the catalog contains the name and 
location of the database connection, the names of the selected table columns, information about 
any join relationships between these tables, user class access permissions, conditional filters, 
calculations, and prompts. 

However, as a report author and user, you do not need to know how to create and maintain 
catalogs: that is the Impromptu administrator’s job. You merely need to select the sample catalog 
and begin exploring.

Note that all the examples are based on the sample reports included with your installation of 
Impromptu and kept in the Reports folder.

Example - Open the Sample Catalog
You are the Sales Manager for a camping equipment company named the Great Outdoors 
Company. You want to open the catalog that lets you view or create reports related to your 
business.

Before you select the sample catalog, you must start Impromptu.

Tip: Double-click the Impromptu icon on your desktop, or click the Start button. If you see the 
Welcome dialog box, you can clear the Show this dialog in the future check box to bypass it from 
now on.

Steps
1. If you do not have the gosales.cat catalog open, from the Catalog menu, click Open and 

double-click gosales.cat in the Reports folder.
Tip: Check the lower status bar. If you see GOSales Catalog, the catalog you need is currently 
open.

2. If the Cognos Common Logon dialog box appears, click Cancel.
3. In the Catalog Logon dialog box, select Sales Department Manager as the user class, and click 

OK.
Note: To perform the exercises in this tutorial, you always select this user class to ensure that 
you are granted the appropriate access privileges. If you use your own catalog, it may have a 
different user class hierarchy. Ask your application developer or administrator what user class 
is appropriate for catalogs other than gosales.cat.

4. If a Catalog Upgrade dialog box appears, click Upgrade this catalog and click OK.

Example - Open an Existing Report
You are the Sales Manager for a camping equipment company named the Great Outdoors 
Company. You want to open an existing report that shows how much revenue each of your 
product types has been generating, country by country.

Because this sample is a prompt report, you can select one country to view its revenue. Other 
prompt dialog boxes require you to type in a prompt value. The prompt acts as a filter for the 
data so that only the information you require appears in the report.

Steps
1. From the File menu, click Open.
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2. In the Reports folder, double-click sales_volume_by_country_(prompt).imr.
Impromptu prompts you to select a country.

3. If a Report Upgrade dialog box appears, click Upgrade this report and click OK to close the 
dialog box.

4. Click Australia, and click OK to open the report.
Observe that the report includes a bar graph and data table showing sales volumes for 
Binoculars, the first product type in the alphabetically sorted set of Great Outdoors Company 
products.

5. From the Report menu, click Prompt to show the Prompts dialog box.
6. Click Austria, and click OK.

Note: You cannot use Ctrl+click to select several countries at once.

7. Explore the report using the navigation arrows in the top right. For example, click the single 
down-arrow to show the next product in the set (Climbing). Or click the double down-arrow 
to go to the last page of the report (Woods).

Try on Your Own
By default, this report appears in Screen Layout view. However, you can change the view to Page 
Layout from the View menu. Each template and sample report has a default layout, and that is 
what is stored when the file is saved. Unless you explicitly change the view and save it again, this 
is the view that appears whenever the file is opened.

Impromptu also offers various options for saving and printing your reports:
• From the File menu, click Print. In the Print dialog box, select the appropriate settings and, 

optionally, send the report to the printer.
• Use the Save As command to save the file as an .xls file type, and then open it in Microsoft 

Excel.
• Save your file as an .HTM file type, and then open the index.htm file to see how the report 

will appear when published to the Web.

Report layer navigation arrows:

- first page
- previous page
- next page
- last page

View Contents Scrolling

Page layout All the information that fits on the defined page size (the 
default is 8.5 x 11 inches) plus the headers and footers for the 
report

Buttons

Screen layout All the information in the report, regardless of how it fits on 
the printed page

Scroll bars
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Chapter 2: Creating a Grouped List Report

The easiest type of report to create is a list report, and Impromptu provides a wizard to guide you 
through the process.

In this lesson, you create a grouped list report like one provided in the sample set, add a filter and 
formatting to help users focus on key data, and then add a summary fact column to tailor the 
report to your business needs.

Example - Create a Grouped List Report Using the Report 
Wizard

You are the Sales Department Manager for a camping equipment company named the Great 
Outdoors Company. The Human Resources Manager wants to develop an incentive program to 
reward excellence in particular sales regions.

You begin by creating a report that lists all sales staff. With the help of the Report wizard, you 
ensure that the data is grouped (or sorted) by position (Branch Managers and Sales 
Representatives at various levels).

Steps
1. If the sample catalog gosales.cat is not already opened, open the catalog now (p. 7).

Tip: Check the lower status bar. If you see GOSales Catalog, the catalog you need is currently 
open.

2. On the toolbar, click the new button to show the Report wizard. 
Tip: Do not click New from the File menu. This opens the New dialog box instead of the 
Report wizard.

3. Type a name for your report, such as Grouped Sales Staff Report, and then click Next.
4. Ensure that List Report is selected, and then click Next to show the data item selection page.

Each data item you select here will be presented as a column in your report.
5. Double-click the Country folder to open it, and then double-click the Country data item to 

add it. (You will be filtering on it, later.)
6. Double-click the Sales Staff folder to open it, and then double-click the following data items 

to add them to the Report Columns box:
• Firstname
• Lastname
• Position
• Workphone
• Extension

7. Click Next and then select the check box next to Position.
This will sort the information about your sales staff by their position.
In this example, because sales figures are not included, the Automatically Generate Totals 
check box is disabled. If your report included a measure such as sales volumes for each staff 
member, you would select this check box to add the values for this numeric column to the 
overall list footer. For a grouped report, separate footers (or subtotals) also appear each time 
the grouping changes (in our case, managers and representatives at each level).

8. Click Finish to retrieve the data and show your grouped list report.
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You could click Next here, and proceed to the filter-adding page of the wizard. However, we 
recommend that you first compare your interim report with the sample sales_staff_report.imr 
located in the  installation_location\cer5\Samples\Impromptu\Reports folder.

Your multi-page report shows information about all your branch managers and sales 
representatives, in Page Layout form.

9. From the File menu, click Save As, type an appropriate name for your report, and then click 
Save.
Your next step is to add a country prompt so you can focus your report on the location where 
you plan to test your reward program.

Example - Add a Filter and Formatting to Focus on Key Data
In this exercise, you learn how to enhance the report you just created by
• adding a filter so that users can focus to one country
• reorganizing the information to make the report more usable
• enhancing its appearance using custom formatting

Instead of reopening the Report wizard, you can use the filter button on the toolbar to filter the 
report on a selected item (in our case, a country).

Steps
1. Open the report you created in the previous exercise, click the down-arrow to the right of the 

filter button on the toolbar, and click Filter Definition.
2. In the Filter tab of the Query dialog box, double-click the Report Columns folder to open it, 

and then double-click Country to add that column to the Filter definition box.
3. Double-click the equals sign (=) and double-click select values.
4. Click Germany and click OK.
10  Cognos Impromptu (R)     
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 5. Accept the defaults, click OK, and observe the filtered report.
The list now shows your German staff: four managers, two mid-level, and one senior sales 
representative.
Tip: If you decide to change the filter, click the Filter button again. A message warns you that 
the filter will be cleared from the report. Click OK to return the report to its unfiltered state.

6. With the report in Page Layout view, click the top of the Country column to select all column 
cells.

7. From the Edit menu, click Delete.
Your list does not need this column because there is only one country in your report.

8. Double-click the existing title, and then change the text by typing German Sales Staff Report. 
9. If you want, from the Format menu, click Align and left-align the title text. Or click Font, 

select a larger type size, and change the text to bold italics for emphasis.
10. Click the top of the Position column, and then click the header button on the toolbar.  

Observe that each staff member is now located under the header appropriate to their position, 
making the list easier to understand.

11. Click the top of the Lastname column, and then click the sort ascending button on the toolbar. 
Observe that the names in each group are now in alphabetical order. 

12. Double-click to select the column headings and then rename them to First Name, Last Name, 
and Work Telephone. 
Observe that the column resizes to accommodate the new width.

13. Click the Branch Manager row so that the entire cell is selected, and then from the Format 
menu, click Patterns to change the background from the default, Transparent, to a solid gray 
pattern.

The filter operators that are 
available depend on the item you 
selected.
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14. Press the Esc key to see the effect of your changes.
Experiment with other formatting options until you are satisfied with the results.

15. From the File menu, click Save As and save your report using an appropriate file name.

Example - Add a Summary Column to a List Report
When you present your report to the incentive program planning team, they ask for additional 
information about sales targets. In this exercise, you learn how to add a summary column to your 
list report.

Steps
1. If you have not already done so, open the grouped list report you created in the previous 

exercise and, from the Report menu, click Query.
2. On the Data tab, double-click the Sales Staff and Targets folders to open them, click 

Salestarget, and then click the sum button.
3. Leave the Label text as is, click the Total button, and click OK.
4. Confirm that your new data item was added to the query. 
5. Click the Group tab and select the Auto-group check box. (Do not click Position: that item 

does not have a 1:1 relationship with your staff, and using it would change the list order used 
in the report.)
This organizes your totals by Work Telephone Extension.

6. Click OK to run the report. 
Observe that your new column, Total Salestarget, is added. Managers are not listed in the 
report because they do not have sales targets.
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7. If you want, double-click the new column heading to select it, and then change the name to 

Total Sales Target.
8. From the File menu, click Save As and save your report with an appropriate file name.

You next learn how to create a more complex report, the crosstab, using a template rather 
than the Report wizard.

Try on Your Own
You can use this report as a building block for more complex reports, or create another report 
based on the default template (Grouped List). For more examples about grouping, summarizing, 
filtering, and formatting your rows and columns, see the remaining exercises in this document or 
the online Help.
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Chapter 3: Creating a Crosstab Report

A crosstab is a tabular report that shows a measure at the intersection of each row and column. 
Columns typically represent different dimensions of your business.

Impromptu provides a template on which you can base your crosstab report. In this lesson, you 
create a simple crosstab like the one provided in the sample set. The report includes summary 
totals to make the information more useful.

Example - Create a Simple Crosstab Using the Template
You are the Sales Department Manager for a camping equipment company named the Great 
Outdoors Company. You want to review expected sales volumes for your various product lines.

You create a crosstab based on the template provided with Impromptu, automatically generating 
the appropriate totals.

Steps
1. If the sample catalog gosales.cat is not already opened, open the catalog now (p. 7).

Tip: Check the lower status bar. If you see GOSales Catalog, the catalog you need is currently 
open.

2. From the File menu, click New to open the New dialog box. 
Tip: Do not click the new button on the toolbar. This opens the Report wizard instead of the 
New dialog box.

3. Specify that your new report will be a Crosstab and click OK.
4. On the Crosstab tab of the Query dialog box, select data items:

• Double-click the Products folder to open it, click Productline, click the rows button, and 
confirm that this item appears in the Rows box as shown.

• Double-click the Sales Forecast folder to open it, click Year, click the columns button, and 
confirm that this item appears in the Columns box, as shown.

• Click Expectedvolume, click the cell contents button, and confirm that this item appears 
in the Cells box, as shown.
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 5. Select the sum symbol check box under the Summarize button, to add footer totals. (If the 
crosstab were to incorporate a nested column, such as Month, subtotals would also be added 
for each month level.)

6. Click Total Cell Details, click Summarize, and then use the Preview box to confirm how your 
overall totals will appear (all product lines will be summarized, for each year).

7. Click OK twice, and then wait for the report to run and appear in Screen Layout view. 
Observe that Camping Equipment sales are expected to increase but sales in the Outdoor 
Protection line are expected to decline.

8. From the File menu, click Save As, type an appropriate name for your report, and then click 
Save. Leave the report open for the next exercise.

Example - Add Formatting as Used in the Sample Report
In this exercise, you learn how to apply some of the formatting effects used in the 
simple_crosstab_report.imr sample to make your report more graphically interesting. You can 
find the sample report in installation_location\cer5\samples\Impromptu\reports.

Steps
1. Click the blank area to the right of the report you created in the previous exercise, to select it. 

Then, from the Format menu, click Properties.
2. Click the Layout tab, select the List Header check box, and click OK. Press the Esc key to 

clear all highlighting from the report.

Data items appear here as you 
add them to form your query.

Catalog folders 
provide a logical list of 
the columns in the 
corporate database.

Buttons: 
- columns 
- rows 
- cell contents 
- calculations
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Observe that you now have a frame that you can use for your title.
3. From the Insert menu, click Text Frame. Drag the pointer to create a text box in the header 

area, and type your title.
4. With the text box selected, from the Format menu, click Font and select a bold italic font at 

14-point size to make your title stand out. Click OK.
5. Drag the left side of the text frame to reduce its size and allow room for your logo in the 

upper left corner of the report. Press the Esc key to clear the selection. From the Insert menu, 
click Picture Frame, and drag the pointer to trace out a small square frame to enclose the GO 
bitmap. 

6. On the Source tab, click the Browse button next to the Load from file option. In the 
\reports\samples support folder, click go.bmp, click Open, and OK. Size the resulting image 
so that it fits into its frame, as shown. 

7. Select all the values and, from the Format menu, click Data.
Tip: You can Shift+click the first and last cells in the table, and then those in the summary 
row, to select all the values at once.

8. In the Positive box, click $#,##0.00_) as the currency data format, and then type Null in the 
Missing box to replace empty cells with the word Null in your final report. Click OK.

9. Experiment with the Format menu. Select each text area in turn, and use the Font and Patterns 
options to achieve different color effects. Use the Esc key to deselect and Edit/Undo Format to 
undo.

10. From the File menu, click Save As, type an appropriate name for your newly formatted report, 
and then click Save.
You next learn how to create linked drill-through reports, building on what you already 
learned.

Try on Your Own
You can add new query data to your crosstab, or use the report as a base for adding pie charts or 
bar charts so viewers can quickly grasp the importance of the numeric data. For more 
information, see "Customizing Reports and Charts" (p. 23), and the online Help.
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Chapter 4: Creating a Drill-Through Report

Typically, a drill-through report lets users move from summary data to supporting detail, revealing 
the underlying trends. By adding a drill-through link to a summary report, users can open the 
detail report that provides the related supporting information. For drill-through reports, summary 
and detail reports are also known as parent and child reports, respectively.

To complete the lesson, you must have the sample file named 
income_from_customers_drillthrough.imr, which is located in 
installation_location\cer5\Samples\Impromptu\Reports.

Example - Create a Summary Report
You are a junior sales analyst for the Great Outdoors Company. Your manager wants a report 
that summarizes the yearly performance of each of the company’s retailers. The information will 
be used to reward high-performing retailers with discounts or promotions, and to cut company 
losses with low-performing retailers and products.

You begin by creating a report that contains a list of retailers with their total incomes. The data 
items you add to the report include a data item that already exists in the catalog and a calculated 
data item that you create. You sort the list by total income in descending order to show which 
retailers have the highest performance. Finally, you add a drill-through link that opens to a related 
report showing the products and product lines contributing to each retailer’s total income.

Steps
1. If the sample catalog gosales.cat is not already opened, open the catalog now (p. 7).

Tip: Check the lower status bar. If you see GOSales Catalog, the catalog you need is currently 
open.

2. From the File menu, click New, and click OK.
The SimpleList template is selected by default.

3. In the Query dialog box, in the Catalog list, open the Orders folder, and then open the Order 
Details folder.

4. Click Retailername and click the add arrow.
Retailername appears in the Query data box.

5. Click Retailername, click Edit Definition, and then in the Name box type 
Retailer Name

6. Click OK.
7. In the Query dialog box, click the calculation button and, in the Name box, type

Income.
8. In the Available Components box, select data items:

• Double-click Summaries, and then double-click the total function.
• Double-click Catalog Columns and, in the Catalog folders box, double-click Orders and 

click Order Income, and click OK.
• Double-click the for operator.
• Double-click Report Columns, click Retailer Name, and then click the Add arrow.
Your expression should look like this:
total (Order Income) for Retailer Name ...

9. Click OK twice.
The report shows a list of retailers in alphabetical order, along with the total income for each.
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10. From the File menu, click Save As, type an appropriate name for your report, and then click 

Save. Leave the report open for the next exercise.

Example - Refine the Query and Format the Report
You refine the report query by adding a filter and sorting the data values in the calculated column. 
Filtering the data lets you focus on the income earned for the year 2001. Sorting the data lets you 
list the retailers in descending order by total income. You then format the report to conform to 
company standards by adding currency formatting to the income values and adding a title to the 
report.

Steps
1. Click the down-arrow to the right of the Filter toolbar button, and click Filter Definition.
2. On the Filter tab in the Available components box, create the year filter:

• Double-click Functions, and then double-click year.
• Double-click Catalog Columns, and then, in the Catalog folders box, double-click 

Orders, click Orderdate, and click OK.
• Double-click the equals sign =.
• Double-click number and then type

2004 
Your expression should look like this:
year(Order Date) = 2004

3. Click OK to save the filter.
4. From the Report menu, click Query, and then click the Sort tab.
5. Select the data item Income, click Descending, and click OK.

Observe that your retailers now appear in ranked order, although the non-standard 
formatting makes it difficult to detect the rankings.

6. Click a data item in the Income column of the report and, from the Format menu, click Data.
7. In the Positive box, click the number format $#,##0.00_) and click OK.
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The numbers are formatted to use the default currency symbol. However, you can change this 
setting in the Positive box of the Data tab to use any other value in the Currency Symbol list. 
Your choices are limited by the languages in your locale setting.

8. Double-click the text area marked <Type here to customize title>.
Impromptu inserts a flashing I-beam in the title area.
Tip: If you click only once in the text area, Impromptu selects the entire text frame in which 
the title is placed. You can press Esc to clear the highlighting and then double-click the title to 
see the flashing I-beam.

9. Drag the pointer to create a text frame, type Income from Customers as your title, and press 
Esc to refresh your view.
Tip: As you type the title, parts of it may disappear from the screen. This happens because the 
text is in a frame of limited size. When you press Esc, all your typed-in text reappears.

Example - Add and Test a Drill-through Link
Now that you have the summary report, you can add a drill-through link that opens a related 
report showing the products and product lines contributing to each retailer’s total income. You 
can use an existing sample report as the detail report.

Steps to Add a Drill-through Link
1. In the Retailer Name column, click a data item.
2. From the Report menu, click Drill Through, then click Properties.
3. In the Drill through link box, click Retailer Name, and then click Add.

Because drill-through access to the detail report is based on one data column only (Retailer 
Name), when the detail report opens, it filters on that column. However, you can set up 
drill-through reports to drill on more than one data column.

4. In the Add Drill Through Query/Report dialog box, go to the folder named 
installation_location\cer5\Samples\Impromptu\Reports, and open the file named 
income_from_customers_drillthrough.imr.

5. Click Open, and then click OK twice.
6. From the File menu, click Save As and then type an appropriate name for the summary report. 

Leave the report open for testing.
Tip: To let users know that a drill-through link exists in the report, you may want to use the 
Font option on the Format menu to add a visual clue, such as underlining, to the Retailername 
data items.

Steps to Test the Drill-through Link
1. In the Retailer Name column of the summary report, click Falcon Outfitters.
2. From the Report menu, click Drill Through, and then click 

income_from_customers_drillthrough.imr.
3. If a Catalog Upgrade dialog box appears, select Upgrade this catalog and click OK.
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4. Confirm that only the data for the appropriate retailer shows in the detail report.
5. Open income_from_customers_drillthrough.imr without using the drill-through link from the 

summary report, and confirm that the filter is no longer applied. You should see different 
data.

Try on Your Own
You can test the drill-through link with the other retailers, to see the product-by-product 
breakdown for each.

You may want to format your report to conform to your company’s standards. For information 
about customizing reports, see "Customizing Reports and Charts" (p. 23) or the online Help.
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Chapter 5: Customizing Reports and Charts

In this lesson, you learn how to customize reports using conditional formatting, and enhance 
charts to better convey information.

Example - Add Conditional Formatting
As the Sales Department Manager for the Great Outdoors Company, you must compare actual to 
forecast sales, year by year and region by region. To help you in this analysis, you use a report that 
applies conditional formatting showing negative numbers in red. You want to remove the existing 
formatting and highlight exceptional performance instead. To do this, you must create and apply a 
new conditional expression.

Steps
1. If you do not have the gosales.cat catalog open, from the Catalog menu, click Open and 

double-click gosales.cat in the Reports folder.
Tip: Check the lower status bar. If you see GOSales Catalog, the catalog you need is currently 
open.

2. From the File menu, click Open, and double-click 
Actual_Sales_Against_Target_Sales_(prompt).imr in the Reports folder.

3. When prompted for the country, click Germany, and click OK.
4. Right-click a value in the Total Sales column, click Conditional Formats, and then click 

Conditions.
5. Click Add Custom Condition.
6. In the Name box, type

Exceeds Target
7. In the Available components box, double-click Report Columns to open it, and then 

double-click Total Sales to start building the expression.
8. Complete the expression for the Exceeds Target definition: 

• Double-click the greater than symbol (>).
• Double-click the number entry and type 3000000.
• Click OK and confirm that the definition appears in the list.

9. Click Close and confirm that your new definition appears in the Condition list. Observe that 
the Style entry is set to None.

10. Click Exceeds Target, and in the Change style to box, click Grass Green 3.
11. Click Missed Target, and in the Change style to box, click None.

The conditional format entries should appear as follows.
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12. Click OK.
13. Press the Esc key to remove the color overlay. Confirm that entries that exceeded target are 

highlighted in green.
14. From the File menu, click Save As, type an appropriate name for your customized report, and 

then click Save.

Try on Your Own
Now try red-flagging vendors whose incomes are below a specific threshold ($75,000). You can 
add a conditional (calculated) expression and custom formatting to the sample report named 
income_from_customers.imr. Or, you can use the vendor list report you previously created as a 
drill-through source (see "Creating a Drill-Through Report" (p. 19).

Tip: You can use the Patterns option in the Format menu to achieve other color effects.

Example - Add Chart Enhancements
As the Sales Manager for the Great Outdoors Company, you frequently give presentations in 
which you include reports that have embedded charts. You typically make enhancements to the 
charts to improve their usability.

In this exercise, you add enhancements to the sample report named 
product_details_drillthrough.imr. This report contains two charts, and you change one chart to 
make it more closely match the other chart. You
• change the chart and axis titles
• customize the category title
• customize the value title (Y1)
• change the location of the legend
• change the location of data values on the bar columns
• change the color of the bar columns
• change the depth of the chart
• add grid markers
• add extra labels on the vertical axis

Steps to Open the Sample Report
1. From the File menu, click Open.
2. In the Reports folder, double-click product_details_drillthrough.imr.
3. In the Prompts box, click Aloe Relief, and click OK.

Steps to Change the Chart and Axis Titles
1. Right-click the chart named Total Return Quantity, click Properties, and click the Format tab. 
2. Click Titles and, in the Title box, select Total Return Quantity, and then type

Total Quantity Returned
3. In the Category Title box, select Returns, and then type

Year
4. Click OK twice.
5. Press the Esc key to see the effect of your changes.

The chart and category titles appear as you entered them.

Steps to Customize the Category Title and Value Title (Y1)
1. Right-click the quantity returned chart, click Properties, and click the Format tab.
2. In the Font formatting box, click Category title, and click Edit. 
3. On the Font tab, change the font color to black and the font style to bold. Keep the alignment 

setting at center, and click OK.
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4. In the Font formatting box, click Value title (Y1), and click Edit. On the Font tab, change the 
font color to black, the font style to bold, and the font size to 11. Click OK twice.

5. Press the Esc key to see the effect of your changes.
The category title and value title appear as you formatted them.

Steps to Change the Location of the Legend
1. Right-click the quantity returned chart, click Properties, and click the Format tab.
2. Click Properties, click the Look tab and, in the Layout box, click Legend on Right Side.
3. Click OK twice.
4. Press the Esc key to see the effect of your change.

The legend now appears on the right side of the chart.

Steps to Customize the Bar Columns
1. Right-click the quantity returned chart, click Properties, and click the Format tab.
2. Click Properties, click the Data Labels tab, in the Labels Location box, click Outside 

Maximum, and click OK.
3. Click Customize per Data Item and, in the Color column, change the color for 2004 to yellow, 

the color for 2005 to light green, and the color for 2006 to dark green.
4. Click OK twice.
5. Press the Esc key to see the effect of your changes.

The data values now appear just below the maximum value on the bar columns. The colors of 
the two charts now match.

Steps to Customize the Chart Depth, Grid, and Scale
1. Right-click the quantity returned chart, click Properties, and click the Format tab.
2. Click Properties, click the General tab, change the depth to 125, and click OK.
3. Click Grids and Scales, and click the vertical Y1 Axis tab. Click the horizontal Grids tab, 

select the Show Gridlines check box and, in the Grid Style box, click Regular Grids to add 
horizontal grid lines to the chart.

4. Click the horizontal Scales tab, select the Set Maximum Value check box, and type 16 to add 
an extra label on the vertical axis. 

5. Click OK twice.
6. Press the Esc key to see the effect of your changes.

The bars in the chart have more depth, and there are now horizontal grid lines and an extra 
label on the vertical axis.

After making all the enhancements, your chart should look like this.
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Try on Your Own
Try using other samples in the Reports folder to experiment with the charting features provided in 
the latest Impromptu release. Try changing the chart type from a bar chart to something different, 
such as a pie chart, and experiment with the options available for that chart. For instructions, see 
the online help.
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Glossary

associated data item
A data item linked to the group data item. Associated data items suppress duplicate data values, 
but do not generate a control break. For example, if Customer Number is the grouped data item, 
you can repress Customer Name by declaring it as an associated data item. When Customer 
Number appears in the report, it appears only once for the group. Marking a data item as 
associated can affect how Impromptu calculates summary values.

calculated data item
A data item that shows the result of an expression that uses stored data. The value recalculates 
each time a value in the expression changes. For example, you can use the string operator (+) to 
combine a data item called Firstname with a data item called Lastname to form a calculated data 
item called Fullname.

catalog
A file (with the extension .cat) that contains all the information necessary for Impromptu to access 
and retrieve information from a relational database. A catalog does not store data, but it does 
provide Impromptu with a business view of the data. A catalog also contains information about 
what database to access, where the database is stored, and how the tables in the catalog are 
joined.

conditional format
An instruction to Impromptu to look through data in the selected report objects and format the 
data that meets predefined conditions. Use this format to identify exceptional data in your report. 
For example, retail outlets with quarterly revenues greater than $500,000 could be highlighted in 
green, while retail outlets with quarterly revenues less than $250,000 could be highlighted in red.

crosstab
Shows summary information from a list report in a compact table of rows and columns. A 
crosstab shows the value for the combination of each row and column, enabling you to gain a 
different perspective on the data and see more without the need to scroll.

For example, you can change a list report that has three columns (Product Type, Sales Channel, 
Total Sale Amount) into a crosstab that has each Product Type as a row, each Sales Channel as a 
column, and the Total Sale Amount for each combination of Product Type and Sales Channel in 
the cells.

drill-through
An action that enables Impromptu, PowerPlay, and Scenario users to view transaction-level details 
in an Impromptu report. You can set up a drill-through for any cell in Impromptu, any value in 
PowerPlay, or any node in Scenario’s tree view.

expression
Any combination of operators, constants, functions, data items, and other components that 
evaluates to a single value.

filter
A set of criteria used to retrieve a subset of records. For example, instead of viewing total sales, 
you can view sales for a specific region, product line, or time period.
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You can add filters to entities, use filters to create specialized subtype entities, and use filters to 
ensure consistency in the filter expressions used by report users in Impromptu, PowerPlay 
Transformer, and Cognos Query. You can also restrict the data that users can see by applying 
filters to objects within a user class. For example, you can create a filter on the Salary table so that 
only the Human Resources department can view that table.

frame
A report object that acts as a container for other report objects. Frames are the basic building 
block with which you create Impromptu reports.

group data item
A control data item that is used to group data in a report.

See also associated data item.

operator
Specifies what happens to the values on either side of the operator. 

There are four types of operators:
• Logical: defines relationships between two parts of the expression.
• Arithmetic: performs arithmetic operations on two parts of an expression.
• String: concatenates two character strings.
• Comparison: compares one or more values that you enter against the values in the database.

picture frame
A frame that you can use to show a bitmap (.bmp) or Device Independent Bitmap (DIB). You can 
enhance the appearance of your reports by adding images such as a company logo. In addition, 
you can show pictures, such as your company’s products or employees, that change based on the 
content for the items.

prompt
A dialog box that asks the user to enter information when a report is opened. A report can contain 
several prompts which it uses to filter so you only get the data you want. Prompts can require the 
user to type in information, or select items from a picklist. A picklist can include data items from 
the catalog, data items from another report, or data from a file in delimited ASCII format.
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