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Chapter 1: View a Report

Description
You may have created your own Impromptu reports, or someone else in your organization may 
have created a number of reports for you. When you view or open a report, Impromptu retrieves 
the data from the database.

What You Can Do
You can
• view an existing Impromptu report.
• view the report in either page or screen layout view.
• drill through to information behind a value in your report using a drill-through report created 

by you or your administrator.
For example, you can view the detailed sales transactions that account for the total sales for a 
particular customer.

Related Topics
• "Change the Page Layout View of a Report" (p. 11)
• "View an Existing Report" (p. 9)
• "View the Details of a Value in a Report" (p. 10)

View an Existing Report

Steps
1. If you are just starting Impromptu, click Open an Existing Report in the Welcome dialog box. 

Otherwise, from the File menu click Open.
2. Locate and select the report you want to open, and click Open.

If the Cognos Common Logon dialog appears, type your User ID and click Log On if you are 
using Access Manager for security. Otherwise, click Cancel.
If you do not have a catalog open, the Catalog Logon dialog box appears where you can select 
a catalog, enter your user class and click OK.

3. Click OK.
If the catalog or report was created with a previous version of Impromptu, see "Upgrade a 
Catalog or Report" (p. 31).

More Info

Note
• The Welcome dialog box is not available when the Show the Welcome to Impromptu dialog 

check box is cleared in the Start-up tab (Options dialog box, Tools menu).

Tips
• To quickly locate reports in the User Workspace folder, click the FastFind button (Open dialog 

box). To add a shortcut to one of your folders or reports in the User Workspace, click Add to 
FastFind (Open dialog box).

• You can load the same catalog automatically every time you run Impromptu. From the Tools 
menu, click Options, and click the Startup tab.
Impromptu User Reference  9
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Related Topics
• "View a Report" (p. 9)
• "View the Details of a Value in a Report" (p. 10)

View the Details of a Value in a Report

Description
You or your administrator may have created one or more drill through reports that you can open 
from your current report. A drill-through report shows information behind a value you select in 
the current report.

The Drill Through command is available for list reports, crosstab reports, sub-reports, charts, and 
reports using HotFiles or snapshots.

Example

Steps to View the Details Using the Report Menu
1. Select a value associated with a drill-through report. 

Note: Do not select multiple rows and columns. Drill-through reports are available only when 
you select a single value.
You may want to add custom formatting, such as highlighting or underlined text, to indicate 
which values are associated with a drill-through report.

2. From the Report menu, click Drill Through.
3. Select the report you want to view from the list, and click OK.

Step to Quickly View the Details of a Value in a Report
• To open the default drill-through report, do one of the following:

• Select a value associated with a drill-through report and click the Drill Through toolbar 
button.
Drill Through button 

• Double-click a value associated with a drill-through report.
Impromptu opens the default drill-through report if an association exists. If no drill-through 
association exists, the I beam cursor appears indicating that you can edit the text.

More Info

Notes
• Only one copy of a drill-through report associated with a value can be open at a time.
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• Impromptu includes a sample drill-through report, Product Orders Drill-Through.imr

Tips
• To return to the main report from a drill-through report, use the Window menu.
• To view all the data in a drill-through report, click the Undo button on the toolbar.

Impromptu removes the drill-through filter and displays all the data in the drill-through 
report.

• To quickly open a drill-through report, double-click a value associated with a drill-through 
report, right-click a value and select Drill Through from the menu, or select a value and press 
Enter.

• To save a drill-through report, click the Save As command (File menu).
• To drill through from a chart, select the entire chart.

What if ...
• The Drill Through command and the Drill Through button are not available?

No drill-through report is available for the value you have selected or you have selected 
multiple columns or rows. Drill-through reports are available only when you select a single 
value.

• The Drill Through Properties command from the Drill Through drop-down menu is not 
available?
The Enable Drill-Through Properties check box (Options dialog box, Tools menu) is not 
selected.

• The drill-through report contains no data?
There is a conflict between the main report and the drill-through report. For more 
information, see your administrator.

Related Topics
• "Drill Through to Cognos Query" (p. 125)
• "Set Up Drill-Through Access to Cognos Query" (p. 126)
• "View a Report" (p. 9)
• "View an Existing Report" (p. 9)

Change the Page Layout View of a Report

Description
Two different views are available when you work in Impromptu. The view you choose depends on 
the type of work you are doing.
• Use Screen Layout view for inserting graphics or comments. Screen Layout view is good for 

editing and formatting text, and for screen-only reports.
• Use Page Layout view to reduce the view so you can see the edges of your report. Use this 

view to see page numbers if you’ve included them in your report. You can also see the layout 
of the report page including page headers and footers. What you see in Page Layout view is 
how your report will look when it is printed. 

Step
• From the View menu, click Screen Layout or Page Layout.

More Info

Notes
• Page layout view is only available if a default printer is defined.
• The results of the Fit to Page and Repeat This Column on Every Page options are not visible in 

the Screen Layout view.
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• The results of the Fit to Page option are not visible in the Page Layout view. You can only see 
the scaled down columns when you preview a report before printing, or when you print the 
report.

Tips
• To quickly move between the Screen Layout view and the Page Layout view, use the toolbar 

buttons.
Screen Layout button 
Page Layout button 

• To take a closer look at your report, click one of the Zoom buttons on the toolbar. You can 
also reduce the view to see the entire page and make layout decisions easier. You can continue 
working on the report after enlarging or reducing the view.

• To enlarge the view in 25% increments, click the Zoom In button.
• To reduce the view in 25% increments, click the Zoom Out button.
• To fill the whole page, click the Whole Page button.
• To zoom in to 100%, click the 100% button.
• To zoom in to fit the page width, click the Page Width button.

Related Topics
• "View a Report" (p. 9)
• "View an Existing Report" (p. 9)
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Chapter 2: View a Report with a Web Browser

Description
Anyone with a Web browser can view a report that is saved as Hypertext Markup Language 
(HTML). To view HTML report output, you do not require Impromptu.

Depending on how the HTML report is distributed, you can view it either
• directly on a Web page by clicking the button set up to launch the report
• by downloading the required HTML files from email or from a network folder and opening 

the main HTML page on your computer

You cannot update an HTML report with new data.

Step to View an HTML Report on a Web Page
• Click the button on the Web page that launches the report. 

Tip
• Save the report to a folder called my report to keep all related files together.

Steps to View an HTML Report
1. Copy all the HTML report files from email or the network folder where they are located. 
2. Open the main HTML page.

Example: C:\Report1\index.htm
You can open the file by
• double-clicking it in Windows Explorer
• using the Run command
• starting your Web browser first, then indicating the location and name of the main 

HTML page.

More Info

Note
• Printing capabilities for HTML reports depend on the browser you are using. You cannot 

print multiple pages of an HTML report and, depending on your browser, if you specify more 
than one page in the print range, a blank page may print. For more information about 
printing HTML reports from within a browser, see your browser help.

What if ...
• You get a blank page when you print an HTML report?

You did not select the report before sending it to print. Open the HTML report in your Web 
browser and click the middle of the report. Note that there is no visual indication that the 
report is selected.

Related Topics
• "Export a Report to Other Applications" (p. 22)
• For information about creating HTML report output, see Mastering Impromptu Reports.
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Chapter 3: Print a Report

Description
Using the Print Preview command, the Page Setup command, and the Print Setup dialog box, you 
can
• preview your report, page by page, to ensure that it looks exactly the way you want it to look 

when it is printed
• set the margins, determine where headers and footers are printed, and set where to start a new 

page
• choose the printer you want to use, the page orientation, the size and the source of paper, as 

well as a whole range of options for fonts, graphics, and memory
• temporarily override the paper size and orientation you set using the Page Setup command by 

clicking Setup in the Print dialog box. What you see in the Print Setup dialog box from the 
Print dialog box is dependent on the printer you have installed

Using the Print command, you can
• choose to print all the pages or a range of pages in your report
• select the print quality of your report
• specify the number of copies you want printed and whether or not you want them collated

Note
• In addition to printing a report, you can keep a copy of your current data by using a local 

snapshots, or the Save As command (File menu). You can also use the Copy and Paste 
commands (Edit menu) to move your data to another application.

Steps
1. From the File menu, click Print.
2. Do one of the following:

• To print the entire report, click OK.
• To print the current page only, in the From and To boxes type the current page number, 

and click OK.
• To print a range of pages, in the From box type the number of the first page you want to 

print, and in the To box type the number of the last page you want to click. Click OK.
• To print more than one copy, in the Copies box type the number of copies, and click OK.
• To print to a file you specify in the Print to File dialog box, click Print to File, and click 

OK.

More Info

What if...
• You want to change how the printer is set up?

In the Print dialog box, click the Setup button. In the Printer box, select the printer and then 
click Properties.

• You want to change the orientation of your report?
In the Print dialog box, click the Setup button. In the Orientation box (Print Setup dialog 
box), select Portrait or Landscape.

• You want to print a wide list report?
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Use the Fit To Page check box (Page Setup dialog box) or the Repeat This Column on Every 
Page check box (Text Properties dialog box). See "Print a List Report With Repeating 
Columns" (p. 18) for more information.

Related Topics
• "Preview a Report" (p. 16)
• "Print a Wide List Report on a Single Page" (p. 17)

Preview a Report

Description
You can preview your report before you print it. Print Preview shows you all the parts of your 
report in their positions on the page. You can see a full report page or the actual page size and 
move to the next or previous page. You can also see one or two pages at a time, or zoom in and 
out on the report.

Steps
1. From the File menu, click Print Preview.

Impromptu shows a page view of your report. You cannot edit your report while you are in 
print preview.

2. Do one of the following:
• To preview the next or previous page, click the Next Page button to go forward a page in 

the report. Click the Prev Page button to go backward a page in the report.
The Next Page button is unavailable once you have reached the end of your report. The 
Prev Page button is unavailable when you are at the first page of your report.

• To switch from viewing a single page to viewing two pages, click the Two Pages button.
The button name changes to One Page. You can click this button to switch back to one 
page.

• To switch from full page view to actual size view, click the Zoom In button on the 
toolbar. To zoom in closer, click the Zoom In button again. The Zoom In button is 
unavailable once you have clicked it twice.

• To return to full page view, click the Zoom Out button. You may have to click it twice to 
get back to full page view. The Zoom Out button is unavailable once you are in full page 
view.

• To return to your report, Click Close.

Related Topics
• "Print a Report" (p. 15)

Set Up the Printer

Description
You can change the current printer or the print setup options. You can
• choose a different printer (if you have access to more than one printer). The Print Setup dialog 

box indicates the printer to which you are currently connected
• change the paper source for the printer you want to use. The choices you have are limited to 

your current printer selection
• temporarily override the paper size and orientation settings using the Page Setup dialog box. 

This will not change the default printer settings

Steps
1. From the File menu, click Print.
2. Click Setup.
3. In the Print Setup dialog box, do one or more of the following:
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• To select a printer from the list, select the printer name in the Name box.
Note: Only installed printers appear in the list.
• To temporarily override the specified paper size, select the paper size in the Size box.
• To specify a paper source, select the paper source from the Source box.
• To temporarily override the specified orientation of the report, click either the Portrait or 

Landscape option button from the Orientation box.
4. Click OK.

Impromptu saves your new printer settings (except for changes to the paper size and 
orientation) and returns you to the Print dialog box.

5. Do one of the following:
• If you want to print based on the settings in the Print Setup dialog box, click OK.
• If you want to save the new printer setting in the Print Setup dialog box, but you do not 

want to print, click Cancel.

More Info

Notes
• The default printer is always the printer you have selected as the default printer in the 

Windows Printers settings.
• Your report can exceed the paper size supported by your printer. To print a wide list report, 

see "Print a Wide List Report on a Single Page" (p. 17).
• List reports and crosstab reports print on multiple pages; other reports are clipped. For 

example, if the list report contains more columns than can fit on a single page, additional 
columns print on the next page unless you've set the Fit to Page option (Page Setup dialog 
box).

Related Topics
• "Print a List Report With Repeating Columns" (p. 18)
• "Print a Report" (p. 15)

Print a Wide List Report on a Single Page

Description
If you have a wide list report with many columns, you can automatically scale it down to a single 
page. This allows you to keep information together on one page. As a result, your report is easier 
to understand.

Steps
1. From the File menu, click Page Setup.
2. In the List Frames box, select the Fit to Page check box.
3. Click OK.

More Info

Notes
• Fit To Page does not affect the Page Layout view or Screen Layout view of a report.
• Fit To Page scales down a wide list report while maintaining the horizontal/vertical ratio. 
• Fit To Page should not be used with the Repeat This Column on Every Page option.
• Fit To Page has no affect on how Impromptu Web Reports displays your report in PDF 

format. For more information about preparing reports for Impromptu Web Reports, see 
"Prepare a Report for Impromptu Web Reports" (p. 127).

What if ...
• The Fit To Page check box is unavailable?
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You are not working on a list report. The Fit To Page check box is only available for list 
reports.

• The report is difficult to read after you select the Fit To Page check box?
The report is too wide for the Fit To Page check box to be useful. You may want to repeat a 
column on every page instead.

• Part of the list report is cut off when you preview or print the report?
The width of the list exceeds the physical page size. Select a value in the list. From the Edit 
menu, click Select Parent. From the Format menu, click Properties. Ensure that the box 
indicating width is set to Parent or is set to a specific width that is less than the physical page 
width.

Related Topics
• "Preview a Report" (p. 16)
• "Print a List Report With Repeating Columns" (p. 18)
• "Print a Report" (p. 15)

Print a List Report With Repeating Columns

Description
You can use the Repeat This Column on Every Page check box to repeat one or more columns in a 
list report on every printed page (after the page where the repeating column first appears). When a 
report is too wide for one page, the additional columns are placed on the next page to the right. 
For page 1, the next page to the right is 1b. If you make a column on page 1 the repeating column, 
it becomes the first column on page 1b.

This can be useful if your report is too wide to fit on a single page or too wide to be readable when 
scaled down using the Fit To Page option.

When you repeat columns, the context of the information is maintained, ensuring that every page 
of your printed report is easy to understand. You can resize or edit repeat columns and the 
changes are automatically applied to the original column on the page that it first appears, as well 
as to all the columns that repeat on subsequent pages.
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Example

Steps
1. Select one or more columns in your report.
2. From the Format menu, click Properties, and click the Printing tab.
3. Select the Repeat This Column On Every Page check box.
4. Click OK.

More Info

Notes
• The Repeat This Column on Every Page option does not affect the Screen Layout view of a 

report.
• The Repeat This Column on Every Page option can also be applied to the row area of a 

crosstab. It cannot be applied to either cells or columns. 

What if ...
• You want to see which columns repeat?

Select a value or column in your report. Click the Select Parent toolbar button. From the 
Format menu, click Properties and click the Printing tab.
Select Parent button 

• Columns do not repeat when you preview or print a report?
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The Fit To Page option may be enabled. From the File menu, click Page Setup and click the 
Printing tab. In the List Frames box, ensure that the Fit To Page option is cleared.

Related Topics
• "Preview a Report" (p. 16)
• "Print a Report" (p. 15)
• "Print a Wide List Report on a Single Page" (p. 17)
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One way of sharing data between an Impromptu report and another application is to save the 
report in the file format of the other application. Saving your data in another file format is one 
way to keep a permanent copy of the current data.

File Formats Available for Exporting

Save Your Report As ... To ...

HotFile (.ims)

HotFiles are used to access data from several 
databases

Use the results of your report as database tables 
in another catalog

Impromptu Query Definition (.iqd)

Transformer uses information in the .iqd file to 
retrieve the data directly from your database 
when generating data in your model. For 
information about creating a model to use in 
PowerPlay, see the documentation for 
PowerPlay Transformer.

Cognos Visualizer uses information in the .iqd 
file to retrieve the data directly from your 
database when generating a visualization. For 
information about creating a visualization to 
use in Cognos Visualizer, see the 
documentation for Cognos Visualizer.

If you save an Impromptu report that contains 
Access Security Tokens as an .iqd, Impromptu 
treats these values with special rules. The 
Access Security Tokens are: 1) 
catalog-user-profile, 2) user-name, and 3) 
user-classes. For more information, see the 
Impromptu Online help.

Create a source file for a PowerPlay 
Transformer model

Excel with Format (.xls) Analyze your data in a spreadsheet and keep 
the report formatting. You can save your 
reports in Excel 2000 format or Excel 2002 
and higher format (default).
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Related Topics
• "Attach a Report to Email" (p. 24)
• "Export a Report to Other Applications" (p. 22)
• "CSV File Format" (p. 24)

Export a Report to Other Applications

Steps
1. From the File menu, click Save As.
2. Locate the folder where you want to save the file.
3. In the File Name box, type a name for the file.
4. In the Save As Type box, select the file format you want.

• When you save a report as Excel, you can specify the version of Excel to use (p. 24).
• When you save as a dBase file, you save the data only.

The dBase field names are based on the data items listed in the Data tab (Query dialog 
box).

• When you save as a delimited ASCII file, you save the data only.
• When you save as an SQL file, you save the SQL statements that Impromptu uses to 

retrieve the data.
• When you save as a text file, you save the data and the column titles.
• When you save as an Impromptu Query Definition file, you save the formatting and the 

commands required to retrieve the data from the database.
5. If you save the report as a dBASE (.dbf), Hypertext Markup Language (.htm), or Delimited 

ASCII file (.csv), click Options to set options on how to export the file.

Delimited ASCII (.csv)

Dates are exported as YYYY-MM-DD hh:mm 
or as YYYY-MM-DD hh:mm am/pm. The latter 
format is used when <ITime> is set to 0 in the 
cerlocale.xml file.

When you use this format for a Transformer 
model, Transformer automatically identifies the 
data items in the file, and assigns them default 
names. The default names are based on the 
data item values in the file’s first record. Note 
the data item names that you are saving so you 
can assign the correct names in your model 
later.

Use an ASCII file as a source file for a 
PowerPlay Transformer model, when you do 
not have to connect to the database to retrieve 
the data for the model

XML (.xml) Use the Impromptu report in XML applications

Portable Document Format (.pdf) Create a report in printable format

Hypertext Markup Language (.htm) View a report using a browser

Data File (.dat) Analyze your data using PowerPlay

Text (.txt) Transfer the results of an Impromptu report to 
other applications that cannot import 
Impromptu reports directly

SQL (.sql) Use the SQL (Structured Query Language) 
statements that created the Impromptu report

dBASE (.dbf) Use data in your report as a dBASE database

Save Your Report As ... To ...
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6. Click Save.
Impromptu makes a copy of the existing file and stores it in the folder you selected, using the 
file name you typed and the extension that matches the new format. The original Impromptu 
version of the report or template remains open on your screen.

More Info

Notes
• Impromptu Query Definition (.iqd) files contain no security information. If the report 

contains information some users should not see, you must set up the appropriate security in 
the target Cognos application.

• Hypertext Markup Language (.htm) files and Portable Document Format (.pdf) files can be 
rendered with a Report Navigator which adds navigation links to report output. To add a 
Report Navigator, use the Navigation tab of the Report Properties dialog box.

Related Topics
• "Export a Report" (p. 21)
• "Render a Report in Excel Format" (p. 24)
• "CSV File Format" (p. 24)
• "Add Report Navigation" (p. 23)

Add Report Navigation
You can add a Report Navigator to your report output to set navigation based on one or more 
grouped columns. The columns serve as bookmarks in PDF report output and table of contents 
entries in HTML report output. 

For items to appear in the Report Navigator, the selected columns must be visible in the report. In 
addition, only grouped and associated columns are available for selection. If you do not have any 
grouped columns in your report, you cannot add columns to the Report Navigator.

A Report Navigator is recommended for multipage reports. However, if your report fits on one 
page, a Report Navigator is not required.

Steps
1. With a report open, from the Report menu, click Navigation.
2. Select the Include report navigator check box.
3. In the Available columns box, select the check box next to one or more of the grouped or 

associated columns that you want.
4. For HTML report output, specify the following HTML navigation properties that you want.

5. Click OK.
Tip: If you later want to remove all bookmarks in your report output without changing the 
settings in the Available Columns box, clear the Include report navigator check box. The 
Bookmark tab remains in the PDF report output when you view a report in Adobe Reader. 
This is expected Adobe behavior.

Related Topics
• "Create a Report" (p. 29)

Goal Action

Include a list of page numbers in the report 
navigator, which link to specific pages in the 
report body

Select the Include page numbers check box

Remove duplicate entries in the report 
navigator caused by horizontal page breaks

Select the Suppress duplicate entries check 
box
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Render a Report in Excel Format
When you export a report to Excel (p. 22), you can choose to render it as Excel 2000 or Excel 
2002 and higher. Reports rendered as Excel 2000 have limited rendering. Reports rendered as 
Excel 2002 and higher have complete rendering of report objects.

There are a number of best practises recommended when exporting reports to versions of Excel 
2002 and higher. For information about designing reports for Excel, see Mastering Impromptu 
Reports. 

Steps
1. Open a report.
2. From the Report menu, click Excel, and in the Version box, click the Excel version to use.
3. If you want to, you can include the following objects with the Excel 2002 and higher version 

by clicking the check box next to the object:
• images
• static charts
• text frames
• summary expressions

4. Click OK.

Related Topics
• "Create a Report" (p. 29)

Attach a Report to Email

Description
If you use Microsoft Mail, Exchange, or Outlook, you can send a report as an attachment to an 
email message to users who have access to the report catalog.

Step
• From the File menu, click Send.

The report appears as an attachment to a new Microsoft Mail, Exchange, or Outlook 
message.

More Info

Tip
• If your users don't have access to the report catalog, save the Report as a snapshot and then 

send the report.

Related Topics
• "Export a Report" (p. 21)

CSV File Format
You can export data as delimited text using many of the Cognos products. In PowerPlay for 
Windows, you can export data as a delimited ASCII text file (.asc). In PowerPlay Web  and 
Cognos Query,  and Impromptu and Impromptu Web Reports, you can export data as a Comma 
Separated Value file (.csv).

Delimited text format is one of the most popular export formats, because the resulting file can be 
used as an import source by many applications. The updated delimited text format used in Series 7 
ensures a high degree of compatibility in multi-language environments. It also ensures reliability 
when importing into third-party applications such as Microsoft Excel.
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Each Cognos product exports data to delimited text format in the same manner, as shown in the 
following table.

  

Related Topics
• "Export a Report" (p. 21)
• "Export a Report to Other Applications" (p. 22)

List separator The list separator specifies what character separates items in a list. Its default 
value is derived from the locale settings. The list separator selected is not 
persisted between sessions or Save As operations.

Note: In Impromptu, you can optionally change this character.

Export of 
numeric data

The decimal symbol for the locale is used, even if the format or pattern of the 
number contains an explicit decimal that differs from the locale.

The digit grouping symbol (the symbol used to group large numbers such as 
thousands in the US locale) is not used in the CSV export.

The negative sign symbol but not the format of the locale is used. This may 
also be different than the explicit format used for that number. The negative 
symbol is always leading.

For example, for a German locale of DE_DE, a number that was formatted 
as "(765 000.45)" is exported to CSV format as "-765000,45".

Export of 
currency data

Currency values follow the same rules as numbers. The currency symbol is 
not exported.

For example, if the locale is EN_US, and the format of the number in a 
PowerPlay report is "$123,456.00", then PowerPlay exports "123456.00".

Export of 
character data

In some products, you can optionally allow quotes to be put around the text. 
This technique ensures that a text field containing the list separator (such as a 
comma) is not interpreted as multiple fields in the exported file.

Export of date 
and time data

Dates are exported in ISO format, YYYY-MM-DD 

Time is exported as ISO format, hh:mm:ss. The hour value (hh) uses the 
24-hour clock.

Note: In PowerPlay, the date is defined in the Transformer model and is 
exported as text.
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Description
Annotations describe catalog and report items that your company may already store in a 
relational database or metadata repository.

Your Impromptu administrator creates the annotation server, connects it to the annotation 
database, and distributes the server (called AnnotationServer.exe). After you copy the server to 
your computer and register it, you can open the annotations that describe the columns, 
calculations, catalog filters, and catalog prompts you use. If you don't register your annotation 
server to your computer, your annotation requests will fail.

You can open annotations in the Query dialog box, Folders dialog box, and any expression editor.

Steps to Register the Annotation Server
1. Copy the server (called AnnotationServer.exe) to your computer.
2. In Windows Explorer, double-click AnnotationServer.exe.

Your annotation server is registered on your computer.

Steps to Request Annotations
1. Open the Impromptu catalog or report that contains annotations.
2. In the Query dialog box, Folders dialog box, or any expression editor, select a data item and 

press F1.
The annotation server starts and shows the annotation information.

Tip
• To request annotations, you can also select the What's This? arrow (in the top-right corner of 

the dialog box) and then click the data item.
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Chapter 6: Create a Report

What Is a Report?
An Impromptu report is a focused answer to a business problem. It is an organized and formatted 
view of the data requested from your company database.

What Is In a Report?
A report contains
• data

Reports show data from your database. The Impromptu catalog contains all the information 
necessary for Impromptu to access and retrieve information from a relational database.
Every time you open your report, Impromptu updates it with the most recent data.

• formatting
You can enhance a report’s appearance by rearranging and aligning parts of a report, 
changing the font, applying borders and patterns, setting margins, and so on.

When you save a report, you save the information and instructions about what data to get from 
the database and how to format the report. You do not save the actual data.

How to Create a Report
You can create a report using
• the Report Wizard
• a template

Using the Welcome Dialog Box
The Welcome dialog box appears when you first start Impromptu. 

Using the Report Wizard
The Report Wizard asks what type of report you want to create, a list report or a crosstab report. 
The wizard then prompts for the title of your report, the data you want to include, and the data 
items to group (if applicable), and how you want to filter the data. The Report Wizard does the 
rest for you. 

Using Templates
A template is an incomplete report. It can contain formatting, calculations, macros, and 
placeholders. You add the appropriate data items to the template to create a report. For example, 
a template may have placeholders for a customer address.

Click ... To ...

Create a Standard Report Use the Report Wizard to help you create a list or 
crosstab report quickly and easily.

Create a Report Using a Template Create a new report using one of Impromptu's 
templates.

Open an Existing Report Open a report that you previously saved.

Take a Quick Tour Discover the possibilities available to you with 
Impromptu.
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You can use a template as a pattern for creating a report. Alternatively, you can modify an existing 
template to suit your business needs or create your own template.

Related Topics
• "Add Report Navigation" (p. 23)
• "Create a Crosstab Sub-Report" (p. 36)
• "Create Accessible Reports" (p. 36)
• "Open a Catalog" (p. 30)
• "Upgrade a Catalog or Report" (p. 31)
• "Use a Report in Another Report" (p. 35)
• "Use a Template to Quickly Create a Report" (p. 33)
• "Use the Report Wizard to Quickly Create a List Report" (p. 31)
• "Use the Report Wizard to Quickly Create a Crosstab Report" (p. 32)
• "View a Report" (p. 9)

Open a Catalog

Description
To create or run Impromptu reports, other than snapshot reports, you must first open a catalog. 
You can open a different catalog at any time during your Impromptu session, but you can open 
only one catalog at a time.

When you open a different catalog, Impromptu, by default, automatically connects the catalog to 
the appropriate database and closes any open reports.

Example
You have a catalog called Sales Results that is attached to the sales database and a catalog called 
Accounts Receivable that is attached to the accounts database. When you close the Sales Results 
catalog and open the Accounts Receivable catalog, Impromptu automatically attaches you to the 
accounts database, not to the sales database.

Steps
Note: If there is no open catalog and you are opening or creating a report using the Report 
Wizard, or creating a report using a template, you are prompted to open a catalog. Proceed to step 
2.
1. From the Catalog menu, click Open.
2. In the Open Catalog dialog box, locate the catalog and click Open.
3. If the Cognos Common Logon dialog appears, type your User ID and click Log On if you are 

using Access Manager for security. 
Otherwise, click Cancel.

4. In the Catalog Logon dialog box, select your user class from the User Class box.
5. If a catalog password is required, type it in the Password box.
6. If you have a database user ID and password, type them in the Database User ID and 

Password boxes and click OK.
If you opened the catalog from the Catalog menu, the screen is blank, but a status message 
indicates the name of the database to which you are connected.

More Info

Notes
• If you cannot open a catalog, your administrator may have it open for maintenance.
• The last user class chosen becomes the default user class for the catalog for that user.
• If you do not know your user class, see the administrator.
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Tip
• To close a catalog, click Close from the Catalog menu.
• To obtain a better view of a long list of catalogs, resize the Open Catalog dialog box.

Related Topics
• "Reporting While Disconnected From the Database" (p. 121)
• "Create a Report" (p. 29)

Upgrade a Catalog or Report

Description
If the catalog or report was created with a previous version of Impromptu, the Catalog Upgrade 
or Report Upgrade dialog box appears.

When you want to use, but not modify the catalog, and also want to continue using previous 
versions of Impromptu, click Open this Catalog as Read-Only. If you want all previous version 
catalogs to open as read-only automatically, click Open this Catalog as Read-Only and then clear 
the Show This Dialog When Opening Previous Version Catalogs check box.

When you want to view, but not modify, a report, and also want to continue using previous 
versions of Impromptu, click Open this Report as Read-Only. If you want all previous version 
reports to open as read-only automatically, click Open this Report as Read-Only and clear the 
Show This Dialog When Opening Previous Version Reports check box.

Steps to Upgrade a Catalog
1. To upgrade a catalog, click Upgrade this Catalog.

Note: If you want to upgrade all previous version catalogs automatically, click Upgrade this 
Catalog and clear the Show This Dialog When Opening Previous Version Catalogs check box.

2. Click OK.
Previous versions of Impromptu can no longer open this catalog.

Steps to Upgrade a Report
1. To upgrade a report, click Upgrade this Report.

Note: If you want to upgrade all previous version reports automatically, click Upgrade this 
Report and clear the Show This Dialog When Opening Previous Version Reports check box.

2. Click OK.
3. From the File menu, click Save.

Previous versions of Impromptu can no longer open this report.

More Info

What if ...
• You want to show the Catalog Upgrade dialog box or the Report Upgrade dialog box?

From the Tools menu, click Options. Click the Show the Catalog Upgrade Dialog Box or the 
Show the Report Upgrade Dialog Box check box.

Related Topics
• "Create a Report" (p. 29)
• "Open a Catalog" (p. 30)

Use the Report Wizard to Quickly Create a List Report

Description
The Report Wizard is the quickest and easiest way to create a list report. The Report Wizard 
prompts you for the information you need to create your report.
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Steps
1. If you just started Impromptu and the Welcome dialog box is open, click Create a Standard 

Report. Otherwise from the File menu click New, select the Simple List template, and click 
Wizard.

2. If the catalog is not open, open and log on to the catalog you want.
3. Type a title for your report, and click Next.
4. Click the List Report option button and follow the instructions in the Report Wizard.

The Report Wizard creates a list report based on the information you provide.

More Info

Notes
• The Report Wizard supports any template created with Impromptu (except the Blank 

template).
• If the catalog or report was created with a previous version of Impromptu, see "Upgrade a 

Catalog or Report" (p. 31).
• You can drag and drop only one data item at a time when working with folders in the Wizard.

What if ...
• You want to create a new report using a different catalog?

From the Catalog menu, click Close, and then create a new report. You are automatically 
prompted to select a catalog.

• You want totals inserted automatically in the list report?
Click the Automatically Generate Totals check box in the Grouping page (Report Wizard). A 
Total summary is inserted at the lowest level of detail in the report.

• You want to quickly save a report to the User Workspace folder?
Click the FastFind button in the Save As dialog box, and then save your report.

Related Topics
• "Create a Report" (p. 29)
• "Open a Catalog" (p. 30)
• "Use the Report Wizard to Quickly Create a Crosstab Report" (p. 32)

Use the Report Wizard to Quickly Create a Crosstab Report

Steps
1. If you just started Impromptu and the Welcome dialog box is open, click Create a Standard 

Report. Otherwise, click New from the File menu, select the Crosstab template, and click 
Wizard.

2. If the catalog is not open, open and log on to the catalog you want.
3. Type a title for your report, and click Next.
4. Click Crosstab Report, and follow the instructions in the Report Wizard.

The Report Wizard creates a crosstab report using the information you provide.

More Info

Notes
• You must enter one data item into the Rows area, one data item into the Columns area, and 

one data item into the Cells area of a crosstab report.
• When you add a data item to the Cells area, Impromptu automatically summarizes the item. 

For example, Sale Amount becomes Total Sale Amount, and Product becomes Count Product. 
If you drag the item from the Cells area back to the Rows or Columns area, it remains 
summarized. To return to the original data item, select the item and edit its data definition.
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• When you create a crosstab report using the Report Wizard, only three data items can be 
entered in the Cells area of the crosstab.

• BLOB columns do not appear in a crosstab report.
• You can drag and drop only one data item at a time when working with folders in the Report 

Wizard.

What if ...
• You want to create a new report using a different catalog?

From the Catalog menu, click Close, and then create a new report. You are prompted to open 
a catalog.

• You want to quickly save a report to the User Workspace folder?
Click the FastFind button in the Save As dialog box, and then save your report.

Related Topics
• "Create a Crosstab Sub-Report" (p. 36)
• "Create a Report" (p. 29)
• "Open a Catalog" (p. 30)
• "Use the Report Wizard to Quickly Create a List Report" (p. 31)

Use a Template to Quickly Create a Report

Description
Templates can save you time and effort when you create new reports. Templates are particularly 
useful when you frequently create the same type of reports. 

The template you use may contain placeholders.

Four types of placeholders can appear in a template:
• optional single-column
• optional multi-column
• required single-column
• required multi-column

You can skip or fill in optional placeholders. You must fill in required placeholders.

You can fill in a single-column placeholder with one data item from the catalog and you can fill in 
a multi-column placeholder with at least one data item from the catalog.

Example
You use a template to create mailing labels. The template contains placeholders for Contact 
Name, Contact Title, Company, Street, City, State, and Zip Code. The Contact Title is an optional 
placeholder and the Street placeholder is a multi-column placeholder. You fill in the contact's 
name, but you don't know the title for the contact person so you skip the contact title placeholder. 
To include both a street address and a suite number, you fill in the placeholder Street with two 
data items: Street and Suite Number.

Steps
1. If you just started Impromptu and the Welcome dialog box is open, click Create a Report 

Using a Template. Otherwise, click New from the File menu.
2. Select the template you want to use, and click OK.

If the current folder does not contain the template you want to use, select another folder.
If you do not have a catalog already open, the Open Catalog dialog box appears, where you 
can locate and select the catalog to use. 

3. In the Catalog box (Data tab), select one or more data items from the folders.
Data item icon 

4. Click the right arrow button to add the selected data items to the Query Data box.
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Add button 
5. Repeat steps 3 and 4 until you have added all the data items you want, and click OK.

More Info

Notes
• All required placeholders appear in bold type and must be filled in.
• When you use a template to create a crosstab report, you must fill in at least one row 

placeholder, one column placeholder, and one cell placeholder.
• Placeholders only accept data items of the same data type.

• If a placeholder accepts only one data item, the placeholder is unavailable once you fill it in.
• You can drag and drop only one data item at a time when working with folders.
• If the catalog was created with a previous version of Impromptu, see "Upgrade a Catalog or 

Report" (p. 31).
• You can only expand placeholders in the Data tab.
• Selecting the Blank template (in the New dialog box) allows a user to create a report with no 

template. Impromptu automatically creates the Blank entry in the New dialog box, there is no 
Blank template file.

Tips
• To quickly add a single data item to the Query Data box, double-click the data item in the 

Catalog box. It is automatically added to the next available placeholder of the same data type. 
If there are no available placeholders of the same data type, the data item is put at the end of 
the list.

• To quickly fill in placeholders, drag a data item from the Catalog box and drop it onto a 
placeholder in the Query Data or Placeholders box (Report Wizard). The placeholder accepts 
the data item if it is of the same data type. If the placeholder is of a different data type than 
the data item, the data item fills the first available placeholder of the same data type. If no 
placeholders are of the same data type, the data item is put at the end of the list.

What if ...
• You want to use the same template with a different catalog?

From the Catalog menu, click Close and then create a new report.
• No data appears in your report after you have selected the data items in the Query dialog 

box?
You are using the Blank template. This template is for creating customized reports. Select a 
different template.

• The data item you add to the Query Data box is appended to the end of the placeholder list 
instead of filling in a placeholder?
There was no available placeholder of the same data type as the data item. This data item 
appears in the report.

• You want to remove a data item from a placeholder?
Select the data item in the placeholder and click Remove.

• You want to quickly save a report to the User Workspace folder?
Click the FastFind button in the Save As dialog box and then save your report.
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Related Topics
• "Create a Report" (p. 29)
• "Apply a Template to an Existing Report" (p. 75)

Import a Query from Cognos Query

Description
You can import a query from Cognos Query using the default template as set in the File Locations 
tab of the Options dialog box.

You can only import queries from Cognos Query version 6.0 and above. When you import a 
query, a log file called CognosQueryImport.log is created. To set the location of this log file, 
specify a folder in the Cognos Query Log File Location box in the File Locations tab of the 
Options dialog box.

Tips
• To avoid confusion when importing Cognos Query (.cq) files, select a catalog that was created 

from the same Architect package that the query was created with.
• To set the title of the report from the imported .cq file, ensure that the default template has 

Text Frame named "Title".
• To control the format of the report resulting from the imported .cq file, change the default 

template for Impromptu or change the primary frame for the default template. All the 
calculations and columns from the default template will be added to the primary frame of the 
default template.

Steps
1. Open Impromptu.
2. From the Tools menu, click Import Cognos Query.

The Import Cognos Query dialog box appears.
3. In the Cognos Query Filename box, specify the Cognos Query file (*.cq) to import into 

Impromptu and click Open.
4. In the Catalog Location box, specify file name of the catalog and click Open.

The file name of the catalog must match the name specified in the Cognos Query file. For 
example, if the query file contains the entry catalog=salesdb, then the catalog file name must 
be salesdb.cat.

5. Click Import.
When the query is successfully imported, a dialog box appears that shows the number and 
type of information messages generated and that prompts you to open the import log file.

6. View your Impromptu report.

Related Topics
• "Drill Through to Cognos Query" (p. 125)

Use a Report in Another Report

Description
Like HotFiles, columns and tables from Impromptu reports can be added as data items to another 
report. You can use any Impromptu report (except crosstabs) as a data source for another report 
as long as both reports are from the same catalog.

Reusing reports was introduced to support stored procedures as a second report is required to 
apply formatting to the data returned from the database. However, reusing reports need not be 
limited to stored procedures.

Note: You can only use a stored procedure report in another report if it has been run at least once 
and it returns a result set.
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Reusing reports saves you time when building queries, but may cost processing time because the 
result set of the reused report is locally cached when you execute the current query.

Steps
1. Open a new report or an existing report.
2. Open the Query dialog box and click the Data tab.
3. In the Data Source box, click HotFile and then browse to directory containing the report to 

reuse.
4. Click OK.

The report to reuse is shown in the Report Directory box.
5. Double-click the report folder to expand it and then select the data items for the current 

report.

Related Topics
• "Create a Report" (p. 29)

Create a Crosstab Sub-Report

Description
Impromptu supports crosstab sub-reports. You can have a main query and several crosstab 
sub-reports in the same report.

You can convert list frame sub-reports to crosstab sub-reports the same way you convert list 
frames to crosstabs: pivot a column and click the Build Crosstab button in the Query dialog box.

You can't drag crosstab sub-report columns into another crosstab. Other drag-and-drop actions 
are allowed, including dragging columns into the same crosstab sub-report or dragging columns 
from another frame into the crosstab sub-report.

You can only link the crosstab sub-report query to the main query in the crosstab detail and 
crosstab summary filters.

Steps
1. Open a report that has at least one query.
2. From the Insert menu, click Sub-Report and then click Crosstab Frame to add a new crosstab 

sub-report.

Related Topics
• "Create a Report" (p. 29)
• "Use the Report Wizard to Quickly Create a Crosstab Report" (p. 32)

Create Accessible Reports
Cognos is committed to assisting people with disabilities, and promotes initiatives that make 
workplaces and technologies accessible. For example, Cognos Series 7 provides a report-reading 
solution for accessibility. This report-reading solution is currently available in English. In addition 
to the English report-reading solution, the Upfront Accessible theme can be read in English and 
French.

To create reports accessible to disabled users, you must enable accessibility in Configuration 
Manager. There are also certain design considerations that you must apply when creating 
accessible reports. For more information, see the Impromptu Administration Guide.

Note
• PDF documents that support software accessibility guidelines contain additional markup 

information that increases the size of the PDF file produced and, as a result, may impact 
performance. For more information about performance and accessibility, see the Planning 
Advanced Installations Guide.
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Related Topics
• "Create a Report" (p. 29)

Retrieve Data from the Database
When you open a report or add data to a report, Impromptu automatically goes to the database 
and retrieves the data you require. You can turn automatic data retrieval off and manually retrieve 
data to improve performance.

Example
You are working with a large database. You want to re-order the report columns without waiting 
for Impromptu to retrieve the data each time you move one column. You turn the automatic data 
retrieval off, and re-order the columns in your report. Once you have finished, you manually 
retrieve the data from the database.

Steps
1. If automatic data retrieval is on, click Query from the Report menu and click the Access tab.
2. In the Query Options box, clear the Automatically Retrieve Data check box and click OK.
3. From the Report menu, click Retrieve.

Impromptu updates the data.

More Info

Note
• Impromptu cycles through three steps when retrieving data. First, Impromptu prepares the 

data. Next, Impromptu scans the data for the best fit, and lastly Impromptu generates the 
report. 

Tips
• You can also turn off automatic data retrieval by clicking the Auto Retrieve button. When the 

button is not depressed, Auto Retrieve is turned off.
• To add the Auto Retrieve button to the toolbar, click Toolbars from the Tools menu. From the 

Categories box, select Report. Click and drag the Auto Retrieve button onto the toolbar.

What if ...
• You want to cancel data retrieval?

The status line reflects the processes that Impromptu cycles through when retrieving data. 
When canceling a query is possible, the status line includes both a button on the left that lets 
you cancel the query, and a message stating that you can cancel the query by pressing the Esc 
key.

Related Topics
• "Add or Remove Data" (p. 39)

Multiple Instances and Versions of Impromptu
You can open multiple instances of Impromptu, each operating independently of each other. Each 
instance can open the same catalog (or a different one). To avoid conflicts between instances using 
the same catalog, make changes to the catalog using the first instance of Impromptu that accesses 
it. When you open Impromptu, it recalls custom settings, such as toolbars and file locations, from 
the most recently closed instance.

You can also install multiple versions of Impromptu on your computer at the same time. For 
example, you can install Impromptu 7.4 and an earlier version of Impromptu, or Impromptu 7.4 
and a current or earlier OEM version of Impromptu. Use multiple versions of Impromptu to keep 
your existing version and test a newer version at the same time.

The following change has been made to Impromptu to handle multiple versions.
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Configuration Settings
Impromptu stores product configuration information in Cern.ini in the Bin folder where 
Impromptu is installed. The exception is database connection information which remains in 
Cognos.ini. In previous versions, information maintained in the Cognos.ini file could be 
overwritten by newly installed versions.

Related Topics
• "Change the Number of Instances of Impromptu" (p. 38)

Change the Number of Instances of Impromptu

Description
By default, you can open multiple instances of Impromptu. With Impromptu set to multiple 
instance you can have reports from two different catalogs open at once. You can also execute 
more than one query at a time.

However, you may want to set Impromptu to single instance. For example, if you are running 
previous versions of macros that haven't been updated.

Ensure you have closed all instances of Impromptu before changing this setting.

Steps
1. Close all instances of Impromptu.
2. From the Start menu, click Run.

The Run dialog box appears.
3. To switch to single instance, in the Open box, type "<path name>\<executable>" /SI.

- or -
To switch back to multiple instance, in the Open box, type "<path name>\<executable>" /MI.
Here are two examples:
• "C:\Program Files\Cognos\Cer3\ImpUser.exe" /SI

Switches to single instance for Impromptu User
• "C:\Program Files\Cognos\Cer3\ImpAdmin.exe" /MI

Switches to multiple instance for Impromptu Admin
Note: If you didn't install to the default location, type your path in the Open box.

4. Click OK.
Now you can open the number of instances of Impromptu you want.

Related Topics
• "Multiple Instances and Versions of Impromptu" (p. 37)
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By default, when you add data items to a report, Impromptu adds them to the query and 
automatically marks them for insertion in the open report. You can add data items to a query 
without showing them in a report. This enables you to use data items in calculations and filters 
without them appearing in the report.

Each time you make changes to a report, Impromptu automatically retrieves the data you require 
from the database. To save time when adding or removing data from a report, you can turn 
automatic data retrieval off. For more information, see "Retrieve Data from the 
Database" (p. 37).

What You Can Do
Within a report, you can
• add data items, calculations, and summary operations
• sort, group, and filter data to create concise and meaningful reports
• edit the names or definitions of data items, calculations, and summary operations to make 

them more relevant

Related Topics
• "Add Data to an Existing Report" (p. 39)
• "Remove Data from a Report" (p. 40)
• "Group, Sort, or Associate Data in a Report" (p. 43)

Add Data to an Existing Report

Description
You can select data to include in a report at any time.

Example
You have a report that provides information on your customers. To include information about 
how they pay for their purchases, you add a data item called Payment Method.

Steps
1. From the Insert menu, click Data.
2. Click the mouse button at the position where you want to insert data.

Impromptu shows the Data tab (Query dialog box).
3. In the Data Source box, do one of the following:

• To insert data from the catalog, click Catalog.
• To insert data from a HotFile or another report, click HotFile.

4. Double-click the folders to open or close them.
5. Double-click each data item you want to add.
6. Repeat steps 4 and 5 until you add all the data items you want to add to your query.

By default, the new data items are marked for insertion into the report. A data item that is 
marked for insertion is identified by the following icon in the Query Data box:
Marked Data icon 

7. Click OK.
Impromptu inserts the data items that are marked for insertion into the report.
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More Info

Notes
• If you insert data into a text frame, Impromptu adds it at the beginning of the text frame in 

the order the data items appear in the Query Data box.
• If you insert data into a form frame, Impromptu adds it a the position where you clicked the 

mouse button.
• If you insert data into a list frame, Impromptu adds it a the position indicated by the 

highlighting.
• If you insert data into chart frame, Impromptu adds it into the list of data items for the chart 

frame.
To add the new data items, click Properties from the Format menu and click the Data tab 
(Format dialog box). Select a data item in the Query Data box and depending on where you 
want the data item to appear, click the add arrow next to the Primary Axis, Secondary Axis, 
or Measure(s) box. The data item appears in the Chart Data box.

• If the space between two adjacent columns is highlighted, or if a data cell is highlighted, then 
Impromptu adds the data item as a new column.

• If a data cell in the group header or footer is highlighted, then Impromptu adds the data item 
to the header or footer.

• If you position the pointer over a header or footer, then Impromptu adds the data item to that 
header or footer.

• If you insert a large amount of data into a text frame, set the height of the frame to size 
dynamically so that the text frame spans pages when the text exceeds a single page.

Tip
• To quickly add data items to a report, click the Data button and click the report.

Data button 

Related Topics
• "Add or Remove Data" (p. 39)

Remove Data from a Report

Description
You can remove data items from a report or from the report query. When you remove data items 
from the report, it is still available in the query. You can add the data item from the query back 
into the report at any time.

If you remove a data item from the report query, you have to add it back into the query and 
retrieve the data again to show the data in the report at a later time.

Example
You remove simple calculations such as totals that become redundant once you create more 
complex calculations, such as totals by branch and salesperson.

Steps to Remove Data from a Report
1. Select the data item.
2. From the Edit menu, click Delete.

Note: You can also use the Cut command (Edit menu) to remove a data item from a report.

Steps to Remove Data from a Report Query
1. From the Report menu, click Query, and click the Data tab.
2. Select the data item you want to remove from the Query Data box.
3. Click the Remove left-arrow button and click OK.

Remove button 
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More Info

What if ...
• You change your mind and want to restore the data item to the report?

Click the Undo button on the toolbar.
Undo button 

• You deleted a column from your report, but it still appears in the Query Data box of the 
Query dialog box?
This column is retrieved from the database every time you open your report, but it is not 
included in the report. To include this column in your report, see "Add Data to an Existing 
Report" (p. 39).

Related Topics
• "Add or Remove Data" (p. 39)
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Chapter 8: Group, Sort, or Associate Data in a 
Report

When you group data, Impromptu sorts the data item you are grouping and removes duplicate 
values. By associating a grouped data item to another data item, you can eliminate duplicate 
information from your report.

What You Can Do
You can
• define one or more data items in your report as grouped data items
• add group headers and footers
• change the grouping order for the grouped items
• generate summaries, such as subtotals, at each group level
• associate a grouped data item with another data item
• search for a specific data item

Associating Grouped Data Items
You can associate a grouped data item with any other data item that has a one-to-one relationship 
with that grouped data item.

Examples
You open an ungrouped report.

You group data by Customer Name so that you can easily view your data by customer. The 
customer names are sorted and the Customer Name appears once for all the entries in that group.

You suppress duplicate Customer Numbers by declaring Customer Number as an associated data 
item.
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Grouping and Sorting
Impromptu sorts grouped data by default. You must remove grouping before you can remove 
sorting.

You can sort on an associated data item, an ungrouped, or an unassociated data item at any time 
using the Sort tab (Query dialog box, Report menu).

Examples
You create a report with two data items: Customer Number and Customer Name. You group 
Customer Name. Impromptu sorts this grouped data by default. You then associate Customer 
Number to Customer Name, and sort Customer Number in descending order. Impromptu 
overrides the default sort on Customer Name and instead sorts on Customer Number in 
descending order. The default sort on Customer Name is lost.

If you group on Customer Name and you have the Order Number data item in the query, you can 
sort in descending order by Order Number. Impromptu sorts Order Number in descending order 
for each grouping of Customer Name. Customer Name, by default, is sorted alphabetically.

Note
• Each time you make changes to a report, Impromptu automatically retrieves the data you 

require from the database.

Tip
• To save time when you group or sort data in a report, you can turn automatic data retrieval 

off. For more information, see Retrieve Data from the Database.

Related Topics
• "Associate Data to a Grouped Data Item" (p. 47)
• "Group Data" (p. 45)
• "Sort Data" (p. 46)
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Group Data

Description
You can organize your report by grouping on one or more data items.

Example

Steps
1. From the Report menu, click Query, and click the Group tab.

Note: the Group tab is not available for crosstab reports. Crosstab reports are grouped 
automatically.

2. In the Group Order box, select the data items that you want to group.
3. Click Group.

A black bar across the top of the data icon indicates a grouped data item.
Grouped data item
Note: The grouping priority of data is set by the order of the grouped data items in the Group 
Order box.

4. Click OK.

More Info

Notes
• When you group data, and grouping is done on your computer rather than by the database, 

text BLOBs disappear from the report.
• The Group button is unavailable if you ctrl-click more than one sub-report frame. To find out 

which frames in your report are sub-report frames, from the View menu click Boundary Lines.
• Impromptu groups crosstab reports automatically. All data items in the rows and columns are 

grouped, and data items in the cells are associated with the lowest-level data item in the 
columns.

Tips
• To quickly group one or more data items, select the data items in the order that you want 

them grouped and click the Group button on the toolbar.
Group button 
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• To change the group order, drag the grouped data items up or down in the Group Order box 
(Query dialog box) or click the Group and Associate buttons on the Group tab (Query dialog 
box, Report menu).

What if ...
• You want to ungroup a data item in a report?

Double-click the data item in the Group Order box that you want to remove from the group 
and click OK.

• You want to quickly remove all groups from a report?
Press Esc to ensure nothing is selected in your report, click the Group button on the toolbar, 
and confirm that you want to delete all group items.

Related Topics
• "Group, Sort, or Associate Data in a Report" (p. 43)

Sort Data

Description
By default, Impromptu does not sort data unless you sort or group the data item. You can sort 
data by
• characters in ascending order (a to z) or descending order (z to a)
• numbers in ascending order (0 to 10) or descending order (10 to 0)
• dates, from the earliest to the latest date (1995 to 1999) or from the latest to the earliest date 

(1999 to 1995)

Example
To make your report easier to understand, you sort on Customer Name in ascending order to list 
the customers in alphabetical order from A to Z.

Steps
1. From the Report menu, click Query and click the Sort tab.
2. Select one or more data items.
3. Click Ascending or Descending to specify the sort order.

A small Ascending or Descending icon appears beside the data item you want to sort.
Ascending icon 
Descending icon 
Note: The order of the data items in the Sort Order box determines the sort priority of the 
data items.

4. Click OK.

More Info

Note
• The Sort Ascending and Sort Descending buttons are unavailable if you ctrl-click more than 

one sub-report frame. To find out which frames in your report are sub-report frames, from the 
View menu click Boundary Lines.

Tips
• To quickly sort data in ascending order, select a data item and click the Sort Ascending button 

on the toolbar.
Sort Ascending button 

• To quickly sort data in descending order, select a data item and click the Sort Descending 
button on the toolbar.
Sort Descending button 
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What if ...
• You don’t want to sort certain data items?

From the Report menu, click Query, and click the Sort tab. In the Sort Order box, select the 
data items that you don't want to sort, click Don’t Sort and click OK.

• You want to quickly clear all sorting from data items?
Press Esc to ensure nothing is selected in your report, click the Sort Ascending button or the 
Sort Descending button, and confirm that you want to delete all sorting from items.

• The Sort Ascending or Sort Descending button is not on your toolbar?
To add a button to the toolbar, click Toolbars from the Tools menu. From the Categories box, 
select Report. Click and drag the toolbar button onto the toolbar.

Related Topics
• "Group, Sort, or Associate Data in a Report" (p. 43)

Associate Data to a Grouped Data Item

Description
You can associate one or more data items with a grouped data item. An associated data item 
should have a one-to-one relationship with the grouped data item. For example, Order No. is a 
grouped data item. For each order number, there is an Order Date. Order No. and Order Date 
have a one-to-one relationship.

You can associate a data item to a grouped data item to suppress duplicate information if you 
know that the associated data item repeats in every row of the grouped item. 

Example

Steps
1. From the Report menu, click Query and click the Group tab.
2. Select the data item you want to associate to a grouped data item.
3. Click Associate.

A black and white bar across the top of the data icon indicates an associated data item.
Associated data item 

4. Click OK.
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More Info

Notes
• When you associate a data item, the data processing takes place on your computer.
• You can only associate a column with the last grouped column in the Group Order box. If you 

want to create an association with a different column, ungroup the columns, create the 
association, and then group them again.

Related Topics
• "Group, Sort, or Associate Data in a Report" (p. 43)
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Filtering Data
A filter is a set of criteria you apply to a report to change the focus of the report. You can use a 
filter to emphasize information that is important to you by filtering out what is unnecessary. 

Example
You focus your report on the product lines that have the highest sales in Mexico. You design a 
filter for the report to show the Total Sales in 1995 for Mexico ... 

... so that it shows only sales over 100,000.

What You Can Do
Use filters to retrieve data
• based on a data item in the report or on any data item in the catalog. For example, you can 

create a customer mailing list that shows just mail order customers.
• that falls between a range. For example, you can retrieve all the sales data that was collected 

between January and June of last year.
• based on summarized information. For example, you can retrieve information about branches 

with total sales exceeding $3,000.
• based on a previously calculated data item in the report or in the catalog. For example, you 

can retrieve information about product sales based on a complex exchange rate calculated in 
the catalog.

• based on a prompt that asks you to select the values on which to filter the report when you 
open or run the report.

Each time you filter data in a report, Impromptu automatically retrieves the data you require from 
the database. To save time when filtering data in a report, you can turn automatic data retrieval 
off. For more information, see "Retrieve Data from the Database" (p. 37).

Finding Specific Data
You can find the next occurrence of a specified value in your report. For example, you use a filter 
to find the next occurrence of "Los Angeles" in a customer address list, then the next, and so on. 
This is useful when you want to locate a specific value without removing data from the report.
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Related Topics
• "Filter a Report Using a Filter Stored in the Catalog" (p. 52)
• "Filter Using Crosstab Titles" (p. 53)
• "Find Specific Data in a Report" (p. 54)
• "Quickly Filter Data Using the Filter Button" (p. 50)
• "Quickly Filter Data Using the Filter Drop-down Button" (p. 51)

Quickly Filter Data Using the Filter Button

Description
You can quickly filter the data in a report by selecting one or more values and clicking the Filter 
button on the toolbar.

When you select values from the same row, such as Environmental Line and Telephone Sales, your 
report shows only the data that contains both of these values. When you select values from the 
same column, such as Telephone Sales and Mail Sales, your report shows data that contains either 
of these values.

Example
You have a report that lists the Product and Price. You select tent in the Product column and $500 
in the Price column and click the Filter button. The report shows only tents with a price of $500.

Steps
1. Select one or more values in the report.
2. Click the Filter button.

Filter button 
Impromptu retrieves only the data based on the values you selected.

More Info

Notes
• You can use
• the Filter button on the toolbar to eliminate rows based on values from one or more columns 

in the existing report
• the Filter drop-down button on the toolbar to define a filter
• a predefined catalog condition that you access from the Filter tab (Query dialog box, Report 

menu)
• the Filter tab (Query dialog box, Report menu) to create complex expressions
• You can also define a filter using the Report Wizard or the Filter drop-down button. For 

information about using the filter drop-down button, see "Quickly Filter Data Using the Filter 
Drop-down Button" (p. 51).

• The Filter button is unavailable if you Ctrl+click more than one sub-report frame. To find out 
which frames in your report are sub-report frames, from the View menu click Boundary Lines.

What if ...
• You want to remove all filters from a report?

Press Esc to ensure that nothing is selected in your report, click the Filter button on the 
toolbar, and confirm that you want to delete the existing filters.

Related Topics
• "Filter or Find Data" (p. 49)
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Quickly Filter Data Using the Filter Drop-down Button

Description
You can quickly filter the data in a report by selecting one or more values in a report and using the 
Filter drop-down button.

Example
You have a report that lists Customer Name, Order Date and Total Sales. You click the Filter 
drop-down button and select Between to filter the report so that it shows only the sales that took 
place within the last six months.

Steps
1. Select one or more values in a column.
2. Click the Filter drop-down button. A drop-down menu appears.

3. Select a filter operator from the drop-down menu.
• To filter on the selected values, click In.
• To filter out the selected values, click Not In.
• To filter the selection on a given range, click Between.
• To filter out the selection on a given range, click Not Between.
• To filter the selection based on one or more values, click an operator such as =, <, < , <=, , 

=.
Note: The contents of the Filter drop-down menu vary depending on the selection you made 
in step 1.

4. Position the cursor over the arrow that appears at the right of the drop-down menu. A fly-out 
menu appears.

5. From the fly-out menu that lists available options, do one of the following:
• To filter a report on one or more data items currently highlighted, click Selection.
• To enter one or more numbers upon which to filter, click Number.
• To select from a list of values upon which to filter, click Select Values.
• To enter one or more text strings upon which to filter, click String.
• To enter one or more dates upon which to filter, click Date.
• To enter one or more times upon which to filter, click Time.
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• To enter a date and time variable upon which to filter, click Date-time.
• To enter one or more intervals upon which to filter, click Interval.
Note: The contents of the Filter fly-out menu vary depending on the selection you made in 
step 1.

6. If you chose
• Selection, the filter is automatically applied to the report
• Select Values, the Select Values dialog box appears, where you can choose from all the 

values for the selected data item
• any of the other options, the Enter Values dialog box appears, where you can enter or 

select the required value or values and click OK

More Info

Notes
• You can also define a filter by using simply the Filter button. For information about using the 

Filter button, see "Quickly Filter Data Using the Filter Button" (p. 50). 
• The Filter button is unavailable if you ctrl-click more than one sub-report frame. To find out 

which frames in your report are sub-report frames, from the View menu click Boundary Lines.

Tips
• To select two or more data items not found next to each other, select one data item and 

Ctrl+click to select the other data items.
• To remove all filters from a report, press Esc to ensure that nothing is selected in the report, 

click the Filter button on the toolbar, and confirm that you want to delete existing filters.

What if ...
• You only see Filter Definition when you click the Filter drop-down button?

Nothing in your report is selected, you have selected an entire column, or you have selected 
values from different columns upon which to filter. 
You can use Filter Definition to create a custom filter.

• Your report data disappears when you filter between two values you have entered manually?
The first number you entered in the Enter Values dialog box is greater than the second 
number. Ensure that the first number is less than the second number.

Related Topics
• "Filter or Find Data" (p. 49)

Filter a Report Using a Filter Stored in the Catalog

Description
You can filter a report using a predefined filter in the catalog. A predefined filter is a condition 
created by your administrator or someone else in your company, and stored in the catalog. When 
you use a predefined filter, Impromptu retrieves the information that meets the criteria expressed 
by this filter condition. Predefined filters save you time when you filter a report, because they 
define frequently-used or complex expressions. 

Filter conditions appear with the other data items in the catalog. You can recognize a filter 
condition by the filter symbol in front of its name. 

Filter symbol 

Example
You open a report called Order Details that lists Customer Name, Order Number, Order Date, 
and Closed Date. You want a list of all the sales that were not closed on time so that you can 
determine the reasons for the delays. From the catalog, select a predefined filter condition called 
Sales Closed Late.
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Steps
1. From the Report menu, click Query and click the Filter tab.
2. In the Available Components box, double-click Catalog Columns.
3. In the Catalog dialog box, double-click the folders until you locate the required predefined 

filter condition.
A filter symbol in front of the filter name identifies a predefined filter condition. 
Filter symbol 

4. Select the filter condition and click OK.
The selected filter condition appears in the Filter Definition box. You can use the filter 
condition on its own or you can add to it.

5. Click OK.

More Info

Notes
• You can retrieve unique rows of data by clicking the Eliminate Duplicate Rows check box in 

the Filter tab (Query dialog box, Report menu) to filter out repetitive information in the 
database.

• You can run a report without its filter by clicking the Suspend the Filter check box in the Filter 
tab (Query dialog box, Report menu) to retrieve data for your report without applying a filter.

What if ...
• You want to remove all filters from a report?

Press Esc to ensure that nothing is selected in your report, click the Filter button on the 
toolbar, and confirm that you want to delete the existing filters.

Related Topics
• "Filter or Find Data" (p. 49)

Filter Using Crosstab Titles

Description
You can select a crosstab title and create a filter for it using the Filter button.

If you selected a crosstab column title when you created a filter, the filter is applied as a detail 
filter. If you selected a crosstab cell when you created a filter, the filter is applied as a crosstab 
detail filter or the crosstab summary filter, depending on whether the selected cell shows detail or 
summary values.

The Filter button is available if all of the following conditions are true:
• All selected titles are titles for columns that contain data from the database, not metadata.

In the example below, you can use the Filter button on the Camping Chain title but not on the 
Product Type title, because the Camping Chain column contains data from the database (from 
the Customer Type table) while the Product Type column is metadata.

• All selected titles belong to the same layer in the column titles.
In example below, you can use the Filter button on both the Fresh Air Co 1 and 2 titles 
together, but not on the Camping Chain and Fresh Air Co 1 titles together because they do 
not belong to the same layer.

• Only crosstab titles are selected.
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Steps
1. Open a crosstab report.
2. Select the crosstab titles you want.
3. Click the Filter button and create your filter.

Related Topics
• "Create a Crosstab Sub-Report" (p. 36)
• "Filter or Find Data" (p. 49)

Find Specific Data in a Report

Description
You can quickly find a specific value in your report when you need to locate an individual record.

Example
You have a multi-page report that details customer names and mailing addresses. You want to 
locate each occurrence of "Los Angeles" without removing the rest of the data from the report. 
You find the first occurrence of "Los Angeles", and then move to the next occurrence using the 
Find Next command.

If you want to search across the entire report, ensure that your report is in Screen Layout view. If 
your report is in Page Layout view, Impromptu searches only the current page of the report.

Steps
1. Select a value in a list.

Note: If you do not see the value you want, select any value to open the Find dialog box.
2. From the Edit menu, click Find.

If you are in Page Layout view, the Edit menu command is Find (on this page).
3. In the Find What box, type the value you want to find.
4. Do any of the following:

• If you want the value in the Find What box to match whole words only, click the Match 
Whole Word Only check box.

• If you want to match the case of the value in the Find What box, click the Match Case 
check box.

5. Click the Up or Down option button to determine the direction of the search.
6. Click Find Next.

Each time you repeat step 6 or use the Find Next command (Edit menu), Impromptu scrolls 
through the report, finding the next occurrence of the specified value.

Note
• To search an entire report, ensure that you are in Screen Layout view. In Page Layout view, 

your search is limited to the current page.
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Related Topics
• "Filter or Find Data" (p. 49)

Copy, Cut, and Paste in the Expression Editor
You can cut, copy, and paste expressions from one expression editor and paste them into another. 
This is a convenient way to generate expressions and is useful when you create filters for reports. 
You can copy a report filter from one source report and paste it into other reports, with changes if 
required. For example, you can cut a filter from the Filter Definition box of the Filter tab (Query 
dialog box) and paste it into the Expression box of the Calculation Definition dialog box.

Select an expression and then cut, copy, and paste using the standard Windows shortcuts, or using 
a right-click menu.

You can copy and paste text from other applications into a constant value component such as 
character strings or dates. However, not all expression components can be copied and pasted into 
various expression editors. When it is inappropriate to paste, the Paste command is unavailable.

Note: If you paste a reference to a column into the data definition of another column, using a 
database that doesn't contain the first column, the query will fail when you execute it.
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Chapter 10: Work with Summaries

Reports frequently require a summary of the data. With Impromptu, you can add summary data 
items to your report. For example, you can add a Total Sales Amount or a Running Total for 
Orders. 

While it is more efficient to add a summary data item when you create the query, you can also add 
a summary after you run the report.

What is a Summary?
A summary is a predefined calculation that takes one or more values, performs an operation on 
these values, and returns a value that summarizes the data. The summary always identifies the 
type of summary, such as total, and the name of the data item that you want to summarize. For 
example, Total (Sale Amount), Average (Product Margin). Summaries are also called aggregates.

Types of Summaries
You can create both
• simple summaries
• complex summaries

Simple Summaries
You create simple summary expressions using the Summary button.

Summary button 

When you click the Summary button (Query dialog box) or Ctrl+click the Total toolbar button, 
the Summary dialog box appears. From this dialog box you can create many summaries, including
• total
• average
• count
• maximum
• minimum
• percentage

Example
A summary with the definition Total (Sales) calculates the total sales for each branch if you put it 
in the Branch footer:

It calculates the total sales for the country if you move it to the Country footer:
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Why Use Summaries?
Use summaries to see a roll-up view of the data in your report or to perform exploratory analysis 
on the data.

Summaries and Association
A simple summary, such as total, average, and count, is a dynamic calculation that is 
automatically associated with its location. When you move a simple summary, the summary 
changes to reflects its new location. You can explicitly associate a summary with a group so that 
the value does not change when you move it from one place to another in a report. This is called 
fixed association. For example, if Total (Sales) is associated with the Country group, you can 
move the Total (Sales) to the footer of the City column and the value remains as the total sales for 
each country. 

Summaries that have fixed association include
• running-average
• running-count
• running-maximum
• running-minimum
• running-total
• standard deviation

Each time you summarize report data, Impromptu automatically retrieves the data you require 
from the database. To save time when summarizing report data, you can turn automatic data 
retrieval off. For more information, see "Retrieve Data from the Database" (p. 37).

Related Topics
• "Add a Total to a List Report" (p. 60)
• "Create a Summary" (p. 58)
• "Move a Summary to Another Location" (p. 61)
• "Use a Summary Stored in the Catalog" (p. 61)

Create a Summary

Description
You can create a summary that is a dynamic calculation that performs common calculations such 
as total, average, count, minimum, maximum, and percent of total. This type of summary is 
"smart" because it has a value that changes with its location.

Example
You want to know the total sales generated by each of your branch offices. You open a report that 
lists the Branches and the Sales for each branch. The Branch column is grouped. You create a 
summary that totals the sales for each branch.

Steps
1. From the Report menu, click Query.
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2. From the Catalog box (Data tab), select the column that you want to summarize.
3. Click the Summary button.

 Summary button 
4. In the Summary dialog box, do one of the following

Note: The buttons that are available in the Summary dialog box depend on the data type of 
the selected column. For example, if you select a column with character data, such as 
Products, the Total, Average, and Percentage buttons are not available. However, the 
Minimum, Maximum, and Count buttons are available.

5. Click OK.
The summary appears in the Query Data box of the Data tab (Query dialog box).

6. Click OK.
The summary appears in the report.
• If a summary is in the body of a list that is grouped, the summary is calculated for the 

lowest group in the list.
• If a summary is in a list group header or footer the summary is calculated for that group.
• If a summary is in a form frame with the scope of the form frame set to a group, the 

summary is calculated for that group.
• If none of the above are applicable, the summary is calculated for the entire report.
You can move the summary to different areas of your report. See "Move a Summary to 
Another Location" (p. 61).

More Info

Tip
• To see the type of frame, click Boundary Lines from the View menu. Refer to the table in the 

Steps tab if you want to know where the summary appears in the report.

Click... To Calculate...

Total

The total for the selected data items.

Minimum

The minimum value of the selected data items.

Maximum

The maximum value of the selected data items.

Average

The average of the selected data items.

Count

The count (number) of selected data items.

Percentage

The percentage of the total that the data item represents.
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Note
• When you create a summary report directly, summarization takes place on the server. When 

you create a summary report from a detail report, summarization may take place locally on 
your computer. You can also set the client/server balance (Access tab, Query dialog box) to 
limit local processing so that the summary is done using a separate database query. This is 
more efficient than processing summaries on your computer.

What if ...
• You don't want totals in a report you created using the Report Wizard?

Clear the Automatically Generate Totals check box on the Grouping page of the Report 
Wizard.

• You want to remove a summary from the report or the query?
You can remove a summary from the report or query in the same way that you remove any 
other data item. For more information, see "Remove Data from a Report" (p. 40).

Related Topics
• "Move a Summary to Another Location" (p. 61)
• "Work with Summaries" (p. 57)
• "Use a Summary Stored in the Catalog" (p. 61)

Add a Total to a List Report

Description
Reports frequently require a summary of the data. For example, you can add the Total Sales 
Amount for each Product in your list report.

Steps
1. Select a column header, a column, or a value in an existing list report.
2. Click the Total button on the toolbar.

Total button 

More Info

Note
• If there is no grouping in the report, Impromptu puts the total in the list footer. If there is 

grouping in your report, Impromptu automatically creates footers (if they do not exist 
already) for every group in the report and inserts a group total into each footer.

What if...
• You want to count the number of selected data items excluding blank cells?

Select a column header, a column, or a value in the existing list report and click the Count 
button on the toolbar.
Count button 

Related Topics
• "Work with Summaries" (p. 57)
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Use a Summary Stored in the Catalog

Description
You can use an existing summary that the administrator has stored in the catalog rather than 
creating your own summary. This saves you time and makes reporting easier. Each time you add 
the summary to a report, Impromptu calculates the value based on where you add the summary. If 
you add the same summary in three different locations (such as an overall list footer and two 
different levels of group footers), Impromptu automatically calculates the appropriate summary 
for each location.

When you select a summary from the available catalog columns for a report, the icon looks like 
this:

You can tell that this calculation is a summary when you view the icon in the Group tab (Query 
dialog box, Report menu). The icon looks like this:

To insert a catalog summary into both a list footer and a group footer, add the summary data item 
twice to the Query data (once for each location in the report that requires the summary). 

Example
You add the Average Sale Amount summary to the Query data and insert it into an overall list 
footer. Impromptu associates the summary with the list report and calculates an overall average. 

You move the Average Sale Amount summary into the Customer footer. Impromptu associates the 
summary with the Customer group and calculates the average Sale Amount for each customer.

Steps
1. From the Report menu, click Query and click the Data tab.
2. In the Catalog box, locate the summary calculation you want to use.
3. Double-click the summary calculation to add it to the Query Data box and click OK.

The summary calculation is added to your report. The summary you inserted from the catalog 
is automatically associated with its location. 

Related Topics
• "Create a Summary" (p. 58)
• "Work with Summaries" (p. 57)

Move a Summary to Another Location

Description
Some types of summaries, such as total, average, count, maximum, minimum, percentage of total, 
percentile, and rank value, are affected by their location. When you move one of these summaries 
to another location, how the summary is calculated and its associated group changes.

Example
You move a data item from the Total (Sales) column to the list footer. The move changes the value 
from the Total (Sales) for the lowest group in the report to the Total (Sales) for the whole report.

Steps
1. Select the summary that you want to move.
2. Drag and drop the summary to the new location.
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Note: By default, a summary, such as total, average, count, maximum, minimum, percentage 
of total, percentile, or rank value, is automatically associated with its location and the value 
of the summary changes when it is moved to a new location. If the association of the summary 
is not automatic, the value of the summary does not change.

Related Topics
• "Add a Total to a List Report" (p. 60)
• "Create a Summary" (p. 58)
• "Work with Summaries" (p. 57)
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Report Variables

To heighten the impact and appearance of your report, you can insert text, pictures, or other 
report variables into the header or footer of your report.

What You Can Do
You can
• add comments to an Impromptu report to clarify or stress aspects of your report.
• insert a picture. A picture can appear once or several times in a report and can be static or 

dynamic. Unlike a static picture, a dynamic picture is associated with a data item or 
calculation. The database must contain a data item that identifies the dynamic picture file. For 
example, you insert a dynamic picture of each product into your report. If the database is 
updated and the picture changes, your report will reflect this change. You can also insert static 
pictures such as a bitmap of the company logo at the top of every order. For an example of a 
report that contains both a static picture (the company logo) and a dynamic picture (the 
product picture), see the sample report Annual Product Sales supplied with Impromptu.

• use report variables to enhance your report. A report variable is a dynamic item such as the 
date, time, page number, and page count. Impromptu or your computer continually updates 
the report variables in your report. For example, you show the system date and time when the 
report is printed. Also, you include the page number and the total pages in your header or 
footer for quick reference.

Related Topics
• "Format a Report" (p. 75)
• "Insert a Report Variable" (p. 67)
• "Insert a Static Picture" (p. 64)
• "Insert Text" (p. 63)

Insert Text

Description
You can add a comment or a title to your report to make it easier to understand. A comment can 
explain the source of the report data so that other people can easily understand your report, and a 
title can clarify the purpose and content of the report.

Steps
1. From the Insert menu, click Text Frame.
2. On the report, position the pointer where you want to locate the upper-left corner of the text.
3. While holding down the mouse button, drag the mouse diagonally to size the area where your 

text will appear, and release the mouse button.
Impromptu shows a flashing I beam. 
I beam 

4. Type or insert the text you want in your report.
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More Info

Tips
• To quickly insert text, click the Text Frame button on the toolbar.

Text Frame button 
• To edit existing text, double-click the text until the flashing I-beam appears. Edit the text and 

click anywhere outside the text area.
• To have a text frame within a list frame span pages when the text exceeds a single page, set the 

height property to dynamic.

What if ...
• You want to delete the text?

Select the text so that the selection handles appear and press the Delete key.
• The text you insert repeats for every row in a list?

The active report is based on a Simple List template, or the insert pointer was placed over the 
list when you clicked to insert text. When using the Simple List template you can only add 
text to the page headers or footers of the report, or you can modify existing text in the list by 
double-clicking the text.

Related Topics
• "Insert Text, Pictures, and Other Report Variables" (p. 63)

Insert a Static Picture

Description
You can insert a picture and show any of the following image file formats that are stored in a 
location your computer can access:
• Windows bitmap file (.bmp)
• Joint Photographic Experts Group (JPEG or JPG)
• Portable Network Graphics (PNG)
• Device Independent Bitmap (DIB)

A picture can appear once or repeatedly in a report.

The picture can be static or dynamic. A dynamic picture is associated with a data item or 
calculation. The database must contain a data item that identifies the picture files.
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Example

Steps
1. From the Insert menu, click Picture Frame.
2. Position the pointer where you want to locate the upper-left corner of the picture.

Your pointer changes to the following: 

3. While holding down the mouse button, drag the mouse diagonally to size the picture, and 
then release the mouse button.
The Source tab (Picture Properties dialog box) appears.

4. Click the Load From File option button.
5. In the Load From File box, locate and select the name of the image file that you want to 

appear in the picture frame.
6. Select the Make a Copy Within the Report check box. 
7. Click OK.

More Info

Notes
• Use small footprint JPEG (Joint Photographic Experts Group) and PNG (Portable Network 

Graphics) image files for improved download performance in Web-based applications.

Tips
• To paste a picture from another application, use the Copy and Paste commands.
• To quickly insert a picture, click the Picture Frame button on the toolbar.
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Picture Frame button 

What if ...
• You want to update the picture?

Clear the Make a Copy Within the Report check box (Picture Properties dialog box)
• You want to remove a picture from your report?

Select the picture and press the Delete key.
• You want to resize a picture?

Click the picture and, while holding down the pointer over one of the handles for the selected 
picture, drag to size the picture, and then release the mouse button.

• The static picture you insert repeats for every row in a list?
The active report is based on a Simple List template, or the pointer was placed over the list 
when you clicked to insert the picture. When using the Simple List template, static pictures 
can only be added to the page header or footer, the list header or footer, or the group header 
or footer.

Related Topics
• "Insert Text, Pictures, and Other Report Variables" (p. 63)

Insert Page Numbers

Description
Number pages in your reports to provide a point of reference when you are reviewing your 
printed report.

You can
• insert page numbers into your report. For example, if you want the current page number to 

appear in the bottom-right corner of your report, you can insert the <Page Number> report 
variable into the right corner of the page footer so the page number repeats on every page.

• format page numbers in your report. For example, if you want the page number to be easier 
to read, you can make it bold, red, and 15 point size.

• remove page numbers from your report. For example, if you added a page number, and the 
final report was one page, you no longer need a page number.

Example
You set the current page number to show in the bottom-right corner of your report. You insert the 
<Page Number> report variable into the page footer so the page number repeats on every page.

Steps
1. From the Insert menu, click More Objects.
2. Select the Page Number report variable and click Insert.

Your pointer changes to the following:

3. On the report, position the pointer where you want the upper-left corner of the page number 
and drag to size the area where the page number will appear.

More Info

Notes
• Page numbers should only be inserted in the Page Layout view.
• If you insert page numbers into a list, the page numbers are inserted as a column.
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Tips
• To format page numbers, select the page number. From the Format menu, click Font, and 

select the font type, style, size, effects, and color.
• To remove the page numbers, select the page number and press the Delete key.

Related Topics
• "Insert Text, Pictures, and Other Report Variables" (p. 63)

Insert a Report Variable

Description
You can insert report variables in your report to ensure that your report contains accurate 
dynamic information such as the date, time, page number, and page count. Report variables are 
continually updated in the report by your computer or by Impromptu.

Example
You are going to print a multi-page report.To ensure that all the pages are printed, and that the 
page sequence is clear, you include the page number and the total pages in the report footer.

Steps
1. From the Insert menu, click More Objects.
2. From the Available Objects box, select the report variable you want to insert in the report.
3. Click Insert.

The pointer changes to a shape that corresponds to the report variable you are inserting.
4. On the report, position the pointer at the point where you want to locate the upper-left corner 

of the report variable, and drag to size the report variable.
Note: When you insert a running page total, the Running Page Totals dialog box appears. 
Select the column you want to use in the running page total, and click OK.

More Info

Notes
• You can cut and paste, copy and paste, and drag and drop report variables within a single 

report or between different reports.
• If you paste a running page total variable into a text frame, the name of the running page total 

variable shown in the status line changes to the name of the text frame.
For example, when you select the running page total variable inserted for Sales 2003, the 
status line shows "Running Page Total [Sales 2003]." If you paste the running page total 
variable into a text frame and select the variable, the status line shows the name of the text 
frame, not the name of the running page total variable.

• If you have not saved your report with a report name, then Impromptu uses the default report 
name (REPORT1). When you save the report and provide a name, Impromptu updates the 
report name.

• A running page total variable cannot be used in an expression or calculation.
• The system date variable is updated automatically each time you open or print a report. The 

<Date> format is based on your settings in the Data Format tab (Options dialog box, Tools 
menu).

• The system time variable updates automatically each time you open or print a report. The 
<Time> format is based on your settings in the Data Format tab (Options dialog box, Tools 
menu).

Tip
• To format a report variable, right-click the variable, and click Format. In the Format dialog 

box, click the Font tab, select the font type, style, size, effects, and color that you want and 
click OK.
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What if ...
• You want to remove a report variable?

Select it and use the Delete command (Edit menu). 
• You remove a column with a running page total variable?

The running page total variable is removed as well.
• You cannot see the running-total in a report?

From the View menu, click Page Layout.

Related Topics
• "Insert Text, Pictures, and Other Report Variables" (p. 63)
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a Report

Hiding, Showing, or Unhiding Part of a Report
You can hide, show or unhide parts of a report at different times. Hiding parts of a report does 
not remove them from the report. The hidden parts of a report no longer show, however, you can 
continue to use them.

For example, you can use the values for hidden data items in filters and calculations, and the data 
items still appear in the Data tab (Query dialog box). 

In a list report, you can hide, unhide or show
• headers and footers. This is useful when you want to concentrate on the report details and not 

view headings and summary information in headers and footers.
• individual columns. You can control the information that appears in the finished report. For 

example, you want the item Salary as the detail lines in an employee report, but you do not 
want the salaries shown when you distribute printed copies of the report to others so you hide 
the Salary data item.

Grouping Parts of a Report
You can group parts of a report so that they are treated as a single entity. This makes it much 
easier for you to show, hide, resize, or format the entire group at once without having to deal with 
the individual parts of a report one at a time. You can ungroup a grouped section at any time.

Resizing Part of a Report
You can resize part of a report to improve its overall appearance. There are several resize options 
you can use to format your report. You can use the mouse to resize areas of your reports or you 
can use the following resize options.
• Snap to Parent. You can snap a part of a report to match the size of its parent frame. For 

example, if you want to create a list that takes up the entire width and height of a page, use 
Snap to Parent.

• Dynamic Height. You can vary the height of part of a report based on the data using the 
Dynamic Height option. This option can only be used with text.

• Specify Width and Specify Height. You can set the exact width and height of a selected report 
part to meet your specific requirements. For example, you can specify a 3.5 in. x 5 in. (8.75 
cm x 12.5 cm) area in the top left area for the customer address.

• Scan Data for Best Width and Scan Data for Best Height. You can size part of a report to fit 
the data using the Scan Data for Best Width or Height options.

Related Topics
• "Group Parts of a Report" (p. 71)
• "Hide Part of a Report" (p. 70)
• "Resize Part of a Report" (p. 72)
• "Show Part of a Report" (p. 70)
• "Stack Parts of a Report" (p. 72)
• "Unhide Part of a Report" (p. 70)
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Hide Part of a Report

Description
Hiding parts of a report enables you to optimize the presentation of the report to maximize data 
analysis.

Example
You have many columns, in a list report but you want to compare the first and last columns. You 
hide all the columns in between and see the first and last columns side-by-side.

Steps
1. Select the row, column, picture, or report variable that you want to hide.
2. From the Format menu, click Hide.

More Info

Note
• Hiding any row in the detail lines of a list report hides all the detail rows.

Related Topics
• "Hide, Show, Group or Resize Parts of a Report" (p. 69)
• "Show Part of a Report" (p. 70)
• "Unhide Part of a Report" (p. 70)

Show Part of a Report

Description
Showing hidden parts of a report makes them temporarily visible, but if you unhide parts of a 
report, they are shown permanently.

Example
In a list report you have several hidden columns. You show the hidden columns so that you can 
compare the values in the hidden columns.

Step
• From the View menu, click Show Hidden.

Any hidden parts of the report are now visible.

Related Topics
• "Hide Part of a Report" (p. 70)
• "Hide, Show, Group or Resize Parts of a Report" (p. 69)
• "Unhide Part of a Report" (p. 70)

Unhide Part of a Report

Description
Unhiding parts of a report makes them permanently visible.

Example
In a list report you have three hidden columns, but you want to compare the first column with one 
of the hidden columns. You unhide the hidden column.
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Steps
1. From the View menu, click Show Hidden to show all hidden parts of a report.
2. Select the hidden row, column, picture, or report variable.
3. From the Format menu, click Show.

The part of the report you selected is no longer hidden.

More Info

What if ...
• You want to see parts of the report that are hidden? 

If you do not want to permanently change them from being hidden, click the Show Hidden 
command (View menu).

Related Topics
• "Hide Part of a Report" (p. 70)
• "Hide, Show, Group or Resize Parts of a Report" (p. 69)
• "Show Part of a Report" (p. 70)

Group Parts of a Report

Description
When you group parts of a report, aligning and formatting is applied to the entire group, not just 
the individual parts of a report.

You can align a grouped section of a report. For example, if you left-align a grouped section of a 
report, the entire group moves to the left of the report. The left-alignment is maintained even if 
you change the report page layout from landscape to portrait or vice versa. If you select parts of a 
report and align them without grouping them first, they align with each other, for example, 
Ctrl+click two text frames and then click Align Left.

Apply a pattern or border to a group to emphasize important information in the report. You can 
maintain spacing between parts of a report by grouping them and moving the group as a single 
unit.

You can remove one or more objects from a group or ungroup the entire group at any time.

Note: Grouping parts of a report is not the same as grouping data.

Steps
1. Select the parts of the report you want to group.
2. From the Format menu, click Group Objects.

More Info

Note
• You cannot group two grouped sections together. However, you can add to a group by 

dropping a new object into the group form frame and you can remove from a group by 
dragging an object out of the group form frame.

Tip
• To quickly select several parts of a report, such as a picture and a comment, Ctrl+click each 

part of the report.

What if ...
• You want to ungroup one object in a group?

Select that object and drag it outside the group form frame.
• You want to ungroup all objects in a group?

Select the group form frame and, from the Format menu, click Ungroup.
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Related Topics
• "Hide, Show, Group or Resize Parts of a Report" (p. 69)

Resize Part of a Report

Description
You can
• resize parts of a report using the mouse.
• snap a part of the report to match the size of its parent frame.
• vary the height of part of a report based on the data using the Dynamic height option. This 

option can only be used with text.
• set the exact width and height of a selected report part to meet your specific requirements.
• size part of a report to fit the data by using the Scan Data for Best Width and Scan Data for 

Best Height options.
• align the width of the header and footer in a list report to the width of the report columns.

Steps
1. Select the part of a report you want to resize.
2. From the Format menu, click Size.
3. In the box indicating height or width, do one of the following:

• To match the size of the parent frame, click Snap to Parent.
• To vary the height of text frames depending on their content, click Dynamic Height.
• To set the exact height and width of part of a report, click Specify Height and Specify 

Width, and type the height and width you want.
• To size part of a report to fit the data, click Scan Data for Best Height.
• To align the header and footer to the width of the report column, click Snap to Columns.
Note: The sizing options available depend on the type of object you select.

4. Click OK.

More Info

Note
• When you select a part of your report to resize, you will see a border with handles that you 

can drag to resize.

Related Topics
• "Hide, Show, Group or Resize Parts of a Report" (p. 69)

Stack Parts of a Report

Description
Parts of a report can be stacked on top of the other.

Example
You use your company logo as the background for an existing report. You insert the bitmap and 
size it to fill the page and then place it behind the existing report.

Steps
1. Click the part of the report you want to stack.
2. From the Format menu, click Stacking, and click one of the following.

• Click Bring Forward to move on layer forward in the stack.
• Click Send Back to move one layer back in the stack.
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• Click Bring to Front to move directly to the front of the stack.
• Click Send to Back to move directly to the back of the stack.

Related Topics
• "Hide, Show, Group or Resize Parts of a Report" (p. 69)
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Chapter 13: Format a Report

There are many things you can do to enhance the format of your reports.

You can
• assign data formats to numbers, characters, dates, times, date-times, and intervals. A data 

format applies pre-determined characteristics to the selected data items, that affect how they 
appear in your report

• customize data formats by editing the standard formats or by creating your own with the 
available format symbols.

• use conditional formats.
• change the font type, style, color, and size
• add colors, patterns, and borders to parts of a report
• resize part of a report
• apply a style to selected parts of a report
• stack text or graphics on top of each other to create special effects
• use the grid to position parts of a report

Each time you make changes to a report, Impromptu automatically retrieves the data you require 
from the database. To save time when formatting a report, you can turn automatic data retrieval 
off. For more information, see "Retrieve Data from the Database" (p. 37).

Related Topics
• "Add a Page Header or Footer" (p. 76)
• "Adjust Margins" (p. 77)
• "Align Parts of a Report" (p. 77)
• "Apply a Template to an Existing Report" (p. 75)
• "Format Data" (p. 81)
• "Insert Text, Pictures, and Other Report Variables" (p. 63)
• "Position Part of a Report Using Snap to Grid" (p. 78)

Apply a Template to an Existing Report

Description
A template contains placeholders and stores formatting information such as margin settings, page 
orientation, and font choices.

If the template you are applying contains placeholders, Impromptu tries to match each 
placeholder to a data item in your report. If a match is found, Impromptu applies the data 
definition from the placeholder to the data item. 

When you apply a different template to a report, Impromptu automatically transfers all the 
formatting from the selected template to the report. 

Example
There is a placeholder in the template with a currency format, and a data item in your report that 
is a number. They are both in the same position in the query (they are both the third item listed in 
the Query Data box in the Data tab of the Query dialog box). Impromptu applies the formatting 
from the placeholder to the data item. The data item in your report that is a number now appears 
in a currency format.
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Steps
1. From the Report menu, click Apply Template.
2. Locate the template you want and click OK.

More Info

Note
• Impromptu does not apply any grouping, sorting, or filtering from the template to your report 

except when you apply the Grouped List template or the Grouped Crosstab template.

What if ...
• You apply a template to a report that contains sub-reports?

The template is only applied to the main report. 

Related Topics
• "Format a Report" (p. 75)
• "Use a Template to Quickly Create a Report" (p. 33)

Add a Page Header or Footer

Description
A page header appears at the top of every page, and a page footer appears at the bottom of every 
page. The page header and the page footer areas are separate parts of a report.

A page header or footer can contain
• text
• pictures
• report variables
• calculations that contain summary values for the detail lines in the list

Example
You add a page header to show a company logo and a page footer to provide page numbers on 
every page.

Steps
1. From the File menu, click Page Setup and click the Page Setup tab.
2. Do one of the following:

• To insert a page header at the top of every page of the report, click Page Header.
• To insert a page footer at the bottom of every page of the report, click Page Footer.

3. Click OK.

More Info

Note
• Although you can insert page headers and footers in Screen Layout view, you can only see 

them in Page Layout view. When you print a report from Screen Layout view, the page 
headers and footers will print.
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Tips
• To add data to a page header or footer, drag and drop data from the report into the header or 

footer.
• To remove a page header or footer, clear the check mark beside the Page Header or Page 

Footer item in the Page Setup tab (Report Properties dialog box).

Related Topics
• "Format a Report" (p. 75)
• "Insert a Report Variable" (p. 67)

Adjust Margins

Description
Margins are the outer perimeters of your report. You can control how much space is on the top, 
bottom, left, and right of the report.

Example
You want to include white space on the report for writing notes. You set the left and right margins 
to 2 in. or 5 cm to provide space on either side of your report data.

Steps
1. From the File menu, click Page Setup.
2. Type values into the Margins boxes.
3. Click OK.

More Info

Tip
• To see the page margins, click Page Layout from the View menu.

Related Topics
• "Format a Report" (p. 75)

Align Parts of a Report

Steps
1. Select the parts of the report that you want to align.
2. From the Format menu, click Align.
3. In the box indicating vertical alignment, do one of the following.

• Click Align Top Edge to align the selected report parts to the top edge and specify 
whether to align them to the top edge of the selection box or the top edge of the report.

• Click Align Center to align the selected report parts to the center and specify whether to 
align them to the center of the selection box or the center of the report.

• Click Align Bottom Edge to align the selected report parts to the bottom and specify 
whether to align them to the bottom edge of the selection box or the bottom edge of the 
report.

• Click Evenly Space to space the selected report parts evenly and specify whether to align 
them to the selection box or to the report.

This option is only available when you select more than one part of a report.
4. Click the down arrow next to the box indicating horizontal alignment and do one of the 

following.
• Click Align Left Side to align the selected report parts to the left and specify whether to 

align them to the left edge of the selection box or the left edge of the report.
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• Click Align Center to align the selected report parts to the center and specify whether to 
align them to the center of the selection box or the center of the report.

• Click Align Right Side to align the selected report parts to the right and specify whether to 
align them to the right edge of the selection box or the right edge of the report.

• Click Evenly Space to space the selected report parts evenly and specify whether to align 
them to the selection box or to the report.

This option is only available when you select more than one part of a report.
5. Click OK.

More Info

Note
• You cannot align parts of a report in different group footers. For example, you cannot align a 

part of the report in a Product Type group footer with a part of the report in the Product Line 
group footer. You can, however, align parts of a report in a list header or footer to details in 
the report.

Tip
• To quickly align selected report parts, click one of these buttons on the toolbar

Align Left 
Align Right 
Align Center (Vertical) 
Align Center (Horizontal) 
Align Top 
Align Bottom 

What if ...
• You do not want to align parts of a report?

Click No Alignment in the box for the vertical or horizontal alignment. None appears in the 
box indicating that no vertical or horizontal alignment is applied.
The None option automatically appears when the selected report parts have conflicting 
alignment options. For example, if you select text in a list report and a rectangle, the None 
option appears.

Related Topics
• "Format a Report" (p. 75)

Position Part of a Report Using Snap to Grid

Description
You can position parts of a report using a hidden grid. When Snap to Grid is enabled, you can 
move report parts in half-character jumps. This enables you to align report parts with precision. 
By default, Snap to Grid is enabled.

Steps
1. From the Tools menu, click Snap to Grid.

Note: A check mark beside to the Snap to Grid command indicates that the option is selected.
2. Move a part of the report.

More Info

Tip
• To position a selected report part and maintain the current horizontal and vertical position, 

hold down the Shift key while positioning the selected report part. Impromptu moves the 
selected report part vertically or horizontally in a straight line.
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What if ...
• You want to change the spacing between the grid?

You can change the grid spacing by specifying the number of inches or centimeters between 
grid intervals. From the Tools menu, click Options, and click the General tab. Ensure that the 
Snap to Grid check box is selected. In the Grid Interval box, type the value for the spacing.

Related Topics
• "Format a Report" (p. 75)
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Description
The database from which Impromptu retrieves data for your reports contains several types of 
data—numeric, character, date, time, date-time, and interval. This data can be formatted using 
standard formats or custom formats you create. A data format applies pre-determined 
characteristics to the selected data items that affect how they appear.

You can create new data formats by editing the standard formats or by creating your own formats 
using the available format symbols. A format symbol represents a value supplied by your 
database. For example, "MMM" is a format symbol that represents the month in a 
three-character form, such as "Jan".

A variety of format settings are established when you install Windows or when you change the 
country selection. For example, the currency format can default to $ or £ depending on your 
default settings.

Steps
1. Select the columns or values that you want to change.

When you format a value, the format is applied to all the values in that column.
2. From the Format menu, click Data.
3. Select a pre-set data format or create a custom data format using the available format 

symbols. To format
• Number data, see "Numeric Format Symbols" (p. 82).
• Character data, see "Character Format Symbol" (p. 83).
• Date data, see "Date Format Symbols" (p. 83).
• Time data, see "Time Format Symbols" (p. 84).
• Date-time data, see "Date-Time Format Symbols" (p. 85).
• Interval data in days or dates, see "Interval Format Symbols" (p. 86).
You can specify different formats for positive and negative numeric values, zero values, and 
missing values.

4. Click OK.
If you specify an invalid format, Impromptu shows #FORMAT# for the selected data items.

More Info

Notes
• If you use characters in your format other than those documented as format symbols, they 

must be surrounded by quotation marks or preceded with the backward slash symbol (\).

Tips
• To quickly apply the currency format to numeric data, select a value or column, and then click 

the Currency button on the toolbar. Impromptu automatically applies the format to all values 
in the column in accordance with the default settings in the Data Format tab (Options dialog 
box, Tools menu).
Currency button 

• To quickly format columns or values, right-click the columns or values, and then click 
Format.

Related Topics
• "Justify Data" (p. 86)
Impromptu User Reference  81



Chapter 14: Format Data 
 

• "Enhance Data Display" (p. 87)
• "Using the Currency Symbol List" (p. 87)

Numeric Format Symbols

Format Symbols Description

General Shows the numeric value in the General format.

Number Shows the numeric value in the format set by the locale settings. For 
information about using the Number format, see (p. 90).

Currency Shows the numeric value with the currency symbol. For information about 
using the Currency format, see (p. 90).

0 Shows the numeric value in the number of digits indicated in the format 
and, if necessary, adds zeros to the number to comply with the format. It 
rounds the number off if the data item has more significant digits to the 
right side of the decimal than the format specifies. For example, #.00 shows 
8.9 as 8.90 and shows 8.912 as 8.91.

# Shows the numeric value in the number of digits indicated in the format but 
constrains the number of digits shown on the right of the decimal to the 
number of #s in the format. For example, ##.### shows 12.345678 as 
12.345 and shows 123.45 as 123.45.

? Shows the numeric value in the number of digits indicated in the format 
but, if necessary, adds spaces on both sides of the decimal point so that 
decimal points align. For example, ?#.0? shows 1.23 (with a space before 
the 1) and 12.3 (with a space after the 3).

. (period) Inserts a period.

, (comma) Inserts a comma.

$ Inserts the currency symbol from your locale settings. For example, ## 
###.##$ with "£" selected as the currency symbol shows as 12345.67 as 12 
345.67£.

% Shows the number as a percentage with a percent sign.

E-#
E+#
e-#
e+#

Shows the number in scientific notation. A negative sign before the 
exponent indicates a number less than one.

The number of digits in the exponent is not constrained by the number of 
#s. For example, 12,500,000,000 shows 1.25E10.

_ (underscore) Skips the width of the next format character. Use this symbol to align 
positive numbers properly in numeric formats where negative values are 
indicated by parentheses. For example, the data format 0.00_) for positive 
numbers and (0.00) for negative numbers aligns both numbers on the 
decimal point as follows.

(21753.00)

     717.00

" " Shows whatever is between the quotation marks.

' (apostrophe) Shows the symbol as entered. When you return to the Format dialog box, 
you will see a backward slash to indicate that the apostrophe has 
significance as a format.
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Character Format Symbol

Date Format Symbols

\ Shows the next character in the format. Use this symbol to treat a format 
symbol as a standard character. Enter two backward slashes to show a 
backward slash.

Format Symbols Description

Format symbol Description

General Shows the character value in the General format.

- (hyphen)
/ 
: 
space

Shows the symbol as entered.

' Shows the symbol as entered. When you return to the data formatting 
dialog box, you will see a backward slash to indicate that the apostrophe 
has significance as a format.

* Shows remaining characters in the string.

\ Shows the next character in the format. Use this symbol to treat a format 
symbol as a standard character. Enter two backward slashes to show a 
backward slash.

_ (underscore) Skips the width of the next format character. Use this symbol to align 
positive numbers properly in numeric formats where negative values are 
indicated by parentheses.

A Shows a single character, uppercase.

a Shows a single character, lowercase.

@ Shows one character, as is.

@* Shows the rest of the string, as is.

| Skips this character.

" " Shows whatever is between the quotation marks.

Format symbol Description

General Shows the date value in the format set by the locale settings.

D Shows the day of the week as one or two digits 
(1-31).

DD Shows the day of the week as two digits (01-31).

DDD Shows the day of the week as a three-letter abbreviation (Mon).

DDDD Shows the full name of the day of the week (Monday).

M Shows the month as one or two digits (1-12).

MM Shows the month as two digits (01-12).
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MMM Shows the month as a three-letter abbreviation (Jan).

MMMM Shows the full name of the month (January).

YY Shows the last two digits of the year (00-99).

YYYY Shows all four digits of the year (1900-2100).

- (hyphen)
/ 
:
space

Shows the symbol as entered.

' Shows the symbol as entered. When you return to the Format dialog box, 
you will see a backward slash to indicate that the apostrophe has 
significance as a format.

\ Shows the next character in the format. Use this symbol to treat a format 
symbol as a standard character. Enter two backward slashes to show a 
backward slash.

" " Shows whatever is between the quotation marks.

Format symbol Description

Format symbol Description

General Shows the time value in the General format.

H Shows the hour as one or two digits in 24-hour format (0-23).

If the format includes the format symbols AM/PM, am/pm, A/P, or a/p, 
then H shows the hour as one or two digits in 12-hour format (1-12).

HH Shows the hour as two digits in 24-hour format (00-23).

If the format includes the format symbols AM/PM, am/pm, A/P, or a/p, 
then HH shows the hour as two digits in 12-hour format (01-12).

M Shows the minutes as one or two digits (1-59).

MM Shows the minutes as two digits (01-59).

S Shows the seconds as one or two digits (1-59).

SS Shows the seconds as two digits (01-59).

SSS Shows the milliseconds (000-999).

AM/PM
am/pm
A/P
a/p

Shows the time in 12-hour format, followed by AM (midnight to 11:59:59 
AM) or PM (noon to 11:59:59 PM).

- (hyphen)
/  
: 
space

Shows the symbol as entered.
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Date-Time Format Symbols

' Shows the symbol as entered. When you return to the Format dialog box, 
you will see a backward slash to indicate that the apostrophe has 
significance as a format.

\ Shows the next character in the format. Use this symbol to treat a 
character that has significance as a format literally. Enter two backward 
slashes to show a backward slash.

" " Shows whatever is between the quotation marks.

Format symbol Description

Format symbol Description

General Shows the date-time value in the format set by the locale settings.

D Shows the day of the week as one or two digits (1-31).

DD Shows the day of the week as two digits (01-31).

DDD Shows the day of the week as a three-letter abbreviation (Mon).

DDDD Shows the full name of the day of the week (Monday).

M Shows the month as one or two digits (1-12).

MM Shows the month as two digits (01-12).

MMM Shows the month as a three-letter abbreviation (Jan).

MMMM Shows the full name of the month (January).

YY Shows the last two digits of the year (00-99).

YYYY Shows all four digits of the year (1900-2100).

H Shows the hour as one or two digits in 24-hour format (0-23).

If the format includes the format symbols AM/PM, am/pm, A/P, or a/p, 
then H shows the hour as one or two digits in 12-hour format (1-12).

HH Shows the hour as two digits in 24-hour format (00-23).

If the format includes the format symbols AM/PM, am/pm, A/P, or a/p, 
then HH shows the hour as two digits in 12-hour format (01-12).

M Shows the minutes as one or two digits (1-59).

MM Shows the minutes as two digits (01-59).

S Shows the seconds as one or two digits (1-59).

SS Shows the seconds as two digits (01-59).

SSS Shows the milliseconds (000-999).

AM/PM
am/pm
A/P
a/p

Shows the time in 12-hour format, followed by AM (12:00AM to 
11:59:59 AM), or PM (12:00 PM to 11:59:59 PM).
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Interval Format Symbols

Justify Data

Description
You can enhance the appearance of your report by centering or aligning data items. By default, 
data items in numeric columns are right-aligned while all other data items are left-aligned.

You can also specify that text wraps.

Steps
1. Select one or more data items in your report.
2. From the Format menu, click Properties and click the Layout tab.
3. Justify the data items to the left, center, or right by selecting the appropriate button in the 

Justification box.
4. To set how text wraps, do one of the following:

- (hyphen)
/  
: 
space

Shows the symbol as entered.

' Shows the symbol as entered. When you return to the Format dialog box, 
you will see a backward slash to indicate that the apostrophe has 
significance as a format.

\ Shows the next character in the format. Use this symbol to treat a format 
symbol as a standard character. Enter two backward slashes to show a 
backward slash.

" " Shows whatever is between the quotation marks.

Format symbol Description

Format symbol Description

D Shows the number of days.

H Shows the hour as one or two digits in 24-hour format (0-23).

HH Shows the hour as two digits in 24-hour format (00-23).

M Shows the minutes as one or two digits (1-59).

MM Shows the minutes as two digits (01-59).

S Shows the seconds as one or two digits (1-59).

SS Shows the seconds as two digits (01-59).

SSS Shows the milliseconds (000-999).

: Shows the symbol as entered.

. Shows the symbol as entered.

space Shows the symbol as entered.

" " Shows whatever is between the quotation marks.
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• To show text on a single line, click the Single Line option button. Text exceeding the 
width of the frame is not visible.

• To show text on multiple lines, click the Multi-Line option button. Text exceeding the 
width of the frame is not visible.

• To show text on multiple lines and wrap text inside the frame, click the Multi-Line with 
Word Wrap option button. Text wraps if it exceeds the width of the frame.

5. Click OK.

More Info

Note
• All values in a selected column are justified. For example, if you select a single value in a 

column and specify right justification, all the values in the column are right justified.

Related Topics
• "Format Data" (p. 81)
• "Enhance Data Display" (p. 87)

Enhance Data Display

Description
You can enhance the appearance of your report by changing the font, font size, style and color of 
data in your report.

Steps
1. Select one or more data items in your report.
2. From the Format menu, click Font.

The Format dialog box appears.
3. In the Font box, click a font.
4. In the Font Style box, click a font style.
5. In the Size box, click a font size.
6. To set text color, click Customize.
7. In the Color dialog box, click a color from the basic colors or define a custom color, then click 

OK.
8. In the Format dialog box, click OK.

More Info

Tip
• To quickly add color to data in a report, click the Color tool and set the color using the Color 

dialog box.
Color Tool 

Related Topics
• "Format Data" (p. 81)
• "Justify Data" (p. 86)

Using the Currency Symbol List
You are provided a list of currency symbols in the Currency Symbol list to format numeric data. 
Currency formatting can be set independently of number formatting on a column-by-column 
basis. You can select an explicit currency symbol that persists with the data, or select the Default 
option. Default uses the currency setting defined by your locale.
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You can change what currencies are listed in the Currency Symbol list. For more information see 
"Maintain Currency Symbols" (p. 88).

Steps to Use a Currency Symbol that Persists with the Data
1. With a report open, click a column with numeric values.
2. From the Format menu, click Data.
3. In the Positive box, click Currency.

The Currency Symbol list is enabled.
4. In the Currency Symbol list, select a currency symbol, such as the euro.

The data in the report shows the number values in the default number format with the 
currency symbol. This symbol persists with the data values when the report is distributed.

Steps to Use a Currency Symbol that Defaults to the User’s Locale
1. With a report open, click a column with numeric values.
2. From the Format menu, click Data.
3. In the Positive box, click Currency.

The Currency Symbol list is enabled.
4. In the Currency Symbol list, select Default.

Default uses the currency setting defined by your locale. For more information about 
modifying locale settings, see the Configuration Manager User Guide.

Related Topics
• "Format Data" (p. 81)

Maintain Currency Symbols

Description
You are provided a list of currency symbols that you can apply to numeric data. You can edit the 
Currency Symbol list by adding, deleting, and re-ordering currency symbols.

To make changes to the Currency Symbol list, you must edit the XML file i18n_res.xml. The file is 
located in the directory installation_location\bin.

The currency symbols that appear in the Currency Symbol list exist as elements in the 
i18n_res.xml file. Each currency element begins with the opening tag <currency> and ends with 
the closing tag </currency>. Nested within the currency element is a name element. The name 
element creates text that displays to the right of the currency symbol. It has the opening tag 
<name> and the closing tab </name>. Both the currency and name elements have attributes. To 
add, delete, or re-order symbols in the Currency Symbol list, you must edit these elements and 
attributes.

Here is a sample of a currency element.
<currency code="CAD" symbol="$" ID="CAD">

<name lang="en">Canadian Dollar</name>
</currency>
The list of currencies that shows in Impromptu is created as follows:
<currency_symbol> - <currency_description>

For example, $ - US Dollar

The currency element attributes are:

Attribute Description

Code Standard ISO three letter currency code. It is recommended that you do not edit 
this value.
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The name element has a single attribute.

Steps to Add a Currency Symbol
1. Open the i18n_res.xml file in Notepad.
2. Add a currency element using the following structure:

<currency code="currency_code" symbol="currency_symbol" ID="currency_id">
      <name lang="language_code">Currency_description</name>
</currency>

3. Define the currency element by adding values to the currency and name elements: 
• in the name-value pairs, code="currency_code", symbol="currency_symbol", and 

ID="currency_id", replace placeholder text in quotation marks with specific values 
• add a currency description
For example,
<currency code="SGD" symbol="S$" ID="SGD">
      <name lang="en">Singapore Dollar</name>
</currency>
Most currencies are listed in the file but commented out. To display them, remove the "<!--" 
on the left-hand side.

4. From the File menu, click Save.
To view the changes to the Currency Symbol list, restart the product.

Steps to Remove a Currency Symbol
1. Open the i18n_res.xml file in Notepad.
2. To delete a currency element, delete the currency opening tag <currency> and the closing 

currency tab </currency> tag and all the content framed by these tags.
Note: To suppress the display of a currency element, without removing the entry from the file, 
insert the comment tag <!-- before the currency opening tag, and the comment tag --> after the 
currency closing tag. For example,
<!-- <currency code="ALL" symbol="Lek" ID="ALL"> <name lang="en">Lek</name> 
-->

3. From the File menu, click Save.
To view the changes to the Currency Symbol list, restart the product.

Steps to Change the Order of Currency Symbols
1. Open the i18n_res.xml file in Notepad.
2. Select the currency element to move.

Be sure to select the opening and closing currency tags <currency> and </currency>.
3. Cut the currency element and paste it in the new location in the currency symbol list.
4. From the File menu, click Save.

Symbol Symbol displayed at the start of the list (on the left-hand side). This symbol can 
have multiple values, for example, $ and US$. However, each symbol value must 
have a unique identifier such as "USD" for $ and "USD1" for US$.

ID Internal identifier. The ID value must be unique in the file.

Attribute Description

Lang Identifies the two letter ISO code for the language of the text. You can define 
multiple names for a single currency symbol. For example,
<name lang="en"> South Korea, won</name>
<name lang="de"> Korea (Süd-Korea), Won</name>
<name lang="fr"> Corée du Sud, won</name>

Attribute Description
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To view the changes to the Currency Symbol list, restart the product.

Notes
• XML syntax is case-sensitive.
• the i18n_res.xml file is encoded in UTF-8. Ensure that you use an appropriate editor.

Tip
• To avoid the loss of existing information, backup the currency symbol file before modifying 

the XML tags.

Related Topics
• "Using the Currency Symbol List" (p. 87)
• "Format Data" (p. 81)
• "Justify Data" (p. 86)
• "Enhance Data Display" (p. 87)

Data Formats and Locale Settings
Data formats depend on the locale configuration settings for your Cognos Series 7 product. By 
default, Cognos Series 7 server products and Cognos Impromptu use a data format configuration 
file named cerlocale.xml.  Cognos Architect, Cognos Visualizer, Cognos PowerPlay for Windows, 
and Cognos Transformer use Windows Regional Settings for locale settings and data format 
information. However, these products can also be configured to use the data format configuration 
file.

For information about managing data formats, copying data format information, or editing the 
data format configuration file, see the Configuration Manager User Guide, or contact your 
administrator.

Number and Currency Data Type Formatting
When you format numeric data, you can apply a custom format explicitly, or you can choose to 
format data with the Number or Currency options. If you use Number or Currency, the data 
format is set to the values retrieved from the cerlocale.xml file. For example, if you specify 
Number, the data items are formatted using the elements such as SDecimal, SThousand, and so 
on. If you use Currency, the data items are formatted using the elements such as SCurrency, 
SMonCurrencySep, SMonThousandSep, and so on. If you want, you can edit the cerlocale.xml 
file and change the default data formats. 

For information about managing data formats, copying data format information, or editing the 
data format configuration file, see the Configuration Manager User Guide, or contact your 
administrator. For information about the impact of using the cerlocale.xml file with existing 
reports, see "Data Formats and Locale Settings" (p. 90). 

When Number and Currency are used, some rules apply.
• If the data type is float or double, the number of decimal places will be set to the value of 

IDigits (for number format) or ICurrDigits (for currency format) set in your cerlocale.xml file.
• If the data type is integer, small integer, packed decimal, or quad, the number of decimal 

places will be set to the column scale value set during database creation.
• If the scale is less than 0, the number of decimal places is 0.
• The maximum number of decimal places is 8. If the scale is greater than 8, the value is 

changed to 8.
• Number format is not rendered in scientific notation.

Tip: To find the data type and scale of a number, in Impromptu Administrator version, from the 
Report menu, click Query, and then in the Profile tab, click Query columns.
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Description
You can add borders around part of a report to emphasize it, to create structure, or to improve the 
overall report appearance. 

Example
You borders to part of a report and you specify colors for your borders.

Steps
1. Select the part of a report you want to put a border around.
2. From the Format menu, click Borders.
3. From the Style box, select the type of line.
4. Select the border lines for your border.
5. To add color to the border, click Customize.
6. In the Color dialog box, select the border color and click OK.

The border color displays in the Color box.
7. Click OK.

More Info

Note
• For information about adding borders to list reports, see "Hide or Show Grid Lines" (p. 95).

Tips
• To quickly add a single-line border around a selected part of a report, click the Borders button 

on the toolbar.
Borders button 

• To remove a border from a selected part of a report, click the Borders button on the toolbar.
• To quickly select several parts of a report, such as a picture and a comment, Ctrl+click each 

part of the report.

Related Topics
• "Add Color or a Pattern to Part of a Report" (p. 91)
• "Change the Font" (p. 92)
• "Apply a Style to Part of a Report" (p. 93)

Add Color or a Pattern to Part of a Report

Description
You can enhance the appearance of a report by changing the background color of part of the 
report.

You can also add patterns to selected parts of a report to emphasize important data.

By mixing the foreground and background colors, you can create a range of patterns to use in 
your report. 
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Example

To make one column in your report stand out from the rest, you give it a pattern.

Steps
1. Select the part of the report that you want to change.
2. From the Format menu, click Patterns.
3. From the Pattern box, select a pattern.
4. To select a foreground color, under Foreground:, click Customize.
5. In the Color Dialog Box, select a color and click OK.
6. To select a background color, under Background:, click Customize.
7.  In the Color dialog box, select a color and click OK.

More Info

Tips
• To quickly change the color of a selected part of a report, click the Pattern button on the 

toolbar.
Pattern button 
Impromptu adds a 25% gray shading to the selected part of a report.

• To quickly remove patterns from selected parts of a report, click the Pattern button on the 
toolbar.

• To remove patterns from selected parts of a report, use the Patterns command (Format menu), 
and then click Transparent in the Patterns box.

• To print your report in black and white, use patterns instead of colors.

Related Topics
• "Add a Border Around Part of a Report" (p. 91)
• "Apply a Style to Part of a Report" (p. 93)
• For information about conditional formatting, see Mastering Impromptu Reports.

Change the Font

Description
When you create a new report, Impromptu uses default font attributes for text. You can override 
these defaults and change the type, size, style, and color of the font. 

Example
You show selected data items in boldface and increase the font size of selected text in a header.
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Steps
1. Select the text you want to format.
2. Click the appropriate formatting button on the toolbar to make the change.

You can choose a font type, size, color, and any or all of three styles: bold, italic, and 
underline.

More Info

Notes
• If you are creating reports for others, use standard fonts available to all users.
• Impromptu’s minimum font size is 6. If you type in a lesser value and click OK, the text size 

remains unchanged.

Tips
• To take advantage of additional font attributes or to make several changes at one time, use the 

Font command (Format menu).
• To change the default font for all new reports, use the Object Format tab (Options dialog box, 

Tools menu).

Related Topics
• "Apply a Style to Part of a Report" (p. 93)

Apply a Style to Part of a Report

Description
You can apply a style to a selected part of a report. Use the convenience of styles to apply several 
pre-defined formats to your report in one step.

Example
You apply a style called "Sales Up" to summary data that represents an increase in sales for a 
given month. This style applies a specific font, font size, and color to the selected report part.

Steps
1. Select the part of the report to which you want to apply a style.
2. From the Format menu, click Styles.
3. From the Style box, select a style.

The Style box contains several styles that come with Impromptu and any styles you have 
created.

4. Click Apply and then click Close.

More Info

Note
• You can apply more than one style to part of a report.

What if ...
• You change your mind after applying a style?

From the Style box, select None.

Related Topics
• "Add a Border Around Part of a Report" (p. 91)
• "Add Color or a Pattern to Part of a Report" (p. 91)
• "Change the Font" (p. 92)
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Chapter 16: Format a List or Crosstab Report

There are many ways to format a list report:
• "Hide or Show Grid Lines" (p. 95)
• "Select Parts of a List Report" (p. 96)
• "Move a Column" (p. 97)
• "Change a Column Title" (p. 98)
• "Change the Width of a Column" (p. 98)
• "Change the Height of a Row" (p. 99)
• "Add a Group or List Header or Footer" (p. 100)
• "Change the Height or Width of a List Header or Footer" (p. 101)
• "Keep Details and Group Headers (or Footers) Together" (p. 101)
• "Insert a Page Break in a List Report" (p. 102)

There are several ways to format a crosstab report:
• "Select and Format Parts of a Nested Crosstab Report" (p. 102)
• "Set the Default Format for Crosstab Columns" (p. 104)

Hide or Show Grid Lines

Description
You can enhance the appearance of a list report by adding grid lines. Grid lines visually separate 
different areas in a report.

You can show or hide grid lines
• around the outside edge of the detail area to show or hide the detail boundaries
• around the individual columns to show or hide the column boundaries
• around the individual rows to set the detail lines apart clearly from any grouped columns
• above and below group data items to show where group data values change
• in any combination of the preceding four grid line settings

Steps
1. Select a cell, row, or column in the list.
2. From the Edit menu, click Select Parent.
3. Right-click the list, and select Format.
4. Click the Grid tab and do one of the following:

Click ... To add or remove ...

Outline

An outline grid from the selected list frame.

Group

The border above and below each group.
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5. If you want to change the line style for the grid, select a new line style from the Style box.
6. If you want to change the line color for the grid, click Customize.
7. In the Color dialog box, select a new color, and click OK.
8. In the Format dialog box, click OK.

Related Topics
• "Format a List or Crosstab Report" (p. 95)

Select Parts of a List Report

Description
You can select a value, row, column, or entire list to perform actions such as
• changing format or properties
• applying a style
• adjusting size or position of items
• inserting a new data item
• copying items to the Clipboard
• moving items by dragging them to a new location
• sorting
• adding a summary operation

Step
• Do one of the following:

Columns

Column grid lines.

Impromptu adds a border around each column except the left-most and 
right-most columns. To add an outside border around the left-most and 
right-most columns, add an outline border in addition to the column 
border. 

Rows

Row grid lines.

Click ... To add or remove ...

To select ... Do the following:

A single value Select the value that you want within the list.

A row Position the pointer over the left edge of the row that you want to 
select and click the mouse button.Your pointer changes to the 
following:

Select Row pointer 
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More Info

Tips
• To select a range of adjacent columns, select the first column you want in the range by 

positioning the pointer over the selected column title header. The pointer changes to a down 
arrow.
Click to select the first column. Shift+click to select the last column you want in the range. 
Impromptu selects all the columns in between the two columns you selected.

• To select non-adjacent columns, select the first column by positioning and clicking the pointer 
over the column title header. Ctrl+click each additional column you want to select.

Related Topics
• "Change the Height of a Row" (p. 99)
• "Change the Width of a Column" (p. 98)
• "Format a List or Crosstab Report" (p. 95)
• "Move a Column" (p. 97)

Move a Column

Steps
1. Position and click the pointer over the selected column title header.

Your pointer changes to the following:

2. Drag the selection to the right or left.
As you drag the column, Impromptu uses highlighting to indicate the column’s new position. 
If two vertical lines appear between adjacent columns, then the column is inserted between the 
adjacent columns. If two vertical lines appear on the outer border of the first column, the 
column is inserted to the left of the first column. If two vertical lines appear on the outer 
border of the last column, the column is inserted to the right of the last column.

3. Release the mouse button when the column is in the correct position.

More Info

Notes
• You can also move a column by selecting a single data value in the column that you want to 

move and dragging the selection to the right or left.
• If you move a column to the top of the list, you create a crosstab.

What if ...
• The pointer changes to the following when you move it over the column headers.

A column Position the pointer over the top edge of the column that you want 
to select and click the mouse button.

Your pointer changes to the following:

Select Column pointer

An entire list Click the mouse to the right of the right-most column.

Headers and footers Click any part of the header or footer that is empty.

To select ... Do the following:
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Column pointer 
You will create a crosstab report if you drop columns in the column headers.

Related Topics
• "Change a Column Title" (p. 98)
• "Change the Width of a Column" (p. 98)
• "Format a List or Crosstab Report" (p. 95)
• "Select Parts of a List Report" (p. 96)

Change a Column Title

Description
You can change a column title so that it is more descriptive and meaningful.

Steps
1. Double-click the column title you want to change.
2. Change the text in the title.
3. When you finish editing the text, click anywhere outside the column title.

Related Topics
• "Change the Width of a Column" (p. 98)
• "Format a List or Crosstab Report" (p. 95)
• "Move a Column" (p. 97)
• "Select Parts of a List Report" (p. 96)

Change the Width of a Column

Description
Impromptu sets the column width to the best fit based on the data in the column. 

You can also change the width of columns in a list to meet specific reporting requirements by
• using the mouse to drag-size the width of a column
• changing the column width using precise specifications

Example
To fit a list exactly within the boundaries of a specific paper size, you set the size of each column 
in the list to a specific value, such as 1 inch and 2.5 cm.

Steps to Change the Width of a Column
1. Select any cell in the column that you want to resize.
2. Position the pointer over one of the handles that controls the horizontal size of the cell.
3. While holding down the mouse button, drag the handle until the cell is the size you want.
4. Release the mouse button.

Steps to Change Column Width Using Precise Specifications
1. Select any cell in the column that you want to resize.
2. From the Format menu, click Size.
3. In the box indicating the width, do one of the following.

• To show the Width Measurement box, click Specify Width. 
You can enter a specific value for the column width. The unit of measurement depends on 
your current settings.
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• To determine the best fit for the column based on a specified number of rows, click Scan 
Data for Best Width. In the Rows box, type the number of rows you want Impromptu to 
scan.

4. Click OK.

More Info

Note
• When you resize a cell to show multiple lines of text, the text in the cell does not wrap unless 

you set its properties appropriately. For information about setting properties, see "Justify 
Data" (p. 86).

Related Topics
• "Change a Column Title" (p. 98)
• "Format a List or Crosstab Report" (p. 95)
• "Move a Column" (p. 97)
• "Select Parts of a List Report" (p. 96)

Change the Height of a Row

Description
By default, Impromptu sets the row height to the height of the largest text string, picture, or report 
variable in the detail lines. When you change the cell font, Impromptu automatically adjusts the 
row height.

You can change the height of a row by
• sizing it with your mouse
• using precise specifications

You cannot change the height of a single row in a list. When you change the height of one row, all 
rows in the report are changed to the same height.

Example
To fit a list exactly within the boundaries of a specific paper size, you set the height of each row in 
the list to a specific value such as 1.25 cm or 0.5 inch.

Steps to Change the Height of a Row
1. Select the largest vertical text string, picture, or report variable from the row.
2. Position the pointer over one of the handles that control the vertical size of the row.
3. While holding down the mouse button, drag the handle vertically until the text string, picture, 

or report variable is the height you want.
4. Release the mouse button.

Steps to Change the Height of Rows Using Precise Specifications
1. Select the largest vertical text string, picture, or report variable from the detail lines of the list.
2. From the Format menu, click Size.
3. In the box indicating the height, do one of the following.

• To show the Height Measurement box, select Specify Height.
You can enter a specific value for the row height. The unit of measurement depends on 
your current settings.

• To determine the best fit for the row based on a specified number of rows, click Scan Data 
for Best Height. In the Rows box, type the number of rows you want Impromptu to scan.

• To set the height of each row based on the contents of the cell you selected in step 1, select 
Dynamic.

4. Click OK.
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More Info

Note
• When you resize a cell to show multiple lines of text, the text in the cell does not wrap unless 

you set its properties appropriately. For information about setting the text properties, see 
"Justify Data" (p. 86).

Related Topics
• "Change the Width of a Column" (p. 98)
• "Format a List or Crosstab Report" (p. 95)
• "Select Parts of a List Report" (p. 96)

Add a Group or List Header or Footer

Description
You can enhance the appearance of a list as well as highlight grouped data by adding headers and 
footers to a list.

You can add or remove the following headers or footers at any time:
• List header and footer. They appear at the top and bottom of a list, and have a default height 

of one row (about 1 cm or .39 inches). You can change this height.
• Group header and footer (if you have grouped items). You can add a group header and group 

footer for each distinct group within the list. You can also insert calculations that show 
summary values such as totals, averages, or maximums in the group header or footer.

Example
You add a group header to your report to show the number of sales made by each sales 
representative in your organization. To clarify the report data, you also add a list header to your 
report and insert a title and the date.

Steps to Add a Group Header or Footer
1. Select one or more data items for which you want to create a group header or group footer.
2. On the toolbar, click the Header or Footer button.

Header button 
Footer button 
If the selected data items are not grouped, Impromptu groups them, sorts them and adds a 
group header or footer for each. In addition, Impromptu automatically inserts the data items 
that you selected in step 1 into the group headers (but not into the group footers).
Note: Impromptu does not cancel any groups that have already been set. The new group items 
are added to any existing group items.

Steps to Add a List Header or Footer
1. Select a cell in the list to which you want to add a list header or footer.
2. From the Edit menu, click Select Parent.
3. From the Format menu, click Properties and click the Layout tab.
4. Click List Header or List Footer check box to add it to the list.
5. Click OK.

More Info

Tip
• To delete a header or footer, select it and press the Delete key.

What if...
• You want to add a title to the list header?
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From the Insert menu, click Text Frame. While holding down the mouse button, drag the 
mouse diagonally to size the area within the list header where your text will appear and 
release the mouse button.

Related Topics
• "Change the Height or Width of a List Header or Footer" (p. 101)
• "Format a List or Crosstab Report" (p. 95)
• "Keep Details and Group Headers (or Footers) Together" (p. 101)

Change the Height or Width of a List Header or Footer

Description
The default height of list headers and footers is two row heights (about 3/4 inches or 2 cm). The 
default width of the list headers and footers corresponds to the width of the list columns. You can 
change both the height and the width of a list header or footer to accommodate another text 
string, value, picture, or report variable. 

Example
You change the height and width of the list header to add your company logo. 

Steps
1. Select the list header or footer whose height you want to change.
2. Position the pointer over one of the handles until it changes to a two-headed arrow.
3. While holding down the mouse button, drag the handle until the header or footer is the size 

you want and release the mouse button.

More Info

Tip
• To align the header and footer in a list report to the width of the report columns, select Snap 

to Columns in the Size tab (Properties dialog box, Format menu).

Related Topics
• "Add a Group or List Header or Footer" (p. 100)
• "Format a List or Crosstab Report" (p. 95)
• "Keep Details and Group Headers (or Footers) Together" (p. 101)

Keep Details and Group Headers (or Footers) Together

Description
For any list report that appears in Page Layout view, you can increase report readability by 
preventing a group header or footer from appearing on a page by itself.

Use the Keep Details and Headers Together button to specify that no group header should appear 
at the bottom of a page by itself. Use the Keep Details and Footers Together button to specify that 
no group footer should appear at the top of page without at least one row of data above it.

Steps
1. Click a cell in the list report.
2. From the Edit menu, click Select Parent.
3. From the Format menu, click Properties and click the Layout tab.
4. To keep details with the group headers, click the Keep Details and Headers Together button.

Otherwise, to keep details with the group footers, click the Keep Details and Footers Together 
button.

5. Click OK.
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Related Topics
• "Add a Group or List Header or Footer" (p. 100)
• "Change the Height or Width of a List Header or Footer" (p. 101)
• "Format a List or Crosstab Report" (p. 95)

Insert a Page Break in a List Report

Description
You can insert a page break in your list report before or after a group or groups of data. You can 
also reset the page number to 1 for each group or after several groups of data. If the report has 
only a few rows of information on each page, you can remove the page breaks before you print to 
save paper. 

Example
You have a long report based on sales in different cities. You start a new page each time your 
report shows information for a new city, and you start each city with the number 1.

Steps
1. Click a cell in the list report.
2. From the Edit menu, click Select Parent.
3. From the Format menu, click Properties and click the Layout tab.
4. To set a page break before or after a grouped data item, click the Page Break Before or Page 

Break After buttons that appear beside the group item.
5. To reset page numbers for one or more groups, click the group you want to reset page 

numbering for from the Reset the Page Number On box.
There is nothing to select from this list if there are no groups in the report.

6. Click OK.

More Info

What if ...
• You want to remove page breaks before you print the report?

In the Layout tab (List Properties dialog box), clear the Page Break Before or Page Break After 
buttons.

Related Topics
• "Format a List or Crosstab Report" (p. 95)

Select and Format Parts of a Nested Crosstab Report

Description
You can select a value, row, column, or you can select all the columns or column headings at a 
particular nesting level to perform actions such as
• changing format or properties
• applying a style
• adjusting size or position of items
• copying items to the Clipboard
• moving items by dragging to a new location
• sorting
• adding a summary operation

Example
You select the Sales Amount column for every sales channel in order to apply formatting.
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Step
• Do one of the following:

More Info

Notes
• You cannot edit the generated column titles in a crosstab report.
• When you apply formatting to all the column titles or all the columns at a particular nesting 

level, you set the default for all formatting at that nesting level. If new columns are added, 
Impromptu applies the default formatting.

Tip
• To format a nested crosstab, select the parts of the crosstab you want to format and apply 

formatting (Format menu). For information about formatting reports, see "Format a 
Report" (p. 75).

Related Topics
• "Create a Crosstab Sub-Report" (p. 36)
• "Set the Default Format for Crosstab Columns" (p. 104)
• "Use the Report Wizard to Quickly Create a Crosstab Report" (p. 32)

To select ... Do the following:

A single value Select the value that you want within the crosstab.

A row Position the pointer over the left edge of the row that you want 
to select and click the mouse button.

Your pointer changes to the following:

A column Position the pointer over the top edge of the column that you 
want to select and click the mouse button.

Your pointer changes to the following:

Select Column pointer

All the column titles at a 
specific nesting level

Click the selection pointer twice in the top half of the column 
title.

All the columns at a 
specific nesting level

Position your pointer over a column at the nesting level you 
want to select and click the mouse button.

Your pointer changes to the following:

Select Column pointer

Click the mouse button a second time to select all the columns.

An entire crosstab Click the point at which the horizontal and vertical scroll bars 
intersect in the lower-right corner of the crosstab.

Headers and footers Click any part of the header or footer that is empty.
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Set the Default Format for Crosstab Columns

Description
The number of columns in a crosstab report can change when you retrieve the data, apply a new 
filter, or change prompt values. Therefore, a crosstab report can have multiple columns. You can 
specify whether you want to change the default column formatting or the formatting for only one 
column.

If you don't set a default column format, then the report uses the formats set in the Data Format 
tab of the Options dialog box.

You can use conditional formatting to format crosstab rows. Any conditional formatting set on a 
row supersedes the default column formatting for the columns cells in that row.

Steps
1. Select the column item you want to set the default formatting for.

• To select a column title, click the bottom half of the title.
• To select a column, click the top half of the column title.

Your pointer changes to the following:
Select Column pointer 

• To select a column total, click the total.
2. Set the default formatting for that column item (at that particular level).

Column titles and totals can have many levels in a crosstab report.

Note
• If you select a single column title, cell, or total and change the format, that change only 

applies to that column item and only for as long as that column item exists in the report.

Related Topics
• "Create a Crosstab Sub-Report" (p. 36)
• "Filter Using Crosstab Titles" (p. 53)
• "Select and Format Parts of a Nested Crosstab Report" (p. 102)
• "Use the Report Wizard to Quickly Create a Crosstab Report" (p. 32)
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In Impromptu, you can add charts to reports to show data graphically. You can choose from 
several different chart types. After you add a chart, you can change the chart type or customize the 
chart to improve readability and presentation. In particular, you can add chart titles, use grid lines 
and include a legend. You can also add labels for the data in a chart, and specify the format for the 
labels, such as style, font type, and size. For certain chart types, you can add a trendline.

For a list of the controls related to chart formatting, see (p. 165).

For information about how tasks are done differently in this version of Impromptu compared to 
earlier releases, see (p. 159).

Choosing a Chart Type

Description
A chart is a visual representation of data that you can use to quickly and easily evaluate 
information.

To choose a chart type, consider what you want the chart to illustrate. Different chart types and 
configurations emphasize different things.

Area Charts
Area charts show trends in data over time by emphasizing the total quantity of several data items 
under the curve.

If data is ungrouped, the chart shows the group summaries for the first data item.

If data is grouped, each data item shows as a data group on the primary axis.

Area charts can have depth added, or have a three-dimensional layout.

Area charts plot data on the primary axis.

Bar Charts
Bar charts highlight changes over time and compare totals and individual values. A bar chart can 
reveal trends and patterns.

Purpose Chart type

Show contributions of parts to a whole pie 

Compare variables bar 

Compare trends in data over time area 

Highlight trends radar

Compare trends and relationships between data correlation

Create a graphical view of a project schedule Gantt

Compare the difference between values such as stock prices HLCO (high low close open)
HLO (high low open)

Identify a pattern scatter
bubble
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If data is ungrouped, each bar represents a summarized data item or a summarized row of values 
for a data item.

If data is grouped, each bar represents a group.

Bar charts can have depth added, or have a three-dimensional layout.

Bar charts plot data on the primary axis.

Bubble Charts
Bubble charts are line charts in which the data points are represented typically by bubbles. The 
advantage of using a bubble chart instead of a line chart is that the size of the marker provides 
quantitative information. Bubble markers can be changed to other formats such as stars. 

Bubble charts plot data on the primary axis, secondary axis, and measure line. The measure data 
value is represented by the size of the bubble.

Correlation Charts
Correlation charts are bar charts overlaid with a line chart that allows you to show two different 
measures with a shared x-axis and two y-axes. The left and right y-axes can each have a different 
scale, enabling you to visually correlate dissimilar measures. For example, you can show products 
on the shared x-axis, with order income on the right-hand y-axis and order revenue on the 
left-hand y-axis, and visually compare the relationship between order income and order revenue 
for each product.

For information about how to create a correlation chart, see (p. 118).

For information about how to format a correlation chart, see (p. 118).

Gantt Charts
Gantt charts provide a graphical view of a project schedule. Gantt charts are horizontal.

To create a Gantt chart, you must group your data, and the second data item must be greater than 
the first data item.

Gantt charts plot data on the primary axis and the secondary axis.

HighLowCloseOpen (HLCO)
HighLowCloseOpen (HLCO) charts highlight changes for a specific time period to compare the 
difference between pairs of values.

HighLowCloseOpen charts plot data on the primary axis, secondary axis and measures line.

You can also use the HighLowCloseOpen chart type to create a HighLow chart and a 
HighLowClose chart. To create a HighLow chart, you do not specify a measure value. To create a 
HighLowClose chart, specify one measure.

HighLowOpen (HLO)
HighLowOpen (HLO) charts track financial data such as the daily high, low and open price of a 
stock. It is a variation of the HighLowCloseOpen chart.

HighLowOpen charts plot data on the primary axis, secondary axis and measures line. The 
measure line plots only one measure.

Line Charts
Line charts plot data at equidistant points connected by lines to illustrate trends. Line charts are 
commonly used to show trends over time. Because the markers in a line chart can be formatted to 
take a up very little space, line charts are useful when you want to plot charts that have many data 
values.

If data is ungrouped, the chart shows a single line containing points for each data item.

If data is grouped, the chart shows multiple lines for each data item. The primary axis shows the 
data groups.

Line charts plot data on the primary axis.
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Line charts can have depth added, or have a three-dimensional layout. Line charts with depth are 
known as tape charts.

A log chart is a line chart that uses a logarithmic scale.

Pie Charts
Pie charts show the relationship of parts to the whole. Data is represented as pie-shaped segments 
in a circle. Pie charts can have depth added.

If data is not grouped, each segment represents a data item.

If data is grouped, each segment represents a group summary.

Pie charts plot data on the primary axis.

Radar Charts
Radar charts are used primarily as a comparative tool. Multiple data values are plotted on a circle 
and joined by connecting lines to create a radial figure. You can use either the area created by the 
connecting lines or the actual values on the chart to do a comparative analysis.

Radar charts plot data on the primary axis.

Scatter Charts
Scatter charts highlight the correlations between large sets of data or several changing data items. 
It is commonly used to analyze data when there is no obvious correlation between two pieces of 
data, such as revenue versus inventory counts. It can be used to identify a pattern by illustrating 
the relationship between independent variables.

Scatter charts plot data on the primary axis and the secondary axis.

Create a Chart

Description
To create a chart, you pick the data that you want to appear in the chart. Depending on the chart 
type you select, you can plot one or more data values. Data values are plotted for the primary 
axis, secondary axis, and for measures.

For more information about the chart types available and the data requirements for each, see 
"Choosing a Chart Type" (p. 105).

You can manipulate the view of the data by 
• pivoting the data on the primary axis
• changing the data mode and viewing the date either by row or column

Before you create a chart, you must define the report query. For more information, see the 
following entry in the online help index: reports, creating.

Steps
1. With a report open, from the Insert menu, click Chart Frame.
2. Place the pointer where you want to locate the upper-left corner of the frame and drag the 

mouse diagonally until the frame is the size you want.
The Chart Properties dialog appears.

3. In the Chart type box, click the chart type.
The chart type sets whether you can plot one or more data values.

4. On the Data tab, in the Query data box, select the data items for the query. Use the arrow to 
move data items from the Query data box to the Primary Axis, Secondary Axis, and 
Measure(s) boxes, as required. 
Only numeric data items appear in the Query data box.
Tip: To remove a data item, click the data item located in the Primary Axis, Secondary Axis, 
or Measure(s) box, and click the arrow.
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5. On the Data tab, do one or more of the following.

6. Click OK.

More Info

What if ...
• You are upgrading a chart and the chart does not have the correct number of data values 

specified for the chart type?
You can upgrade or open the report but you receive a warning. You cannot apply the settings 
for the chart until the required data values are specified.

• You want to remove a chart?
Select the chart and press the Delete key.

• You want to create a 100% pie chart?
Select the pie chart type, and then on the Format tab of the Chart Properties dialog box, click 
Properties. In the Properties dialog box, on the Data Labels tab, select the Show Values and 
As Percentage check boxes.

• You want to create a percent or stacked bar chart?
Select the bar chart type, and then on the Format tab of the Chart Properties dialog box, click 
Properties. In the Properties dialog box, on the Layout tab, select Percent or Stacked.

• You want to create a horizontal bar chart?
In the Chart type list, select Bar chart, and then on the Format tab of the Chart Properties 
dialog box, click Properties. In the Properties dialog box, on the Layout tab, under Axes, 
select the Horizontal option.

• You want to create a bar chart with depth that is horizontal and 100% stacked.
In the Chart type list, select Bar chart, and then on the Format tab of the Chart Properties 
dialog box, click Properties. In the Properties dialog box, on the General tab, click Depth and 
specify the amount of depth. On the Layout tab, select Stacked and Horizontal. 

• You want to create a three-dimensional bar chart.
In the Chart type list, select Bar chart, and then on the Format tab of the Chart Properties 
dialog box, click Properties. In the Properties dialog box, on the Layout tab, select True 3D 
Column. The three-dimensional layout is only available when the bar chart plots data 
vertically, that is, on the x-axis.

Tips
• To quickly access the Chart properties, right-click the chart and click Properties.

Related Topics
• "Choosing a Chart Type" (p. 105)
• "Format a Chart" (p. 109)

Goal Action

Show in a chart the first row in a grouped 
data item.

Show in a chart the first column in a grouped 
data item.

In the Mode box, click By Row.

In the Mode box, click By Column.

Swap rows and columns. You must have at 
least one grouped data item.

Click Pivot data.

If you swap rows and columns in a chart that 
is grouped by rows, it becomes grouped by 
columns.

Plot null data. Select the Plot null data check box.

Plot negative data. Select the Plot negative data check box.
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Change the Chart Type

Description
There are many chart types that you can choose when adding a chart to a report. Choosing the 
appropriate chart type depends on the purpose of the chart. For example, if you want to compare 
parts to the whole, a pie chart is suitable. If you want to compare quantitative data such as annual 
sales, you may want to use a bar chart. For more information, see "Choosing a Chart 
Type" (p. 105).

Charts plot data values on one or more axis. If you change chart type, ensure that you specify data 
values for each of the required axes.

Steps
1. Right-click the chart and click Properties.

Check that the Chart Properties dialog box opened. If another dialog box opened instead, you 
did not have the chart selected. Click Cancel to close the dialog box, press Esc to clear your 
selection, and try again.

2. In the Chart type box, click a chart type.
3. Click the Data tab and specify any additional data values, if required.

For example, a pie chart requires only primary axis values whereas a scatter chart requires 
both primary and secondary axis values.

4. Click OK.

Related Topics
• "Format a Chart" (p. 109)
• "Add Chart Titles" (p. 110)
• "Format the Chart, Plot, and Legend Area" (p. 112)
• "Format Chart Titles, Axis Titles, Data Labels, and Legend Text" (p. 111)
• "Change the Axis Labels and Scale Settings" (p. 112)
• "Change the Grids Settings" (p. 114)
• "Format Data Items" (p. 114)
• "Hide or Show Data Labels in a Chart" (p. 115)
• "Add and Format a Chart Legend" (p. 115)
• "Show TrendLines" (p. 117)

Format a Chart

Description
There are many formatting options that you can use to enhance your charts. For example, you can 
add a footnote, change the chart background color, add a legend, and so on. 

When formatting charts, you can define properties that apply to the entire chart or to particular 
data items in the chart. To format particular data items, use the Customize per Data Item dialog 
box. (p. 114) To define chart properties that apply globally, use the Properties dialog box.

Steps
1. Right-click the chart, click Properties, and then click the Format tab.

Check that the Chart Properties dialog box opened. If another dialog box opened instead, you 
did not have the chart selected. Click Cancel to close the dialog box, press Esc to clear your 
selection, and try again.
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2. Click the Format tab and use the available controls to set the chart properties. The tabs and 
settings that appear can vary depending on the chart type you select. Here are some of the 
formatting changes you can make. 

3. To accept your formatting changes, click OK.

Related Topics
• "Change the Chart Type" (p. 109)
• "Add Chart Titles" (p. 110)
• "Format the Chart, Plot, and Legend Area" (p. 112)
• "Format Chart Titles, Axis Titles, Data Labels, and Legend Text" (p. 111)
• "Change the Axis Labels and Scale Settings" (p. 112)
• "Change the Grids Settings" (p. 114)
• "Format Data Items" (p. 114)
• "Hide or Show Data Labels in a Chart" (p. 115)
• "Add and Format a Chart Legend" (p. 115)
• "Show TrendLines" (p. 117)

Add Chart Titles

Description
Charts can have a main title, a subtitle, a footnote, a category axis title, a Y1 axis title, a Y2 axis 
title, and a series axis title. 

You can specify a title for the Y1 and Y2 axes, if your chart has dual value axes. The series axis 
title is available only for three-dimensional charts. The category and value titles (Y1 and Y2) are 
available only in charts that use the x-axis and y-axis, respectively.

Goal Action

Specify a layout type such as stacked, 
percent, and true 3D column.

Click Properties, and click the Layout tab.

Add data labels. Click Properties, and click the Data Labels tab.

Add a legend. Click Properties, and click the Look tab.

Add dual axes. Click Properties, and click the Layout tab.

Show trendlines. Click Trendlines.

Add a chart title, subtitle, or footnote.

Add a title for the category or value axis.

Add a series title.

Click Titles.

Customize the grids and scales of the 
category axis, y-axis, and series axis.

Click Grids and Scales.

Customize data items. Click Customize per Data Item.

Change the chart, plot or legend 
background color.

In the Chart background box, click the item to 
format, and click Edit.

Change the font formatting of such chart 
characteristics as chart titles, legend text, 
and data labels.

In the Font formatting box, click the item to 
format, and click Edit.
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Steps
1. Right-click the chart, click Properties, and then click the Format tab.

Check that the Chart Properties dialog box opened. If another dialog box opened instead, you 
did not have the chart selected. Click Cancel to close the dialog box, press Esc to clear your 
selection, and try again.

2. On the Format tab, click Titles, and then in the Titles dialog box, choose from the available 
options. Select the
• Title check box and type a main title for the chart
• Subtitle check box and type a subtitle. A subtitle appears beneath the main title.
• Footnote check box and type a footnote. A footnote appears in the lower, right-hand 

corner of the chart.
• Category Title check box and type a title for the x-axis
• Value Title (Y1) check box and type a title for the Y1-axis
• Value Title (Y2) check box and type a title for the Y2-axis
• Series Axis check box and type a series title

3. Click OK.
After you have added a title, you can format it using the Font formatting box located on the 
Format tab of the Chart Properties dialog box. See, (p. 111).

More Info

What if ...
• You want to remove titles?

Clear the appropriate check box: Title, Subtitle, Footnote, Category Title, Value Title (Y1) 
Value Title (Y2) and Series Axis.

Related Topics
• "Change the Chart Type" (p. 109)
• "Format a Chart" (p. 109)
• "Format the Chart, Plot, and Legend Area" (p. 112)
• "Format Chart Titles, Axis Titles, Data Labels, and Legend Text" (p. 111)
• "Change the Axis Labels and Scale Settings" (p. 112)
• "Change the Grids Settings" (p. 114)
• "Format Data Items" (p. 114)
• "Hide or Show Data Labels in a Chart" (p. 115)
• "Add and Format a Chart Legend" (p. 115)
• "Show TrendLines" (p. 117)

Format Chart Titles, Axis Titles, Data Labels, and Legend Text

Description
Certain chart objects such as chart and axis titles, data labels, and legend text permit font 
formatting. Font formatting includes specifying font color, size, style and alignment. Certain 
objects, such as data labels, also permit rotation. Rotating objects can be useful when you want to 
avoid overlapping text.

Steps
1. Right-click the chart, click Properties, and then click the Format tab.

Check that the Chart Properties dialog box opened. If another dialog box opened instead, you 
did not have the chart selected. Click Cancel to close the dialog box, press Esc to clear your 
selection, and try again.

2. On the Format tab, in the Font formatting box, click the object to format, such as Data 
Labels.
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3. Click Edit and, in the Formatting dialog box, specify the format characteristics. 
4. Click OK twice.

The chart appears with the new formatting you specified.

Related Topics
• "Change the Chart Type" (p. 109)
• "Format a Chart" (p. 109)
• "Add Chart Titles" (p. 110)
• "Format the Chart, Plot, and Legend Area" (p. 112)
• "Change the Axis Labels and Scale Settings" (p. 112)
• "Change the Grids Settings" (p. 114)
• "Format Data Items" (p. 114)
• "Hide or Show Data Labels in a Chart" (p. 115)
• "Add and Format a Chart Legend" (p. 115)
• "Show TrendLines" (p. 117)

Format the Chart, Plot, and Legend Area

Description
The chart has three distinct areas that you can format: chart, plot and legend. The plot area is that 
area of the chart enclosed by the x-axis and the y-axis. The legend area refers to the legend 
background. The chart area includes the remaining areas other than the plot and legend areas.

For the chart, plot and legend areas, you can customize the line and fill properties.

Steps
1. Right-click the chart, click Properties, and then click the Format tab.

Check that the Chart Properties dialog box opened. If another dialog box opened instead, you 
did not have the chart selected. Click Cancel to close the dialog box, press Esc to clear your 
selection, and try again.

2. On the Format tab, in the Chart background box, click the chart, plot or legend area, and 
then, click Edit to specify the fill color, pattern, and pattern color.

3. Click OK twice.
The chart appears with the new formatting you specified.

Related Topics
• "Change the Chart Type" (p. 109)
• "Format a Chart" (p. 109)
• "Add Chart Titles" (p. 110)
• "Format Chart Titles, Axis Titles, Data Labels, and Legend Text" (p. 111)
• "Change the Axis Labels and Scale Settings" (p. 112)
• "Change the Grids Settings" (p. 114)
• "Format Data Items" (p. 114)
• "Hide or Show Data Labels in a Chart" (p. 115)
• "Add and Format a Chart Legend" (p. 115)
• "Show TrendLines" (p. 117)

Change the Axis Labels and Scale Settings

Description
Customize the axis labels and scale settings in a chart to enhance your charts.
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Note that the tabs and settings that appear in the Grids and Scales dialog box can vary depending 
on the chart type you select.

Steps
1. Right-click the chart, click Properties, and then click the Format tab.
2. On the Format tab, in the Display options box, click Grids and Scales.
3. In the Grids and Scales dialog box, click the axis to format.

Depending on the chart type and chart layout, you can have a Y1 axis, Y2 axis, X Axis, 
Category Axis, Z Axis, and Series Axis. The Series Axis is only valid for three-dimensional 
charts. The Y2 Axis appears when the chart has dual axes. The Z Axis appears for bubble and 
scatter charts.

4. On the General tab, specify where you want the axis labels to be located. 
In addition to specifying the location, you can arrange the value labels in descending order 
and the category labels in reverse order.

5. On the Labels tab, choose whether to show or hide the axis labels.
For the X Axis, you can stagger the labels or manually set the number of categories you want 
to show.
For the Y Axis, you can specify whether to show the maximum or minimum value label.

6. On the Scales tab, format the chart scale. Note that the Scales tab is not available if the Series 
Axis or Category Axis tab is selected.
 Here are the formatting changes you can make. 

7. Click OK twice to accept your formatting changes.

Tip: After you have added axis labels to the chart, you can specify such characteristics as font 
style, color, alignment, and rotation. For more information, see (p. 111).

Related Topics
• "Change the Chart Type" (p. 109)
• "Format a Chart" (p. 109)
• "Add Chart Titles" (p. 110)
• "Format the Chart, Plot, and Legend Area" (p. 112)
• "Format Chart Titles, Axis Titles, Data Labels, and Legend Text" (p. 111)
• "Change the Grids Settings" (p. 114)
• "Format Data Items" (p. 114)
• "Hide or Show Data Labels in a Chart" (p. 115)
• "Add and Format a Chart Legend" (p. 115)
• "Show TrendLines" (p. 117)

Goal Action

Specify a logarithmic scale Select the Make Logarithmic check box.

Start the scale with zero Select the Always Include Zero check box.

Manually set the maximum value on the 
scale

Select the Set Maximum Value check box, 
and enter a value in the box.

Manually set the minimum value on the scale Select the Set Minimum Value check box, 
and enter a value in the box.
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Change the Grids Settings

Description
Grid settings let you add major and minor grid lines to a chart and add and specify the location of 
grid labels.

Note that the tabs and settings that appear in the Grids and Scales dialog box can vary depending 
on the chart type you select.

Steps
1. Right-click the chart, click Properties, and then click the Format tab.
2. On the Format tab, in the Display options box, click Grids and Scales.
3. In the Grids and Scales dialog box, click the axis to format.

Depending on the chart type and chart layout, you can have a Y1 axis, Y2 axis, X Axis, 
Category Axis, Z Axis, and Series Axis. The Series Axis is only valid for three-dimensional 
charts. The Y2 Axis appears when the chart has dual axes. The Z Axis appears for bubble and 
scatter charts.

4. On the Grids tab, specify whether to show the major and minor grid lines.
If you add grid lines, you can specify a grid style, such as Outer Ticks, and you can manually 
specify the grid intervals.
For certain charts, you can also add and specify the location of a custom grid line by selecting 
the Draw Custom Line at check box.

5. Click OK twice to accept your formatting changes.

Related Topics
• "Change the Chart Type" (p. 109)
• "Format a Chart" (p. 109)
• "Add Chart Titles" (p. 110)
• "Format the Chart, Plot, and Legend Area" (p. 112)
• "Format Chart Titles, Axis Titles, Data Labels, and Legend Text" (p. 111)
• "Change the Axis Labels and Scale Settings" (p. 112)
• "Format Data Items" (p. 114)
• "Hide or Show Data Labels in a Chart" (p. 115)
• "Add and Format a Chart Legend" (p. 115)
• "Show TrendLines" (p. 117)

Format Data Items

Description
Formatting the data items in a chart can enhance the appearance of the chart and better 
communicate information in the chart. Depending on the chart type, you can set data item 
properties such as color, line style, marker style, and marker size.

Steps
1. Right-click the chart, click Properties, and then click the Format tab.

Check that the Chart Properties dialog box opened. If another dialog box opened instead, you 
did not have the chart selected. Click Cancel to close the dialog box, press Esc to clear your 
selection, and try again.

2. Click Customize Per Data Item and set any properties you want for any data items, then click 
OK twice.

Related Topics
• "Change the Chart Type" (p. 109)
• "Format a Chart" (p. 109)
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• "Add Chart Titles" (p. 110)
• "Format the Chart, Plot, and Legend Area" (p. 112)
• "Change the Axis Labels and Scale Settings" (p. 112)
• "Change the Grids Settings" (p. 114)
• "Hide or Show Data Labels in a Chart" (p. 115)
• "Add and Format a Chart Legend" (p. 115)
• "Show TrendLines" (p. 117)

Hide or Show Data Labels in a Chart

Description
You can hide or show data labels in a chart. You can also format the data labels by adding 
bolding, for example, as well as changing the font type and size.

Steps
1. Right-click the chart, click Properties, and then click the Format tab.
2. On the Format tab, in the Display options box, click Properties.
3. In the Properties dialog box, click the Data Labels tab.
4. To have data labels appear in the chart, select the Show Data Labels check box.
5. In the Labels Location box, choose where you want the labels located. You can choose

• Outside Maximum  
• Inside Maximum  
• Center  
• Base of Chart  

6. In the Label Format box, choose how labels appear. You can specify
• Value  
• Label  
• Label & Value  

7. Click OK twice.

Related Topics
• "Change the Chart Type" (p. 109)
• "Format a Chart" (p. 109)
• "Add Chart Titles" (p. 110)
• "Format the Chart, Plot, and Legend Area" (p. 112)
• "Format Chart Titles, Axis Titles, Data Labels, and Legend Text" (p. 111)
• "Change the Axis Labels and Scale Settings" (p. 112)
• "Change the Grids Settings" (p. 114)
• "Format Data Items" (p. 114)
• "Add and Format a Chart Legend" (p. 115)
• "Show TrendLines" (p. 117)

Add and Format a Chart Legend

Description
You can include a chart legend with your chart. When you add a legend, the chart is resized within 
the boundaries of the chart frame to accommodate the legend. You may have to adjust the chart 
frame to better present the chart and the legend together. When legend markers do not appear in 
the legend because there are too many to fit within the legend boundaries, an arrow indicates that 
there are more markers.
Impromptu User Reference  115



Chapter 17: Create and Customize a Chart 
 

After you add a legend, you can specify the location of the legend relative to the chart. You can 
also specify the location of the markers and legend text and set the style of the legend frame.

If you are upgrading charts with legends, the legend will appear to the right of the chart and 
legend markers to the left of the legend text. You can change this if you want.

Steps
1. Right-click the chart, click Properties, and then click the Format tab.

Check that the Chart Properties dialog box opened. If another dialog box opened instead, you 
did not have the chart selected. Click Cancel to close the dialog box, press Esc to clear your 
selection, and try again.

2. On the Format tab, click Properties, and on the Look tab, click Show Legend.
3. In the Markers and Text box, specify the location of legend markers and text by clicking one 

of the following:
• Markers to Left of Text  
• Markers to Right of Text  
• Text Centered on Marker  
• Markers Above Text  
• Markers Below Text  

4. In the Layout box, specify the location of the legend. You can specify
• Legend on the Right Side  
• Legend on the Left Side  
• Legend Below Chart  

5. In the Box Style box, specify whether to include a box frame and the box style for the legend.
6. Click OK twice.

The chart legend appears in the chart with the characteristics you specified.

What if ...
• You are upgrading charts with legends?

The legend shows to the right of the chart. Legend markers show to the left of the legend text. 
• You want to change the font type, style, and color of the text in the legend. 

On the Format tab, in the Font formatting box, specify Legend text and click Edit.
• You want to exchange the values in the legend for the values on the primary axis?

In the Chart Properties dialog box, click the Data tab and select the Pivot data check box. The 
Pivot data check box is not valid for some types of charts.

Related Topics
• "Change the Chart Type" (p. 109)
• "Format a Chart" (p. 109)
• "Add Chart Titles" (p. 110)
• "Format the Chart, Plot, and Legend Area" (p. 112)
• "Format Chart Titles, Axis Titles, Data Labels, and Legend Text" (p. 111)
• "Change the Axis Labels and Scale Settings" (p. 112)
• "Change the Grids Settings" (p. 114)
• "Format Data Items" (p. 114)
• "Hide or Show Data Labels in a Chart" (p. 115)
• "Show TrendLines" (p. 117)
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Show TrendLines

Description
A trendline is a line that indicates the general direction of a series of data over time. For example, 
are production costs trending up? Are sales increasing year after year? 

Important: Trendlines do not predict the future. They merely show trends in data based on 
historical information.

A trendline can connect all actual data points or it can be a line that is computed mathematically, 
such as the moving average line. In the latter instance, the line smooths the fluctuations of the 
actual data points in the series. The data points through which the trendline is drawn, or that it 
approximates, can represent individual data elements or groups of data elements such as averages 
or medians.

You can add trendlines to the following charts: area, bar, line, and scatter.

You can draw linear, logarithmic, polynomial, exponential and moving average trendlines.

Steps
1. Right-click the chart, click Properties, and then click the Format tab.

Check that the Chart Properties dialog box opened. If another dialog box opened instead, you 
did not have the chart selected. Click Cancel to close the dialog box, press Esc to clear your 
selection, and try again.

2. On the Format tab, click Trendlines, and select the Show Trendlines check box. With 
trendlines selected, you can then make the following changes: 

3. Click OK twice.

Related Topics
• "Change the Chart Type" (p. 109)
• "Format a Chart" (p. 109)
• "Add Chart Titles" (p. 110)
• "Format the Chart, Plot, and Legend Area" (p. 112)
• "Format Chart Titles, Axis Titles, Data Labels, and Legend Text" (p. 111)
• "Format a Chart" (p. 109)

Goal Action

Specify the type of trendline to draw. In the Regression Type box, click a trendline 
type.

For a polynomial trendline, you must specify 
the degree of linear regression in the Order 
box. The value must be greater than one but 
no greater than the number of groups in the 
chart.

For Moving Average, you must specify the 
number of periods in the Period box. The 
value must be greater than 1 and less than 
the number of groups.

In the chart, show the equation that was used 
to calculate the trendline.

Select the Show Equation check box.

In the chart, show the coefficients values 
used to draw the trendline.

Select the Show Coefficients Values check 
box.

Have the trendline appear in the same color 
as the selected data series.

Select the Show Color same as Series check 
box.
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• "Change the Axis Labels and Scale Settings" (p. 112)
• "Change the Grids Settings" (p. 114)
• "Hide or Show Data Labels in a Chart" (p. 115)
• "Add and Format a Chart Legend" (p. 115)

Correlation Chart
A correlation chart plots data using columns or bars and a line. To identify the data item plotted 
by the line, see the Chart Properties, Data tab, Primary Axis box while in a chart. The last data 
item listed in the Primary Axis box is plotted by a line on the Y2 axis. This data item cannot be 
moved to the Y1 Axis.

A correlation chart always has a dual axis. To view the data items plotted by the Y1 and Y2 Axis, 
see the Properties dialog box, Dual Y Options tab.

For information about how to create a correlation chart, see (p. 118).

For information about how to format a correlation chart, see (p. 118).

Example - Create a Correlation Chart to Show Order Income Relative to Order Revenue

You are a report author at The Great Outdoors Company. You are requested to create a chart that 
shows the correlation between order revenue and order income from 2004 to 2006. You decide to 
create a correlation chart because it allows you to correlate two dissimilar measures.

Steps
1. From the File menu, click New and on the FastFind tab, click Blank, and click OK.
2. In the Open Catalog dialog box, click gosales.cat and click Open.
3. If you are prompted for a userid and password, type Administrator in the UserID box and 

leave the Password box empty. Click Log On.
4. In the Catalog Logon for GOSALES.CAT dialog box opens, accept the default values and 

click OK.
5. In the Query dialog box, define the report query as follows:

• Click the calculation button and in the Calculation Definition dialog box, create the 
expression, year (Orderdate), name it Order Year, and click OK.

• On the Data tab, add Order Income, and Order Revenue to the Query data box.
• On the Group tab, click Order Year and click Group. Click Order Income and click 

Associate. Do the same for Order Revenue. Click OK.
6. From the Insert menu, click Chart Frame and drag the pointer to create the chart frame.
7. In the Chart Properties dialog box, in the Primary Axis box, remove the data items listed by 

default, and add Order Revenue followed by Order Income. Click OK.
8. Right click the chart, click Properties, and in the Chart type box, click Correlation and click 

OK.
The last data item in the Primary Axis list appears as a line in the correlation chart. In our 
example, this is Order Income.

9. Save the report and name it correlation_chart.imr.
You are now ready to format the chart (p. 118). 

Example - Format the Correlation Chart Correlation_chart.imr

You created a correlation chart named correlation_chart.imr that shows the relationship between 
order revenue and order income (p. 118). You want to format this chart before you distribute it 
throughout your department.

Steps
1. With correlation_chart.imr open, right-click on the chart, click Properties, and click the 

Format tab.
2. In the Chart background box, click Chart area, and Edit. On the Fill tab, click dark gray and 

click OK.
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3. In the Chart background box, click Plot area, and Edit. On the Fill tab, click light gray and 
click OK.

4. Click Titles, and add a Title, Footnote, Value Title (Y1) and Value Title (Y2). Name them as 
follows:
• for Title, type Order Income 
• for Footnote, type Order Income Correlated to Order Revenue
• for Value Title (Y1), type Order Revenue 
• for Value Title (Y2), type Order Income 

5. To format the chart titles, in the Font formatting box, click the title, and click Edit. In the 
Formatting dialog box, specify the font, font size and style and alignment.

6. To add a legend, click Properties, click the Look tab, specify the following legend settings and 
click OK:
• Markers to the Right of Text  
• Legend below Chart  
• Beveled Frame  

7. To customize the data items in the chart, click Customize per Data Item. In the Color column, 
click the Order Revenue color. In the Formatting dialog box, click Pattern, and specify a 
pattern. Experiment with different background and foreground colors until you get an 
acceptable combination. Click OK.
Your chart should look something like this:

Tip: To make the bars in the chart narrower, increase the gap width. On the Format tab, click 
Properties, and on the General tab, increase the Gap Width value.
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Chapter 18: Reporting While Disconnected From 
the Database

When you are disconnected from the database, you can use a snapshot to work with reports. A 
snapshot is a permanent local copy of the data in your report. Like a photograph, a snapshot 
captures a picture of the data as it existed when you created the snapshot.

Snapshots
When you open a snapshot report, the report accesses data stored in a snapshot located on your 
personal computer.

Why Use Snapshots?
Snapshots let you
• save historical data that otherwise would be updated or lost
• access and manipulate data when you are unable to attach to the database
• minimize data processing when the network traffic for the database is heavy
• e-mail a report and its data to someone as a file attachment

You can also save a snapshot as another file format. For more information about the file formats 
available see, "Export a Report" (p. 21).

Used properly, snapshots can improve the efficiency of your report.

Because each snapshot is its own independent, static data source, certain restrictions apply to 
snapshots.

What You Can Do
You can
• drag and drop to move parts of a report within the snapshot report
• Ctrl+drag to make copies of parts of a report

What You Cannot Do
You cannot
• add new data to a snapshot such as new tables or new filters
• create new calculations that are based on data items that are not part of the snapshot
• cut and paste or drag and drop data between snapshot reports
• save a report that contains sub-reports as a snapshot

When you save a snapshot with your report, the data and the report are saved as one file, and the 
data in the report is static. If the database for your report is updated after a snapshot is taken, the 
data in the snapshot does not change to reflect the updates. If you want to use the updated data, 
you must refresh the snapshot.

Note
• Do not use snapshots to send highly sensitive or confidential information. No security 

measures are included in a snapshot. As a result, snapshots can be accessed by anyone with 
Impromptu.
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Comparing Snapshots to HotFiles
When you use a snapshot, you separate the report from its original data source. Other Impromptu 
users can access a snapshot report without having to connect to the original source database or 
catalog. All you need is Impromptu to run the report. 

A HotFile is a table of data. You need a catalog to bridge the report and the HotFile it accesses. 
You need Impromptu and the catalog to view a report that uses a HotFile.

You can save historical data using either a snapshot or a HotFile. The following table compares 
snapshots to HotFiles:

What You Can Do with a Snapshot but Not with a HotFile
With a snapshot, you can
• have all the data you need for your report in one file
• e-mail your report to someone as a single file attachment
• open a report without accessing a catalog

Related Topics
• "Retrieve Data from the Database" (p. 37)
• "Create a Local Copy of the Report Data" (p. 122)
• "Refresh a Local Copy of the Report Data" (p. 123)
• "Remove a Local Copy of the Report Data" (p. 124)

Create a Local Copy of the Report Data

Description
A snapshot is a permanent local copy of the data in your report. Like a photograph, it captures the 
data as it existed when you created the snapshot. 

Example
You create and save a snapshot of the current monthly sales report to compare it to future 
monthly sales reports.

Steps
1. From the Report menu, click Query and click the Access tab.
2. In the Data Source box, click the Local Snapshot option button and click OK.

The indicator on the lower-right corner of the Impromptu window shows the Snapshot icon.

Snapshots HotFiles

Are integrated with the report. You cannot add 
new data to the report.

Are separate, local data tables. A HotFile that is 
included in the catalog enables you to add 
additional data to the report.

Have many cut and paste restrictions. Have no cut and paste restrictions.

Cannot be added to your catalog. Can be added to your catalog.

Cannot be used to create a new report with 
data.

Can be used to create a new report with data.

Stand alone. Do not stand alone.

Do not require catalog access. Require catalog access.

You cannot apply filters or calculations that 
use data not included in the snapshot.

You can add filters and calculations.
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Snapshot icon 

More Info

Notes
• You cannot save a report that contains sub-reports as a snapshot. 
• You can save a snapshot as another file format. The file formats available in Impromptu 

include Delimited ASCII,  Excel with Format, HotFile, PDF, XML, Hypertext Markup 
Language and text.

• The Show SQL box (Profile tab, Query dialog box) shows the SQL required to create the 
snapshot. If you add filters or calculations to the snapshot, the SQL box doesn't change.

Tips
• To quickly create a snapshot, click the Snapshot button on the toolbar.

Snapshot button 
• To save your report as a snapshot, from the File menu, click the Save As command and select 

the Save a Snapshot with the Report check box.

What if...
• The Save a Snapshot With the Report option (Save As dialog box) and the Snapshot button 

are not available?
The report is already a snapshot or the report contains sub-reports. You cannot save a report 
that contains sub-reports as a snapshot.

• You do not have an Access tab?
From the Tools menu, click Options, and click the General tab. Select the Show Advanced 
Tabs in the Query Dialog Box check box.

Related Topics
• "Reporting While Disconnected From the Database" (p. 121)

Refresh a Local Copy of the Report Data

Description
You can refresh a snapshot with the current data to reflect the most recent changes in the 
database. When you refresh a snapshot, the data from the original snapshot is lost.

Example
The latest sales data for the last quarter has been updated in the database. Before you go away on 
business, you add the new sales data by refreshing your snapshot.

Steps
1. From the Report menu, click Query and click the Access tab.
2. In the Data Source box, click the Database option button and click OK to reconnect to the 

database.
3. Repeat step 1 to show the Access tab (Query dialog box).
4. Click the Local Snapshot option button and click OK to capture the new database 

information.
Impromptu refreshes your snapshot with the new data from the database.

More Info

Tip
• To quickly refresh a snapshot with the current data, click the Snapshot button on the toolbar. 

In the Report Snapshot dialog box, click Refresh the Snapshot and click OK. 
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What if ...
• You do not have an Access tab?

From the Tools menu, click Options, and click the General tab. Select the Show Advanced 
Tabs in the Query Dialog Box check box.

Related Topics
• "Reporting While Disconnected From the Database" (p. 121)

Remove a Local Copy of the Report Data

Description
When you need more data than is in the snapshot, you can remove a snapshot from a report and 
retrieve data from the database instead.

Example
The snapshot you created last month for your accounts payable report only contains the data 
from the San Diego office. Since you now need data from the entire west coast, you remove the 
snapshot from the report and redirect your query to the database.

Steps
1. From the Report menu, click Query and click the Access tab. 
2. In the Data Source box, click Database, and then click OK.

Your query retrieves the data from the database. The indicator on the lower-right corner of 
the Impromptu window now shows the database icon.

More Info

Tip
• To quickly remove a snapshot from a report, click the Snapshot button on the toolbar. In the 

Report Snapshot dialog box, click Remove the Snapshot and then click OK.

What if ...
• You do not have an Access tab?

From the Tools menu, click Options, and click the General tab. Select the Show Advanced 
Tabs in the Query Dialog Box check box.

Related Topics
• "Reporting While Disconnected From the Database" (p. 121)
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Description
If you use Impromptu Web Reports to distribute your reports over the Web, you can set up 
drill-through access to Cognos Query. Impromptu Web Report users can view your Impromptu 
reports in PDF format, drill through to Cognos Query, and then explore the data in their Web 
browsers. Before you publish the report in Impromptu Web Reports, you can test drill-through 
access by drilling through from the Impromptu report.

Steps
1. Open the report to drill through to Cognos Query.
2. Select a report item that has drill-through access set up.
3. From the Report menu, click Drill Through and then click Cognos Query.

The Drill Through URLs to Cognos Query dialog box appears.
4. Click the query that users will drill to and then click Execute URL.

Related Topics
• "Import a Query from Cognos Query" (p. 35)
• "Select the Cognos Query Server" (p. 125)
• "Set Up Drill-Through Access to Cognos Query" (p. 126)
• "View the Details of a Value in a Report" (p. 10)

Select the Cognos Query Server

Description
Specify a Cognos Query server before you test drill-through access from the Impromptu report.

Steps
1. Open Impromptu.
2. From the Tools menu, click Options and then click the Drill Through tab.
3. In the Cognos Query Server box,

• for a simple install, type your Web server name (for example, wotalaventus1).
• for a distributed install, type the location and name of the Cognos Query gateway.

4. Click OK.

More Info

Note
• The default protocol for drill through to Cognos Query is /cognos/cgi-bin/cqcgi.exe.

Related Topics
• "Drill Through to Cognos Query" (p. 125)
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Set Up Drill-Through Access to Cognos Query

Description
You can use Impromptu Query Definition files (*.iqd) to set up drill-through access to Cognos 
Query. However, before you save a query in Cognos Query, click the Enable Drill Through 
Properties check box to store information about the query in an Impromptu Query Definitions file 
(*.iqd).

Steps
1. Open Impromptu.
2. Open the parent report (the one that users will drill from) and click any data item.
3. From the Report menu, click Drill Through and then click Properties.

The Drill Through Properties dialog box appears.
Note: If the Drill Through Properties command (Report menu) is unavailable, click Options 
(Tools menu), select the Drill Through tab, and then select the Enable Drill Through 
Properties check box.

4. Select the column you want to drill through to a query from Cognos Query and click Add.
The Add Drill Through Query/Report dialog box appears.

5. Select any additional columns that you want to include in the drill-through report filter.
6. Type file name for the drill-through query (*.iqd), or click Browse to find it.
7. Click OK twice.

Impromptu validates the file name for the query report, but does not verify whether the 
selected columns exist in the query from Cognos Query.

Related Topics
• "Drill Through to Cognos Query" (p. 125)
• "Import a Query from Cognos Query" (p. 35)
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Reports

Prepare a Report for Impromptu Web Reports
You can deliver Impromptu reports to the Web either by using Impromptu Web Reports or by 
publishing them directly to Upfront via the IWR server. When you change Impromptu reports to 
package them for Impromptu Web Reports, be aware of the report characteristics described in this 
chapter. For information about publishing reports directly to Upfront, see the Impromptu 
Administration Guide.

Bookmark with Undefined Destination
If you use a data item to group the data in a report, but do not include it in the report, then 
Impromptu Web Reports generates a bookmark that has no destination in the PDF report.

CognosScript and Macros
Impromptu Web Reports does not support CognosScript or AutoRun macros. If your report uses 
these features, your report administrator can automate the reports using events. The report 
administrator may also need to create HotFiles for dependent reports, because these reports are 
usually executed in Impromptu by using macros.

Connection String and Multiple Servers
Work with the report administrator to determine a strategy for providing all report servers with 
the same database connection string. If the current database connection string in the catalog 
cannot be used by the report servers, you may have to modify the string before the catalog is 
published to the Web.

For more information, see your report administrator.

Database Userid and Password
If you are using your Impromptu catalog for security, ensure that the Impromptu catalog you 
package contains a database userid and password in each user profile. If you are using Access 
Manager for database security, you don't need to do this.

Note: Catalogs generated in Architect always use Access Manager for database security.

Distributed Catalogs
You should disconnect personal catalogs used in Impromptu Web Reports from the master 
catalog. Any changes to the master catalog are not reflected in your personal catalogs.

If you package reports that access an Impromptu distributed catalog and the master catalog is 
updated, you must repackage your reports with the updated personal catalog. Ensure that you 
don’t include the master catalog with your repackaged reports and personal catalog.

Drill-Through Access to More Than One Report or Query
You can set up drill-through access to more than one report or query from the same report 
column. After you publish the report in Impromptu Web Reports, drill-through access is available 
to PDF and HTML report formats. With this access, report consumers can drill through to any of 
the reports or queries you set up.

For more information about setting up drill-through in Impromptu Web Reports, see the Cognos 
Web Portal User Guide.
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Failure to Publish From Impromptu to Impromptu Web Reports with Anonymous 
Access Configured in Access Manager
If anonymous access is enabled in Access Manager, you cannot publish from Impromptu to 
Impromptu Web Reports. Instead, you will receive an error saying that there was a failure to 
obtain a ticket.

To publish from Impromptu to IWR disable anonymous access in Access Manager.

Fit to Page
The Fit to Page feature only affects how Impromptu prints your report; it does not affect how 
Impromptu Web Reports displays your report in PDF format.

OLE automation and OLE Objects
If some reports contain links to OLE objects, you need to copy those objects manually to the 
Impromptu Web Reports server.

Note: OLE objects may not always behave as expected in the Web environment, and are valid 
only under Windows. In Web reporting applications, you should consider other alternatives.

Prepare HotFiles
If the report set contains HotFiles, you must know which operating systems the report set is going 
to be published on. For example, the format of HotFiles is different for UNIX and Windows. 
HotFiles for use on an Impromptu Web Reports server running on UNIX must be generated in 
UNIX.

If your report set is being published to Impromptu Report Servers that run
• only in Windows, include the HotFile in the report set
• both Windows and UNIX, you must repackage the HotFile each time you update the report 

set
• only in UNIX, the report administrator must create the HotFile in UNIX for you to include in 

the final report set

For more information, see "Package HotFiles" (p. 129).

Repeated Bookmarks in PDF Reports
When you create reports in Impromptu, do not insert a data item into the page header. If you do, 
Impromptu Web Reports generates the report with repeated bookmarks that link only to the page 
where the page header changes.

Restriction on Using Equals Sign in Prompt Names
Report authors and administrators who publish to Impromptu Web Reports should be aware of 
the following restriction when creating report prompts: if the prompt name contains an Equals 
sign (=), users will be unable to run a report based on that prompt. 

Only by deleting the non-supported character from the prompt name and republishing the report 
can the user successfully select a prompt and run the requested report.

Screen Layout View
You must change all reports in Screen Layout view to Page Layout view because Impromptu Web 
Reports shows all reports in Page Layout view.

Using a Locked Catalog
Impromptu administrators can add a lock to a catalog. In Impromptu Web Reports, the catalog 
Creator user class cannot run reports using a locked catalog. If a user attempts to run a report 
using the catalog Creator user class, they receive an error message. To run the report successfully, 
use a non-Creator user class. 

View Reports in Excel
Some limitations apply when exporting reports to Excel. For more information, see Mastering 
Impromptu Reports.
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Related Topics
• "Create Burst Reports" (p. 129)
• "Notify the Report Administrator" (p. 130)

Create Burst Reports

Description
You have to add some user classes and filters when creating a report that will be a burst report in 
Impromptu Web Reports.

In the Impromptu Administrator, set up the catalog then 

Steps
In the Impromptu Administrator, set up the catalog. 
1. Open Impromptu.
2. Open the catalog from which you want to generate reports.
3. From the Catalog menu, click User Profiles.
4. Click the User Classes tab and add the user classes you want for your burst report.

For more information on adding user classes, see the Mastering Impromptu Reports book.
5. Click the Filter tab.
6. In the User Class list, click one of your user classes and create a specific filter for it.
7. Repeat step 6 for each user class for which you want to apply a filter.

Using either the Impromptu User or Impromptu Administrator,
8. Create a new report as the Creator user class and add the required columns (the columns that 

have a filter or prompt on them).
9. From the Catalog menu, click User Class and click one of your user classes.
10. From the Report menu, click Retrieve to verify that this user class displays a unique report.
11. Repeat steps 9 and 10 for each user class.

For more information on setting up a burst report in Impromptu Web Reports, see the Report 
Administrator's Guide.

Package HotFiles

Description

Package HotFiles for Both Windows and UNIX
To ensure that a report set can be published to Impromptu Web Reports servers running in either 
Windows or UNIX, you must package both the original report and the HotFile that it creates in 
the same directory. This ensures that the directory can be used to publish the report set to either 
operating system. After the report set is published, the instructions that you give to the report 
administrator depends on the operating system that the Impromptu Web Reports server runs on:
• If the report set is published to an Impromptu Web Reports server running in Windows, you 

only need to tell the report administrator to hide the original report from report consumers.
• Reports that source Hotfiles published to UNIX must be run at least once before other IWR 

reports can access them.
You must tell the report administrator to perform this procedure every time you publish or 
update this report set.

Package HotFiles for UNIX
The format of HotFiles is different for UNIX and Windows. HotFiles for use on an Impromptu 
Web Reports server running on UNIX must be generated in UNIX.
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Steps for UNIX only
1. Find the report that creates the HotFile from the report set and package it in the same 

directory.
2. Tell the report administrator to publish that report set to an Impromptu Web Reports server 

running on UNIX, run the report (.imr), and save the results in a HotFile using the same name 
as the original HotFile.

3. Have the report administrator FTP that HotFile back to you.
4. Add the new HotFile to the same directory containing all the reports in the report set.
5. Tell the report administrator to publish the report set to UNIX.

This ensures that the directory always contains a HotFile that works in UNIX.

Notify the Report Administrator
After you package reports sets, you need to tell the report administrator
• the location of the database and any connection parameters
• the amount of disk space the report set uses
• if the catalog contains a database ID and password
• if the report set is new or updated
• if the report set has been updated, any changes to user profiles
• which reports should be generated as HotFiles
• which reports read or write which HotFiles
• which reports are used as a data source for other reports
• which reports contain links to OLE objects
• which reports use stored procedures or prompts
• which reports use PowerPrompts applications or user-defined functions (UDFs)
• which reports need to be scheduled to run and when
• which reports are dependent on other reports or events
• if any reports contain access to drill-through reports
• who needs to see the reports

For more information about what the report administrator needs to know after the report sets are 
packaged, see the Impromptu Web Reports Administrator Guide.
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A PowerPrompts application guides report consumers through a series of HTML pages where 
they select the information that they want in a report. The report consumer then sees the report 
that is generated based on the selections. For example, using a PowerPrompts application report 
consumers can modify
• columns in a report
• column formatting
• a report template
• conditional formatting
• filters
• prompts and prompt values

Use PowerPrompts Developer Studio to create these Web-based applications for Impromptu Web 
Reports; it is available with both the Administrator and the User versions of Impromptu. 
PowerPrompts applications do not interfere with the use of report or catalog prompts.

For more information about PowerPrompts, see the PowerPrompts online help.
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Attribute Maximum

bitmap size Limited only by available memory

Column width Limited only by available memory

Number of group headers and footers 10

Height of headers and footers Limited only by available memory

Height of report Limited only by available memory

Largest allowed negative number Database dependent

Largest allowed positive number Database dependent

Number of characters in a column name No known limit

Number of colors available Limited by the number of colors supported by 
your monitor or printer

Number of report columns Limited only by available memory. However, 
your database may impose a lower limit.

Number of tables in query 128

Number of fonts per report Limited only by available memory

Number of open reports Limited only by available memory

Number of sub-reports in report Limited only by available memory.

Number of Toolbar buttons per Toolbar 100

Number of parameters in a stored procedure 
call

15

Number precision Database dependent

Number of printed pages Limited only by available memory

Row height Limited only by available memory

Smallest allowed negative number Database dependent

Smallest allowed positive number Database dependent

SQL character length 32,766 characters

Report width Limited only by available memory.
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File Searching
Impromptu catalogs and reports use other files. For example, a catalog may
• use a HotFile
• contain a prompt that is a report picklist
• be a distributed catalog pointing to the master distributed catalog

A report includes a reference to a catalog file and can also include references to
• picklist reports
• bitmaps
• HotFiles
• other files

The fully qualified paths for these associated files are stored in the catalog or report. For users to 
easily share catalogs and reports, Impromptu incorporates file searching capabilities to locate the 
associated files when a catalog or report is opened.

When a user wants to share a catalog or report, the paths to at least some of the associated files 
may be different on the other user's computer.

Example
For example, you receive the following from another user:
• a report containing a reference to a .bmp file on the LAN
• a catalog

When you save these files and open the report, Impromptu recognizes that the paths in the report 
are not current and attempts to find the associated files.

How the Search Works
If you create a catalog or report using an associated file on a network, the path of the associated 
file is stored in Universal Naming Convention (UNC) format. Paths for local files are stored using 
local drive letters (LDLs). When an associated file cannot be found using the LDL or UNC path 
stored in the catalog or report, Impromptu searches for the file in this order:
1. In the current folder.
2. Using the stored path, but replacing the drive letter with the letter of the drive where the 

catalog or report file currently resides.
For example, the stored path is D:\1998\Reports. The report is opened on C:. Impromptu 
searches for C:\1998\Reports.

3. By deriving a relative path from the stored paths.
For example, the report was in C:\1998\Reports, and the associated file was in 
C:\1998\Reports\Bitmaps, then Impromptu searches for a \Bitmaps folder where the report 
file currently resides.

4. Using the actual catalog or report path.
5. Using the workspace path specified in Preferences.
6. Using the catalog path specified in Preferences (if Impromptu is looking for a catalog).
7. Using the report path specified in Preferences (if Impromptu is looking for a report).
8. Using a standard Windows search.

This includes a search of Impromptu’s main folder, the Windows folders and the path 
variable.
If the search is unsuccessful, Impromptu asks you to help locate the file.

Notes
• You can store both LDL and UNC paths for a file on a network.
• Impromptu does not use the search capability when you attempt to open a file from the most 

recent file list in the File menu.
• Enhanced file searching is not available through OLE automation.
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Command Line Switches

Description
You can use command line options when you start Impromptu to
• execute a macro
• open a specific report

The complete command line syntax is as follows:
IMPADMIN.EXE
   [-m macro-filename]
   [report-name]
or
IMPUSER.EXE
   [-m macro-filename]
   [report-name]

Notes
• You can also execute a macro from within Impromptu or using the Cognos Scheduler.
• Use double quotes to define a file name or pathname containing a space.

Related Topics
• "-m macro-filename" (p. 135)
• "macro-filename" (p. 135)
• "report-name" (p. 135)

-m macro-filename
Opens the macro text file and runs the commands within the file.

Discussion
Use the -m command line option for macros written using the Impromptu Macro Editor.

Example
This command starts Impromptu and specifies the macro to execute:
C:\Program Files\Cognos\cer3\bin\IMPADMIN.EXE -m monthly.mac

Limit
• 127 is the maximum number of characters for commands entered on the command line.

Related Topics
• "Command Line Switches" (p. 135)

macro-filename
Specifies the name of the macro file.

You can also specify the path for the macro file. By default, Impromptu looks first in the catalog 
directory and then in the current directory.

Related Topics
• "Command Line Switches" (p. 135)

report-name
Opens the specified report
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Discussion
Impromptu retrieves data depending on
• the settings in the Access tab (Query dialog box) that you access from the Report menu
• the preferences you set using the Options command (Tools menu)

Example
This command starts Impromptu and opens a report named summary:
C:\Program Files\Cognos\cer3\bin\IMPADMIN.EXE summary.imr

Limit
• 127 is the maximum number of characters for commands entered on the command line.

Related Topics
• "Command Line Switches" (p. 135)
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When you install Impromptu, the setup program automatically creates several .ini (configuration) 
files. Some of the initialization files created are
• Cognos.ini
• Cern.ini
• Impromptu.ini

If you upgrade from an earlier version of Impromptu, the setup program automatically updates 
your .ini files with new information and maintains the settings that still apply from the earlier 
version. Setup ignores settings that no longer apply. When you start Impromptu, it reads the .ini 
files and uses the settings that were used at the end of the last Impromptu session.

Impromptu uses the .ini files to define your Impromptu environment and configure it to match 
your preferences. The .ini files store preferences for environmental settings, such as
• formats and styles for report objects
• toolbar buttons
• data access options
• file locations for catalogs and reports

Warning
• Normally, Impromptu or the setup program updates initialization files automatically. If you 

edit .ini files manually, use caution. Always back up an .ini file before you change it so you 
can restore the original file if necessary.

Related Topics
• "Cern.ini" (p. 138)
• "Cognos.ini" (p. 138)
• "Function Definition Table (FDT) Files" (p. 138)
• "Impromptu.ini" (p. 139)
• "ini File Format" (p. 137)
• "Use Type Libraries" (p. 151)

ini File Format
.ini files contain several sections of related settings. Each section is in the following format:
[section name]
keyname=value

[section name]
The name of a section. The starting square bracket must be in the left-most column of the line.

keyname=value
Defines and names the value of a setting. A keyname can consist of any combination of uppercase 
or lowercase letters, digits, and spaces. The keyname must be followed immediately by an equal 
sign. The value can be an integer, a string, or a string enclosed in quotation marks.

You can include comments in the .ini files by starting a line with a semicolon (;). Blank lines are 
ignored.
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Related Topics
• "Configuration Files" (p. 137)

Function Definition Table (FDT) Files
FDT files mirror the information in the database function initialization files (.ini) and are created 
by Impromptu to improve its performance. FDT files are created for a new or modified .ini file the 
first time the .ini file is read while opening the catalog.

Updating the FDT files requires write privileges in the working directory. Your LAN users may not 
have the required privileges to create and modify the FDT files. To provide these users with FDT 
files, open a catalog that accesses the database supported by your enterprise
• when you first copy the Impromptu setup files to the LAN
• each time you modify the .ini file for the supported database

Related Topics
• "Configuration Files" (p. 137)

Cognos.ini
Previous versions of Impromptu created this file in your Windows folder to store configuration 
information.

Impromptu stores that information in Cern.ini in the Bin folder where Impromptu is installed. The 
exception is database connection information which remains in the Cognos.ini file.

Cognos.ini includes [Databases] preferences. Each user must have a Cognos.ini file that contains 
the appropriate database connection strings.

Related Topics
• "Configuration Files" (p. 137)

Cern.ini
Configuration Manager is the user interface for maintaining your rendition settings. For 
information about these settings, see the Configuration Manager documentation.

The Impromptu state file location setting is Impromptu-specific and must be added explicitly to 
the rendition file. For a description of this setting, see [Cognos Locations].

Related Topics
• "Configuration Files" (p. 137)

[Cognos Locations]
Specifies other locations of Cognos applications and components.
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Impromptu state file location=<path>

Related Topics
• "Cern.ini" (p. 138)
• "Configuration Files" (p. 137)

Impromptu.ini
Specifies Impromptu preferences. This file is created or updated when you start Impromptu. Some 
entries in this file can be updated in Configuration Manager.

Impromptu.ini includes the following preferences:

[Data Attributes]

[Default Directories]

[Startup Options]

[Query Options]

[Object Attributes]

[Styles]

[Graph Default Colors]

[Query Statistics]

[MRU Files]

Note
• If you are distributing reports to users, ensure that the Impromptu.ini settings are consistent 

for all the users. For example, if you define styles in Impromptu.ini, use those styles in 
standard reports, and then distribute the reports to users without those styles in their 
Impromptu.ini files, the reports won't display properly for those users. You must modify their 
Impromptu.ini files to include the same styles included in your Impromptu.ini file.

Related Topics
• "Configuration Files" (p. 137)

Default The Impromptu state file location setting is not enabled by default. It must be 
explicitly added to the cern.ini file, where n represents the product rendition 
number.

Description Identifies where to create or find the Impromptu.ini file for an Impromptu 
User, Administrator, or workstation installation. When an Impromptu state file 
location is specified, Impromptu searches for the Impromptu.ini file in the state 
file location rather than in the default location. If the Impromptu.ini file does 
not exist in this location, it is created. Use an Impromptu state file location 
when you want to maintain one Impromptu.ini file for several users.

In a workstation installation, the cern.ini file in the shared LAN location must 
contain the Impromptu state file location. Users specify this location in the 
Application Destination Folder dialog box during installation. The Impromptu 
state file location must be the same for each workstation installation.

Example Impromptu state file location=C:\Program Files\State

To change Edit the Impromptu state file location entry added to the cern.ini file, where n 
represents the product rendition number.
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[Data Attributes]
Stores application-wide data format settings. By default, data is formatted using the General 
option which uses the user’s locale settings.

numeric format=<setting>

date format=<setting>

date time format=<setting>

time format=<setting>

interval format=<setting>

string format=<setting>

Default No default.

Description Shows the format of numeric data.

To change From the Tools menu, click Options and then click the Data Format tab.

Default No default.

Description Shows the format of date data.

To change From the Tools menu, click Options and then click the Data Format tab.

Default No default.

Description Shows the format of date-time data.

To change From the Tools menu, click Options and then click the Data Format tab.

Default No default.

Description Shows the format used for time.

To change From the Tools menu, click Options and then click the Data Format tab.

Default No default.

Description Shows the format of  intervals.

To change From the Tools menu, click Options and then click the Data Format tab.

Default No default.
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[Default Directories]
Defines the default directories for storing and locating the following files:
• Impromptu catalogs
• Impromptu reports
• temporary files (used for sorting and grouping)

temporary data path=<path>

catalog path=<path>

report path=<path>

user template path=<path>

Description Shows the format of string expressions.

To change From the Tools menu, click Options and then click the Data Format tab.

Default temporary data path=C:\TEMP

Description Sets where Impromptu creates temporary files.

To change From the Tools menu, click Options and then click the File Locations tab 
or edit the parameter in Configuration Manager.

Default catalog path=C:\Program Files\
Cognos\cern\Samples\Impromptu\Reports

Description Sets where Impromptu looks for catalogs.

To change From the Tools menu, click Options and then click the File Locations tab 
or edit the parameter in Configuration Manager.

Default report path=C:\Program Files\
Cognos\cern\Samples\Impromptu\Reports

Description Sets where Impromptu looks for reports.

To change From the Tools menu, click Options and then click the File Locations tab 
or edit the parameter in Configuration Manager.

Default user templates path=C:\Program Files\
Cognos\cern\Samples\Impromptu\Templates

Description Sets the location of user template files. User template files provide users 
with consistent access to templates across the entire application.

To change From the Tools menu, click Options and then click the File Locations tab 
or edit the parameter in Configuration Manager.
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workgroup templates path=<path>

default template=<path>

Related Topics
• "Impromptu.ini" (p. 139)
• "Configuration Files" (p. 137)

[Startup Options]
Sets Impromptu's startup attributes.

show QuickHelp=<setting>

connect to database=<setting>

Default workgroup templates path=C:\Program 
Files\Cognos\cern\Samples\Impromptu\Templates

Description Sets the location of workgroup templates. Workgroup templates provide 
uses with consistent access to templates across the entire application.

To change From the Tools menu, click Options and then click the File Locations tab 
or edit the parameter in Configuration Manager.

Default default template=C:\Program Files\
Cognos\cern\Samples\Impromptu\templates\
standard\simple list.imt

Description  Sets the location of the default template to use when creating a new report.

To change From the Tools menu, click Options and then click the File Locations tab or 
edit the parameter in Configuration Manager.

Default show QuickHelp=1

Description Sets whether Impromptu shows QuickHelp as the mouse pointer moves 
over buttons on the toolbars.

To change From the Tools menu, click Toolbars, and then clear the Show the Toolbar 
QuickHelp check box.

Default connect to database=1

Description Sets whether Impromptu automatically connects to the database when 
opening a catalog.

To change From the Tools menu, click Options, click the Start-up tab, and then clear 
the Auto Attach to Database When Catalog is Opened check box.
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ruler displayed=<setting>

last used catalog=<CatalogName>

ruler in centimeters=<n>

catalog defrag threshold=<n>

Default ruler displayed=0

Description Sets whether to show the ruler.

To change From the View menu, click Ruler.

Default Determined when a new catalog is opened.

Description Sets the name of the last catalog opened.

To change Not applicable. This option resets each time a new catalog is opened.

Default ruler in centimeters=1

Ruler displays measurements in centimeters.

Description Sets whether the rulers displays measurements in centimeters or inches. To 
display measurements in inches set the value to 0.

To change Open a report and then under View, click Ruler.

Default catalog defrag threshold=66

Description Sets a threshold for the percentage of useful information. If a catalog 
becomes fragmented and falls below this threshold, the catalog 
defragments when explicitly closed. Click Close from the Catalog menu to 
explicitly close a catalog.

Defragmenting a catalog makes it smaller by removing wasted space in the 
catalog.

Defragmentation does not happen if

the catalog is read-only

there is insufficient disk space to perform defragmentation

To change Use a text editor to edit the Impromptu.ini file.

You can set the following values:

0 = Do not defragment the catalog.

100 = always defragments the catalog.

66 = value not set.
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report defrag threshold=<n>

windows maximized=<setting>

window size=<setting>

show invocation dialog=<n>

Default report defrag threshold=66

Description Sets a threshold for the percentage of useful information. If a report 
becomes fragmented and falls below this threshold, the report defragments 
when file is closed.

If you set Report Defrag Threshold to any value other than 0, the value is 
read as a percentage of the amount of accessible data in the report before 
the report is defragmented. If the percentage of accessible data falls below 
the threshold value you set, the report is defragmented and the unused data 
in the report is removed.

To change Use a text editor to edit the Impromptu.ini file.

You can set the following values:

0 = Do not defragment the reports.

100 = Always defragments the reports.

66 = The default value.

Default window maximized=0

Description Sets whether Impromptu maximizes on startup.

To change Maximize the Impromptu window.

Default Determines when the Impromptu window is resized.

Description Defines the size of the Impromptu window.

Example window size=0, 0, 1020, 690

To change Close Impromptu after resizing the Impromptu window.

Default Show invocation dialog=1

Description Determines whether to show the Welcome dialog box.

To change Use the Show this dialog in future check box in the Welcome dialog box or 
use the Show the Welcome to Impromptu dialog box check box in the 
Options dialog box.
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Always show catalog logon dialog=<setting>

maximize document=<setting>

file picklist delimiter=<c>

export HTML metadata=<n>

open lock warning message=<n>

Default Always show catalog logon dialog=1

Description Determines whether the Catalog Login dialog box appears when Access 
Manager can provide all the required logon information.

To change Use the Always Show this Dialog check box in the Catalog Logon dialog 
box or the Always Show Catalog Logon Dialog check box in the Options 
dialog box.

Default maximize document=1

Description Sets whether to show Impromptu reports as maximized.

To change Maximize or restore a report.

Default No default entry. When there is no entry, the value is a , (comma).

Description Specifies the picklist file separator.

To change Use a text editor to add and then edit this entry in the Impromptu.ini file.

Default No default. You must add this entry.

Description Specifies that HTML metadata is included in a report you save as HTML. 
The metadata describes report contents and individual values.

To change Use a text editor to add the following to the Impromptu.ini file:
[Startup Options]
Export HTML Metadata=1

Default No default. You must add this entry.

Description Specifies that a warning message doesn't appear when you try to open a 
report that another user has open or that is read-only.

To change Use a text editor to add the following to the Impromptu.ini file:
[Startup Options]
Open Lock Warning Message=0
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OverrideDistributed = <n>

Allow Lazy Path Matching=<setting>

Related Topics
• "Impromptu.ini" (p. 139)
• "Configuration Files" (p. 137)

[Query Options]
Sets query options, such as minimum free disk space and the number of rows to bulk fetch. 
Impromptu can retrieve more than one row of data in a single fetch call. Since none of the entries 
in this section appear in the Impromptu.ini by default, you may have to add this section before 
you add one its entries.

minFreeDiskSpace=<n>

Default No default. You must add this entry.

Description Specifies that you can continue to use the Tables and Joins commands 
when you edit personal distributed catalogs. In Impromptu 6.0, these 
commands are unavailable unless you add this entry.
In earlier versions of Impromptu Administrator, when using personal 
distributed catalogs the Tables and Joins commands (from the Catalog 
menu) were available. They shouldn't have been available and using them 
resulted in a loss of information.

To change Use a text editor to add the following to the Impromptu.ini file:
[Startup Options]
OverrideDistributed=1

Default No default. You must add this entry.

Description Add this setting when you are updating a report with a modified or 
different catalog than the one it was created with, and you want to enable 
matching on the first folder item with the same name as the report item.

By default, matching on the first folder item is disabled, because if all 
folder items in the new catalog don’t have unique names, then matching on 
the first folder item can generate SQL queries improperly. 

To change Use a text editor to add the following to the Impromptu.ini file:
[Startup Options]
Allow Lazy Path Matching=T

Default No default entry. When there is no entry, the value is 0 (meaning unlimited 
diskspace).

Description Sets the size of the internal swap file (in bytes) that Impromptu uses to 
cache query results. Defaults to unlimited disk space. If you want to reserve 
free disk space for other applications, set this entry to the desired level, for 
example, 100000 (approx. 100 KB). When the swap file reaches maximum 
size, performance may slow down if you scroll repeatedly across a large 
number of pages in a report.

To change Use a text editor to edit the Impromptu.ini file.
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bulk fetch rows=<n>

use parameterized query=<n>

use automatic ORACLE Decode=<n>

generate isnull join=<n>

Default No default entry. When there is no entry, the value is 100.

Description Specifies how many rows Impromptu retrieves in one fetch call if your 
database supports bulk fetch.
Note: A limit may have been placed on the number of rows Impromptu can 
retrieve. If that limit is lower than the bulk fetch rows value, Impromptu 
uses that limit instead. For more information on limiting the number of 
rows retrieved, see your Impromptu administrator.

To change Use a text editor to edit the Impromptu.ini file.

Default No default entry. When there is no entry, the value is 0 (meaning that 
parameterized queries are not used).

Description Specifies whether SQL parameters are used for prompt values in query 
statement.
In large queries with prompt values, use parameters in queries to increase 
performance. To use parameterized queries, add this entry and set the value 
to 1.

To change Use a text editor to edit the Impromptu.ini file.

Default No default entry. When there is no entry, the value is 1 (meaning that 
automatic ORACLE Decode is turned on).

Description Specifies whether to automatically generate Decode statements when 
running queries against an ORACLE database.
If an Impromptu query contains If statements, then a Case When statement 
is written into the SQL query for the database. However, ORACLE 
databases cannot process Case When statements, which must be processed 
locally.
For queries against ORACLE databases, use the automatic ORACLE 
Decode statements to increase performance. However, if these queries 
return the wrong results (possibly because of null or floating point 
numbers), turn off the automatic ORACLE Decode setting by adding this 
entry and set the value to 0.

To change Use a text editor to edit the Impromptu.ini file.

Default No default entry. When there is no entry, the value is 1.

Description Specifies whether isnull joins are created during SQLGroup transformation. 
To turn off isnull join creation, create this entry and set it equal to 0.

To change Use a text editor to edit the Impromptu.ini file.
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Related Topics
• "Impromptu.ini" (p. 139)
• "Configuration Files" (p. 137)

[Object Attributes]
Sets default formatting attributes, such as patterns or borders, for Impromptu report objects.

<ObjectAttribute>=<setting>, <setting>...

Related Topics
• "Impromptu.ini" (p. 139)
• "Configuration Files" (p. 137)

[Styles]
Stores defined style names used in reports and templates.

Note
• If you deploy reports to other users, ensure that the [Styles] section of their Impromptu.ini 

files contains <Stylename=> entries for the styles used in your reports, and that there is a [Style 
- <Stylename>] entry for each style defined in the [Styles] section.

Default Form Border=1,0,0,0,1,0,0,0,1,0,0,0,1,0,0,0
Report Border=1,0,0,0,1,0,0,0,1,0,0,0,1,0,0,0
List Border=1,0,0,0,1,0,0,0,1,0,0,0,1,0,0,0
Crosstab Border=1,0,0,0,1,0,0,0,1,0,0,0,1,0,0,0
OLE Border=1,0,0,0,1,0,0,0,1,0,0,0,1,0,0,0
Graph Border=1,0,0,0,1,0,0,0,1,0,0,0,1,0,0,0
Bitmap Border=1,0,0,0,1,0,0,0,1,0,0,0,1,0,0,0
ColumnTitle Border=1,0,0,0,1,0,0,0,1,0,0,0,1,0,0,0
Rectangle Border=1,0,0,0,1,0,0,0,1,0,0,0,1,0,0,0
Text Pattern=0,255,255,255,0,0,0
ColumnTitle Pattern=0,255,255,255,0,0,0
Form Pattern=1,255,255,255,0,0,0
Report Pattern=1,255,255,255,0,0,0
List Pattern=0,255,255,255,0,0,0
Rectangle Pattern=0,255,255,255,0,0,0

Description Sets the default format for Impromptu report objects.

To change From the Tools menu, click Options and then click the Object Format tab.
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<StyleName>=

Each style listed in the [Styles] section, is followed by a separate [Style - <Stylename>] entry that 
looks like this:
[Style - Light Emboss]
Border=1,255,255,255,1,128,128,128,1,128,128,128,1,255,255,255
Pattern=1,192,192,192,0,0,0
The Style entries define borders, a pattern, a font, and a color for each Impromptu default style as 
well as any styles you have defined.

Default Light Emboss=
Dark Emboss=
Column Title Emboss=
Light Etch=
Dark Etch=
Transparent=
Heading 1=
Heading 2=
Heading 3=
Heading 4=
Heading 5=
Poor (Color)=
Normal (Color)=
Good (Color)=
Poor (Mono)=
Normal (Mono)=
Good (Mono)=
Blue Sky 1=
Blue Sky 2=
Blue Sky 3=
Blue Sky 4=
Sea Blues 1=
Sea Blues 2=
Sea Blues 3=
Sea Blues 4=
Seeing Red 1=
Seeing Red 2=
Seeing Red 3=
Seeing Red 4=
Mellow Yellow 1=
Mellow Yellow 2=
Mellow Yellow 3=
Mellow Yellow 4=
Grass Green 1=
Grass Green 2=
Grass Green 3=
Grass Green 4=

Description Stores names of Impromptu report styles.

Example [Styles]
Raised Button=
Lowered Button=
High Risk=

To change Add new styles or modify existing ones, use the Styles dialog box. To access 
the Styles dialog box, with a report open, under the Format menu, click 
Styles.
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Related Topics
• "Impromptu.ini" (p. 139)
• "Configuration Files" (p. 137)

[Graph Default Colors]
Specifies the default colors for color palettes and patterns.

<ObjectAttribute>=<setting>, <setting>...

Related Topics
• "Cern.ini" (p. 138)
• "Configuration Files" (p. 137)

[Query Statistics]
Stores statistics for Impromptu queries.

<ReportName> = <statistic>, <statistic>...

Related Topics
• "Impromptu.ini" (p. 139)
• "Configuration Files" (p. 137)

Default Custom Colors=65793,8388608,32768,8421376,
128,8388736,32896,12632256,8421504,16711680,65280,
16776960,255,16711935,65535,16777215

Custom Pattern IDs=1,2,3,4,5,6,7,8,9,10,11,
12,13,14,15,16

Description Specifies the default colors for color palettes and patterns.

Default Created or updated automatically when a report is run.

Description Stores statistical information about Impromptu queries. Impromptu uses 
the entries in the Query Statistics section to provide query feedback. This 
information is shown in the Profile tab (Query dialog box) as the average 
number of seconds to execute the query and the average number of rows 
the query returns. Impromptu updates the Query Statistic entry each time a 
report is run, resulting in increasingly accurate statistics as reports are 
used.

Example C:\Program 
Files\Cognos\cer3\Samples\Impromptu\Reports\Ppview.imr=793994733,0,
0.000000,0.000000,2,54.000000,1458.000000

To change Do not change these entries. If you delete this information, you will lose 
the query performance information shown in the Profile tab (Query dialog 
box).
Note: Impromptu automatically deletes these entries based on file 
existence. If a query statistics entry is more than 60 days old, Impromptu 
checks for the existence of the file containing the associated report. If the 
file no longer exists, Impromptu deletes the Query Statistic entry.
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[MRU Files]
Stores a list of the most recently used reports and templates.

MRUF<n>=FileName

Related Topics
• "Impromptu.ini" (p. 139)
• "Configuration Files" (p. 137)

Use Type Libraries

Description
Type libraries contain the available components of the OLE automation server, including 
information about those components and how to use them. The type library can show
• arguments and return types of the methods
• properties for objects defined by the server application
• definitions for custom data types such as enumerations, unions, data structures, and 

non-interface functions that can be called from a .dll
• be used with C++

If you use macros for Impromptu, you can use the type library file, ImpClient.tlb, that comes with 
Impromptu.

ImpClient.tlb contains information about automation objects and collections, along with their 
properties and methods. Instead of using the Cognos Script Editor, you can use the information in 
ImpClient.tlb to build macro scripts in Visual Basic or create header files and implementation files 
in Visual C++.

You can also use other applications, such as, Word or Excel, to open the type library (through a 
Visual Basic-compatible editor).

Notes
• The use of the Impromptu type library with Visual Basic is not supported.
• Type libraries and OLE automation only work in Windows deployment environments. They 

do not work in other environments, such as, UNIX.

Steps
1. Open Developer's Studio.
2. Open a project.
3. From the View menu, click Class Wizard.
4. Click Add Class and then click From a Type Library.
5. Select ImpClient.tlb.

Default Not applicable. Determined when you work with reports and templates.

Description Stores the names of the most recently used reports and templates. 
Impromptu shows the names in the recent file list in the File menu.

Example [MRU Files]
MRUF1=C:\Program 
Files\Cognos\cer3\Samples\Impromptu\Reports\Report1.imr
MRUF12=C:\Program 
Files\Cognos\cer3\Samples\Impromptu\Reports\Xform01.imr

To change Changes when you work with a new report or template.
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6. In the Confirm Classes box, click the classes you want and click OK.
7. In the Workspace, click Class View to show the selected classes and their objects.

Note: Only methods are shown for objects, not properties.
8. In the Workspace, click File Viewer to view the object definitions in the ImpClient.h file.

You can now create objects in implementation files (*.cpp).
9. Use both types of files in the application you are writing or editing.

Note
• Always refer to the Macro online help if there is a discrepancy in object and collection names.
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Chapter 24: Get Help on Basic and Advanced 
Topics

This Help File
The Impromptu online Help is structured to meet the needs of its primary audiences: the report 
viewer and report creator.
• Report viewers view, print, or export information found in existing reports.
• Report creators create reports using the Report Wizard or a template, and apply essential 

skills, such as sorting, grouping, formatting, and basic filtering.

All the information needed to perform essential tasks in Impromptu is in the online Help.

Mastering Impromptu Reports
If you are an advanced report author (you create complex reports for others), see the topic in the 
Mastering Impromptu Reports online help file that is provided with Impromptu.

Comprehensive Index
A comprehensive index for the online Help contains keywords for topics within both the online 
Help files.
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Chapter 25: Troubleshooting

For information about errors during the installation, see the readme file. The following error 
messages may be resolved by following the suggestions in the solution section.

Cannot Access the Datasource

Error Message
DMS-E-DBACCESS, It was not possible to access <logical database name> database.

[Microsoft][ODBC DLL] datasource name not found and no default driver specified.

Information
Occurs when you attempt to open a catalog or when you connect to the database using 
Impromptu. Impromptu cannot open the target datasource.

Solution
Check the following information
• That the ODBC driver has been installed and configured correctly through the Microsoft 

ODBC Administrator. Verify that the entry for your data source is in the Odbc.ini file.
• That the Impromptu logical database definition is correct, confirm that the correct ODBC 

data source is specified. Check that the database definition is in the [Databases] section of the 
Cognos.ini.

• That you are using a 32-bit ODBC driver.
• That you have the latest version of the ODBC driver, including all available patches.
• That the Odbc.dll and Odbcint.dll are version 2.10 or later.
• That the AS/400 ptf must be sf34548, if you are using IBM's Client Access.

Problem Description

Cannot Access the Datasource Occurs when you attempt to open a catalog or when you 
connect to the database through Impromptu.

Cannot Open a Catalog 
Created with Architect

Occurs when you attempt to open a catalog created with 
Architect.

Cannot Open a Catalog with 
the Current User Class or 
Version of Impromptu

Occurs when you attempt to open a catalog using the User 
version of Impromptu or if your User Class does not exist in 
the catalog security.

Cannot Connect to the 
SQLServer Database

Occurs when you attempt to connect to a catalog or an 
SQLServer database.

Cannot Connect to the MS SQL 
Server

Occurs when you attempt to connect to a MS SQL Server.

Cannot Find the Report or One 
of Its Components

Occurs when you attempt to open a report by double-clicking 
on the file within Windows Explorer.

Unable to Connect to the 
Database

Occurs when you attempt to execute a report or query 
immediately after installing and setting up a connection to 
DB2, Sybase Adaptive Server Enterprise, or Teradata
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• That you verify the path with the SQL Lib IBM ACE.
• Run an ODBC Trace to help identify the problem.
• Compare the ODBC driver settings with a successful connection from another PC.

If the above is verified, then the database definition for this catalog may be incorrect. Try creating 
a database definition.

Steps
1. From the Impromptu Help menu, select Contents and Index.
2. In the Help Topics dialog box, select the Contents tab and double click Database Definition 

Manager. 
3. Double click Setup Up Database Access and double click Create a Database Definition. 

Note: This topic is available only in the Impromptu Administrator online help.

Cannot Open a Catalog Created with Architect

Error Message
The catalog's available user classes do no correspond to any defined by the Common Logon 
Server.

Information
This error occurs when you attempt to open a catalog created with Architect. The catalog contains 
security information stored as authentication data in Access Manager. The current user ID does 
not have permission to access the data in the catalog.

Solution
You must log on to this catalog as the Creator.

Steps
1. In Access Manager, add a user class called Creator and associate the user logging on to the 

Common Logon Server, to it.
2. Shut down the Common Logon Server and reconnect to the catalog.
3. Use the Creator User Class at the Catalog Logon dialog box.

Note: By default every catalog has a Creator User Class.

Cannot Open a Catalog with Current User Class or Version of Impromptu

Error Message
Catalog has no User Class that is valid with this edition. Contact the catalog administrator.

Or when using the Impromptu User edition.

Cannot open a catalog nor query a report, because an Impromptu warning message is displayed: 
Catalog has no user class that is valid with this edition. Contact the catalog administrator.

Information
This error occurs when you attempt to open a catalog using the User version of Impromptu or if 
your User Class does not exist in the catalog security.

Solution
The current user ID does not have permission to access the data in this catalog with the User 
version of Impromptu. Either the current user class does not exist in the catalog or there are no 
user classes defined in the catalog. An Impromptu administrator must create and define additional 
user classes for this catalog. For information about creating user classes, see the Impromptu 
Administrator online help or the Impromptu Administration Guide.
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If setting the user classes in the catalog does not fix the problem, than ensure that the report has 
the correct path to a valid catalog which has user classes defined in its User Profiles:
1. Open the report.
2. From the Report menu, click General and review the Catalog path. If necessary, click Browse 

to find the correct catalog location and file.
3. Upgrade the catalog and all reports to the same version of Impromptu. You should also 

synchronize the versions between the Administrator and User editions.

Note: The above suggestions do not apply if the catalog was created using Architect.

Cannot Connect to the SQL Server Database

Error Message
Error 53 dms-e-yv_systemerr, an unexpected Windows error (1157) occurred while attempting to 
load the gateway.

Information
This error occurs when you try to connect to a catalog or a SQLServer database.

Note: If you are using Windows authentication for SQL Server login you can connect to SQL 
Server without logging in again.

Solution
Check the following information
• The 32-bit MS SQL client software is properly installed and configured on your PC.
• The Path environment variable contains the path to the \MSSQL\bin directory
• You can successfully connect to the database outside Impromptu.
• The files Dbnmpntw.dll and Ntwdblib.dll are in the \MSSQL\bin and \WinNT\System32 

directories.

Cannot Connect to the MS SQL Server

Error Message
Unexpected Windows error (1157) occurred while attempting to load the gateway 'msdbak.dll'.

Information
This error occurs when you attempt to connect to a MicroSoft SQL Server. The MS SQL Server 
Client software does not appear to be installed or is not properly configured.

Solution
If the MS SQL Sever Client software appears to be configured properly, than verify that the 
following DLLs exist under <drive>:\MSSQLl\bin directory
• Dbnmpntw.dll
• Ntwdblib.dll

If you have a server without SQL Server or SQL Enterprise Manager, you must verify that these 
DLLs also exist under <drive>:\WinNT.

If the MS SQL Sever Client software does not appear to be configured properly, install or reinstall 
the MS SQL Server Client software.

Cannot Find the Report or One of Its Components

Error Message
Cannot find the file'<path>\<report>.imr' or one of its components.
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Information
This error occurs when you attempt to open a report by double-clicking on the file within 
Windows Explorer. 

The Impromptu report does not have a valid application associated with it.

Solution
Impromptu must be identified as the associated application. To do this
1. In Windows Explorer, highlight the .imr file by selecting it.
2. Hold the shift key down, right click the .imr file and select Open With.
3. In the Open With dialog box navigate to either ImpAdmin, if the Administrator version is 

installed, or ImpUser, if the User version is installed. 
4. Select the Always use this program to open this type of file check box.
5. Click OK.

Unable to Connect to the Database

Error Message
Unable to connect to database.

Information
When you try to execute reports or queries immediately after installing and setting up a 
connection to DB2, Sybase Adaptive Server Enterprise, or Teradata, you may receive an error 
message that there is a problem connecting to the database or executing the report.

Solution
You must reboot your system to solve this problem.
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Formatting charts in the Impromptu Series 7 Version 4 release has changed significantly from the 
last release. Powerful new dialogs have been introduced that offer more functionality. So, moving 
to the latest version of Impromptu means that you will not lose any functionality that you had in 
previous versions. However, it does mean that you will do certain tasks differently in the new 
environment. To identify the changes related to formatting charting, see the following topics:
• chart types 
• chart properties 
• titles 
• legends 
• data properties 
• grids, scales and axis labels 

Chart Types

See the following table to compare how you add and change the chart type in Impromptu Series 7 
Version 3 and Series 7 Version 4. 

Goal Series 7 Version 3 Series 7 Version 4

Add a 2D bar chart In the Chart Properties dialog, 
in the Chart type list, click 2D 
Bar.

In the Chart Properties dialog 
box, in the Chart type list, 
click Bar. On the Format tab, 
click Properties, and then on 
the General tab, un-check the 
Depth check box (no Depth).

Add a 3D bar chart.

Note: This 3D bar chart is not 
a true three-dimensional chart. 
It is a 2D bar chart with depth.

In the Chart Properties dialog, 
in the Chart type list, click 3D 
Bar.

In the Chart Properties dialog 
box, in the Chart type list, 
click Bar. On the Format tab, 
click Properties, and then on 
the General tab, specify Depth.

Add a pie chart. In the Chart Properties dialog, 
in the Chart type list, click 
either 2D Pie or 3D Pie.

In the Chart Properties dialog 
box, in the Chart type list, 
click Pie.

Add a 2D pie chart. In the Chart Properties dialog, 
in the Chart type list, click 2D 
Pie.

In the Chart Properties dialog 
box, in the Chart type list, 
click Pie. On the Layout tab, 
click 2D Circular Pie.

Add a 3D pie chart. In the Chart Properties dialog, 
in the Chart type list, click 3D 
Pie.

In the Chart Properties dialog 
box, in the Chart type list, 
click Pie. On the Format tab, 
click Properties, and then on 
the General tab, specify Depth. 
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Other Chart Properties

See the following table to compare how you change certain other chart properties in Impromptu 
Series 7 Version 3 and Series 7 Version 4.

Add a 2D area chart. In the Chart Properties dialog, 
in the Chart type list, click 2D 
Area.

In the Chart Properties dialog 
box, in the Chart type list, 
click Area. Click the Format 
tab, click Properties, and on 
the General tab, un-check the 
Depth check box (no Depth).

Add a 3D area chart.

Note: This 3D area chart is not 
a true three-dimensional chart. 
It is a 2D area chart with 
depth.

In the Chart Properties dialog, 
in the Chart type list, click 3D 
Area.

In the Chart Properties dialog 
box, in the Chart type list, 
click Area. Click the Format 
tab, click Properties, and on 
the General tab, specify Depth.

Add a line chart. In the Chart Properties dialog, 
in the Chart type list, click 
Line.

In the Chart Properties dialog 
box, in the Chart type list, 
click Line. Click the Format 
tab, click Properties, and on 
the General tab, un-check the 
Depth check box.

Add a 2D line. In the Chart Properties dialog, 
in the Chart type list, click 
Tape.

In the Chart Properties dialog 
box, in the Chart type list, 
click Line. Click the Format 
tab, click Properties, and on 
the General tab, specify Depth.

Add a log chart. In the Chart Properties dialog, 
in the Chart type list, click 
Log.

In the Chart Properties dialog 
box, in the Chart type list, 
click Line. Click the Format 
tab, click Grids and Scales, and 
then on the Scales tab, click 
Make Logarithmic. 

Add a tape chart. In the Chart Properties dialog, 
in the Chart type list, click 
Tape.

In the Chart Properties dialog 
box, in the Chart type list, 
click Line. Click the Format 
tab, click Properties, and on 
the General tab, specify Depth.

Goal Series 7 Version 3 Series 7 Version 4

Goal Series 7 Version 3 Series 7 Version 4

Change chart background, plot 
and legend color.

On the Format tab, in the 
Select box, click the chart. 
Under the Background color 
option, click Customize.

The color you specify applies 
to the chart, plot and legend 
areas.

On the Format tab, in the 
Chart background box, click 
the area of the chart to format: 
chart, plot or legend. Click 
Edit and use the Formatting 
dialog box to format the color.

Show chart values as a percent. On the Format tab, click 
Percent.

On the Format tab, click 
Properties. On the Layout tab, 
click Percent.
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Titles

See the following table to compare how you change chart titles in Impromptu Series 7 Version 3 
and Series 7 Version 4.

Legends

See the following table to compare how you add and format a legend in Impromptu Series 7 
Version 3 and Series 7 Version 4.

Swap the chart axes. On the Format tab, click Swap. On the Format tab, click 
Properties. On the Layout tab, 
select the Horizontal check 
box.

For pie chart, specify a pullout 
slice.

On the Format tab, in the 
Select box, click the chart. 
Click Show pullout slice. Use 
the dropdown list to specify 
the data item to pull out.

On the Format tab, click 
Properties, and on the General 
tab, specify an Explode value. 
This value is applied to each 
piece of the pie. To customize 
the Explode value for a 
particular slice, on the Format 
tab, click Customize per Data 
Item.

Goal Series 7 Version 3 Series 7 Version 4

Goal Series 7 Version 3 Series 7 Version 4

Add a chart title. In the Chart Properties dialog 
box, on the Format tab, click 
Chart Title.

In the Chart Properties dialog 
box, click the Format tab, and 
then click Titles.   Click the 
Title check box and type a 
title.

Add a primary or x-axis title. On the Format tab, click the 
primary or x-axis Title.

In the Chart Properties dialog 
box, click the Format tab, and 
then click Titles.   Click the 
Category Title check box and 
type a x-axis title.

Add a secondary or y-axis title. On the Format tab, click the 
secondary or y-axis Title.

In the Chart Properties dialog 
box, click the Format tab, and 
then click Titles.   Click the 
Value Title (Y1) check box and 
type a y-axis title.

Format a title. On the Format tab, in the 
Select box, click the chart or 
axis title, then click Font. Use 
the Chart Font dialog box to 
format the title.

In the Chart Properties dialog 
box, on the Format tab, use the 
Font formatting list box to 
select the title, then click Edit.

Goal Series 7 Version 3 Series 7 Version 4

Add a legend. In the Chart Properties dialog 
box, on the Format tab, click 
Legend, and then click Show 
the legend.

In the Chart Properties dialog 
box, on the Format tab, click 
Properties. Click the Look tab, 
and select Show Legend.
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Data Properties

See the following table to compare how you change data properties in Impromptu Series 7 Version 
3 and Series 7 Version 4.

Change legend and legend 
marker location.

On the Format tab, click 
Legend, with Show the legend 
selected, specify the legend 
location and the location of 
markers and legend text. 

In the Chart Properties dialog 
box, on the Format tab, click 
Properties. Click the Look tab, 
select Show Legend, and 
specify the legend options.

Format legend text. In the Chart Properties dialog 
box, on the Format tab, click 
Legend, then click Font. Use 
the Chart Font dialog box to 
format the legend text.

In the Chart Properties dialog 
box, on the Format tab, use the 
Font formatting list box to 
select the title, then click Edit.

Goal Series 7 Version 3 Series 7 Version 4

Goal Series 7 Version 3 Series 7 Version 4

Plot null data. On the Format tab, in the Null 
data box, click Plot as zero or 
Exclude from chart. 

Available only for line charts.

In the Chart Properties dialog 
box, on the Data tab, select the 
Plot null data check box. 

Available only for line and 
correlation charts.

For bar charts only, change the 
location of data labels.

On the Format tab, in the 
Select box, click the chart. In 
the Display options box, in the 
Show Values box, click where 
you want the data labels to 
appear.

In the Chart Properties dialog 
box, on the Format tab, click 
Properties. Click the Data 
Labels tab, select Show Data 
Labels, and then specify Labels 
Location and Label Format. 

Per data item, customize

data item color

marker style

marker size

line style

On the Format tab, in the 
Select box, click the chart. 
Click Customize per Data 
Item.

In the Chart Properties dialog 
box, on the Format tab, click 
Customize per Data Item.

For the entire chart or series, 
specify line style, marker style 
and size.

This applies to line, bubble and 
scatter charts.

On the Format tab, click the 
chart. In the Display options 
box, specify line style, marker 
style and size.

To format marker shape and 
size:
On the Format tab, click 
Properties and use the General 
tab.

To format the line style:
On the Format tab, click 
Customize per Data Item and 
specify the line style for each 
data item.
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See the following table to compare how you add and format grids and scales in Impromptu Series 
7 Version 3 and Series 7 Version 4.

Show data items with color. On the Format tab, click the 
chart. In the Display options 
box, in the Data item colors 
box, click Show as colors. 
Data items automatically 
appear in different colors.

After you specify color to 
show, to customize the color of 
each data item, click 
Customize per Data Item. 

On the Format tab, click 
Customize per Data Item and 
the color of a data item. In the 
Formatting dialog, specify a 
color from the color palette.

Show data items with pattern. On the Format tab, click the 
chart. In the Display options 
box, in the Data item colors 
box, click Show as patterns. 

After you specify pattern, to 
customize the pattern for each 
data item, click Customize per 
Data Item.

On the Format tab, click 
Customize per Data Item and 
in the Color column, click the 
color for a data item. In the 
Formatting dialog box, in the 
Fill Options, click Pattern. In 
the Choose a Pattern dialog 
box, specify the fill pattern, 
foreground and background 
color. 

Goal Series 7 Version 3 Series 7 Version 4

Goal Series 7 Version 3 Series 7 Version 4

Add gridlines. On the Format tab, in the 
Select box, click the chart. 
Select the Primary gridline 
check box to gridlines to the 
x-axis. Select the Secondary 
gridline check box to add 
gridlines to the y-axis.

On the Format tab, click Grids 
and Scales. Click the axis tab, 
and then click the Grids tab. 
You can specify gridlines, grid 
style and grid spacing for 
major and minor gridlines.

Add and format x-axis labels. On the Format tab, in the 
Select box, click the Labels 
button for the x-axis. Select 
Show the labels check box to 
add the axis labels.

Click Font to format the labels.

To add labels:
On the Format tab, click Grids 
and Scales. Click the Category 
Axis, and use the Labels tab 
and General tab to add labels 
and specify how they display.

To format labels:
On the Format tab, in the Font 
formatting list, click the axis 
you want to format, for 
example, Category axis, and 
then click Edit. 

Wrap x-axis labels. On the Format tab, in the 
Select box, click the Labels 
button for the x-axis. Select 
Show the labels check box to 
add the axis labels.

Click Word wrap to wrap 
labels.

Word wrap text:
You cannot specify word wrap 
explicitly. Text is wrapped 
automatically. 

For information on formatting 
x-axis labels, see "Add and 
format x-axis labels". 
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Truncated x-axis labels. On the Format tab, in the 
Select box, click the Labels 
button for the x-axis. Select 
Show the labels check box to 
add the axis labels.

Click Truncate to truncate 
labels.

Truncate text:
You cannot specify that text be 
truncated explicitly. It is 
truncated automatically.

For information on formatting 
x-axis labels, see  "Add and 
format x-axis labels".

Add and format y-axis labels. On the Format tab, in the 
Select box, click the Labels 
button for the y-axis. Select the 
Show labels check box to add 
the axis labels.

Select Customize the scale and 
then edit the Minimum, 
Maximum and Number of 
steps boxes to customize the 
labels.

To add labels:
On the Format tab, click Grids 
and Scales. Click the a y-axis 
tab, and use the Labels tab and 
General tab to add labels and 
specify how they display.

Goal Series 7 Version 3 Series 7 Version 4
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Impromptu provides several dialog boxes that you can use to format charts. These include the 
Properties, Titles, Trendlines, Grids and Scales, Customize per Data Item, and Formatting dialog 
boxes. To assist you with chart formatting, you can find a list of controls for the following dialog 
boxes, together with a description of each control and the chart types that use them. The dialog 
boxes are listed alphabetically.
• Formatting dialog box  
• Grids and Scales dialog box 
• Properties dialog box 
• Titles dialog box 
• Trendlines dialog box 

For information about chart-related tasks, see (p. 105).

For information about how tasks are done differently in this version of Impromptu compared to 
earlier releases, see (p. 159).

Formatting Dialog Box Controls
Here is a list of the controls in the Formatting dialog box. Not all the controls apply to every chart 
type or chart configuration. If a control does not apply, either the control does not appear in the 
dialog box, or it appears but is unavailable.

For information about chart-related tasks, see (p. 105). For information about how tasks are done 
differently in this version of Impromptu compared to earlier releases, see (p. 159).

Font tab
Specifies font characteristics for certain chart objects, such as chart titles, axes titles, data labels, 
and legend text. Here are an alphabetical list of the controls you find on the Font tab.

Name Description

Alignment list box Specifies the text alignment. You can align text left, right, or have 
it centered.

Color palette Specifies font color.

Font list box Specifies the font type.

Rotation list box Rotates text. Rotating text can help avoid overlapping text, for 
example, in axis labels.

Size list box Specifies the font size.

Style buttons Specifies the font style: italic, bold, and underline.

Transparent button Makes text transparent.
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Line tab
Specifies line characteristics, such as line color, style, and thickness.

Fill tab

Specifies fill characteristics, such as fill color, fill pattern, and fill pattern color.

Grids and Scales Dialog Box Controls
Use the Grids and Scales dialog box controls to add axis labels, scales and grids to your charts.

The tabs on the left-side of the dialog box show the available axes in the chart: Y1 Axis, Y2 Axis 
(for dual-axes charts), Category Axis, X Axis (for bubble and scatter charts) and Series Axis (for 
three-dimensional charts). When you select an axis tab, the tabs for formatting appear at the top 
of the dialog box. Not all of the controls apply to every chart type or chart configuration. If a 
control does not apply, either the control does not appear in the dialog box, or it appears but is 
unavailable.

For information about chart-related tasks, see (p. 105). For information about how tasks are done 
differently in this version of Impromptu compared to earlier releases, see (p. 159)

General tab

Here is an alphabetical list of controls in the General tab.

Name Description

Color palette Specifies font color.

Style list box Specifies the line style.

Thickness list box Specifies the line width.

Transparent button Makes text transparent.

Name Description

Color palette Specifies font color.

Pattern button Opens the Choose a Pattern dialog box that lets you specify fill 
pattern, pattern background and foreground color.

Transparent button Makes text transparent.

Name Description Axis Chart Type

Draw 
Categories in 
Reverse 
Order check 
box

Reverses the categories plotted on the chart 
Category Axis. The Category Axis labels 
appear from left-to-right at the bottom of 
the chart.

Category Axis, 
X Axis

area, bar, 
correlation, gantt, 
HLCO, HLO, 
line, radar 

Draw Series 
in Reverse 
Order check 
box

Reverses the data plotted on the Series Axis.

The Series Axis is only valid for 
three-dimensional charts.

Series Axis area, bar, line
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Labels on 
Both Sides 
radio button

Specifies the location for the Category or X 
Axis baseline and labels.

The default category axis baseline and labels 
appear at the bottom of the chart.

Y1 Axis
Category Axis
X Axis

Y1 Axis:

area, bar, bubble, 
correlation, 
HLCO, HLO, 
line, radar, scatter 

Category Axis:

gantt

Labels on 
Bottom radio 
button

Specifies the location for the Category or X 
Axis baseline and labels.

The default category axis baseline and labels 
appear at the bottom of the chart.

Category Axis, 
X Axis

 area, bar, bubble, 
correlation, 
HLCO, HLO, 
line, radar, scatter 

Labels on 
Left radio 
button

For the Y1 Axis, specifies that labels appear 
on the left side of the axis.

Y1 Axis, 
Category Axis

Y1 Axis:

 area, bar, bubble, 
correlation, 
HLCO, HLO, 
line, radar, scatter 

Category Axis:
gantt

Labels on 
Right radio 
button

For the Y1 Axis, specifies that labels appear 
on the right side of the axis.

Y1 Axis, 
Category Axis

Y1 Axis:
area, bar, bubble, 
correlation, 
HLCO, HLO, 
line, radar, scatter

Category Axis:
gantt

Labels on 
Top radio 
button

Specifies the location for the Category or X 
Axis baseline and labels.

The default Category Axis baseline and 
labels appear at the bottom of the chart.

Category Axis, 
X Axis

area, bar, bubble, 
correlation, 
HLCO, HLO, 
line, radar, scatter 

Make this a 
Descending 
Axis check 
box

Draws the numeric axis in descending order 
for the X Axis value labels and columns.

Y1 Axis
X Axis

Y1 Axis:
area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, 
line, radar, scatter 

X Axis:
scatter

Show the 
Axis Line on 
the Chart

Shows or hides the category or Y axis base 
lines. This option is always enabled.

Category Axis correlation

Value Axis 
Crosses 
Between 
Categories

When selected, offsets the area from the plot 
edges so that there are gaps between the Y 
Axis and the start of the plot area values. 
When cleared, the categories are aligned 
flush to the plot area edge.

Category Axis, 
X Axis

area, line

Name Description Axis Chart Type
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Scales tab

Here is an alphabetical list of controls in the Scales tab.

Name Description Axis Chart Type

Make 
Logarithmic 
check box

Specifies a logarithmic scale.

To set the logarithmic scale, you must 
choose manual scaling and set the minimum 
and maximum value to a value greater than 
zero.

Y1 Axis
X Axis
Z Axis

Y1 Axis: 
area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, 
line,   radar 

X Axis:
bubble

Z Axis:
bubble

Always 
Include Zero 
check box

Specifies whether to include a zero on the 
numeric axis.

This option is disabled when the Set 
Minimum Value option is selected.

Y1 Axis
X Axis
Z Axis

Y1 Axis: 
area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, 
line, radar 

X Axis:
bubble

Z Axis:
bubble

Set 
Maximum 
Value check 
box

Applies manual scaling on the axis. This 
allows you to specify a range of values that 
is different from the range specified in the 
data.

The value you enter sets the maximum value 
that appears on the numeric axis. The value 
label and chart columns are adjusted to 
align with this value.

Y1 Axis
X Axis
Z Axis

Y1 Axis: 
area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, 
line, radar 

X Axis:
bubble

Z Axis:
bubble

Set Minimum 
Value check 
box

Applies manual scaling on the axis. This 
allows you to specify a range of values that 
is different from the range specified in the 
data.

The value you enter sets the minimum value 
that appears on the axis. The value label and 
chart columns are adjusted to align with this 
value.

Y1 Axis
X Axis
Z Axis

Y1 Axis: 
 area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, 
line, radar 

X Axis:
bubble

Z Axis:
bubble
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Labels tab

Here is an alphabetical list of controls in the Labels tab.

Name Description Axis Chart Type

Automatic 
radio button

Draws all labels on the axis. This option is 
available for the Category and Series axes.

Category Axis
Series Axis

Category Axis:
area, bar, bubble, 
correlation, 
HLCO, HLO, 
line, radar 

Series Axis:
area, bar, line

Hide labels 
for:

Maximum 
Value check 
box

Shows or hides the maximum value on an 
axis.

Y1 Axis
Y2 Axis
X Axis

Y1 Axis:
area, bar, bubble, 
correlation, 
HLCO, HLO, 
line, radar, scatter 

Y2 Axis:
area, bar, 
correlation, line 

X Axis:
bubble, scatter

Hide labels 
for:

Minimum 
Value check 
box

Show s or hides the minimum value on an 
axis.

Y1 Axis
Y2 Axis

Y1 Axis:
area, bar, bubble, 
correlation, 
HLCO, HLO, 
line, radar, scatter 

Y2 Axis:
area, bar, 
correlation, line, 

X Axis:
bubble, scatter

Number of 
categories 
between 
labels radio 
button

Controls the number of labels that appear 
on the axis by specifying the number of 
labels that can be dropped between 
categories. By default, all labels appear. 

To restrict the number of labels, you must 
select the Show Labels with this Axis check 
box. 

Category Axis area, bar, bubble, 
correlation, 
HLCO, HLO, 
line, radar 
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Grids tab

 Here is an alphabetical list of controls in the Grids tab.

Show Labels 
for this Axis 
check box

Shows or hides numeric and Category Axis 
labels. 

On the numeric axis, labels identify the 
range of data values that are charted. On the 
category axis, the labels show how data in 
the chart is grouped or categorized.

When the check box is selected for the 
category axis, the axis labels appear 
immediately below the chart frame. For 
numeric axis labels, when the columns 
appear vertically from top-to-bottom or 
bottom-to-top, the labels on the Y1 Axis 
appear on the left side of the chart. For the 
Y2 Axis, the labels appear on the right side 
of a vertical chart and on the top for a 
horizontal chart.

For 3D charts, the category labels appear on 
the lower right side of the chart.

Y1 Axis
Y2 Axis
Category Axis
X Axis
Series Axis

Y1 Axis:
area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, 
line, radar, scatter 

Y2 Axis:
area, bar, 
correlation, line 

Category Axis:
area, bar, bubble,   
correlation, gantt, 
HLCO, HLO, 
line, radar 

X Axis:
bubble, scatter

Series Axis:
area, bar, line

Stagger 
Labels radio 
button

Staggers Category Axis labels.

Staggering labels is useful when long labels 
are required for each data group but you do 
not want the labels to wrap.

By default, labels on the Category Axis 
appear on a single line. If labels are too long 
to fit on a single line, labels are wrapped at 
word breaks and appear on multiple lines.

This option is not available for 3D charts.

Category Axis
X Axis

Category Axis:
area, bar, 
correlation, 
HLCO, HLO, 
line, radar 

X Axis:
bubble

Use Manual 
Number of 
Series radio 
button

Allows you to manually specify the number 
of data series plotted in the chart.

Series Axis area, bar, line

Name Description Axis Chart Type

Draw 
Custom Line 
at check box

Draws a custom grid line on the Y1 Axis or 
Y2 Axis in your chart. The location of the 
grid line is specified by the value you enter 
in the Draw Custom Line at edit box.

Y1 Axis
Y2 Axis
X Axis

Y1 Axis:
area, bar, 
correlation, 
HLCO, HLO, 
line, scatter 

Y2 Axis:
area, bar, 
correlation, line 

X Axis:
scatter

Name Description Axis Chart Type
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Grid Style list Specifies the style of grid line for major and 
minor grid lines. You can specify the 
following styles:
Regular Grids
Grids and Ticks
Inner Ticks
Outer Ticks
Spanning Ticks

To format the width and color of a grid line, 
use the Formatting option on the Chart 
Properties, Format tab. 

Y1 Axis
Y2 Axis
Category Axis

Y1 Axis:
area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, 
line, radar, scatter   

Y2 Axis:
area, bar, 
correlation, line 

Category Axis:
area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, line

Gridlines per 
interval box, 
Minor 
Gridlines tab

Controls the number of minor grid lines in 
the chart.

Y1 Axis
Y2 Axis

Y1 Axis:
correlation, gantt, 
radar 

Y2 Axis:
correlation

Set manual 
number of 
categories 
between 
gridlines 
radio button

Minor 
Gridlines tab

For minor grid lines on the Category Axis, 
specifies the number of categories between 
the grid lines.

Category Axis area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, line

Show 
Gridlines 
check box

Shows or hides major grid lines in a chart.

To specify a grid line style, see the Grid Style 
option.

Y1 Axis
Y2 Axis
Category Axis
Series Axis

Y1 Axis:
area, bar, gantt, 
correlation, 
HLCO, HLO, 
line, radar, scatter 

Y2 Axis:
area, bar, 
correlation, line

Category Axis:
area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, 
line, radar 

Series Axis:
area, bar, line

Name Description Axis Chart Type
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Properties Dialog Box Controls

Use the Properties dialog box controls to format chart characteristics that apply to the chart 
globally, such as the layout type, data labels, and legend.

Here is a list of the controls in the dialog box, grouped by tab. Not all of the controls apply to 
every chart type or chart configuration. If a control does not apply, either the control does not 
appear in the dialog box, or it appears but is unavailable.

General tab
 This tab specifies the general properties of a chart, which vary depending on the chart type. For 
example, you can specify tilt, depth, rotation and explode values for a pie chart. For the columns 
in a bar chart, you can specify shape, overlap, gap width between columns, and depth.

For information about chart-related tasks, see (p. 105). For information about how tasks are done 
differently in this version of Impromptu compared to earlier releases, see (p. 159)

Here is an alphabetical list of the controls in the General tab.

Use manual 
grid interval 
value check 
box

For major grid lines, let’s you set the grid 
interval value manually.

Y1 Axis
Y2 Axis
X Axis

Y1 Axis:
area, bar, 
correlation, gantt, 
HLCO, HLO, 
line, radar, scatter 

Y2 Axis:
area, bar, 
correlation, gantt, 
line 

X Axis:
 scatter

Name Description Axis Chart Type

Name Description Chart Type

Bubble size slider Specifies the size of the markers in a bubble chart. bubble

Connect Data Points 
with Lines check box

Shows or hides a connecting line between each 
marker in a series.

scatter

Depth check box Controls whether depth is added to a chart. When 
cleared, the chart is flat. By default, all charts 
appear with depth added to the chart frame and 
columns.

This option is not available for bar charts with the 
True 3D layout.

area, bar, 
correlation, gantt, 
line

Depth slider Specifies the amount of depth to be applied to the 
chart. For a pie chart it controls the thickness of 
the pie. For the remaining charts, it controls the 
depth of the bars risers and frame.

This option is not available for bar charts with the 
True 3D layout.

area, bar, bubble, 
correlation, gantt, 
line, pie

Direction slider Specifies the direction in which the depth is 
applied.

This option is not available for bar charts with the 
True 3D layout.

area, bar, 
correlation, line
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Display Series Lines 
check box

Draws a line connecting the series data. stacked bar, 
percent bar

Explode slider Detaches all slices from the pie.

Exploding a pie or donut chart detaches all slices 
away from the center.

pie

Gap Width slider Changes the gap between the group of bars or 
columns in each category.

bar, correlation, 
gantt, HLCO, 
HLO, 3D area, 
3D line

Hole Size slider Controls the size of the hole in a ring pie chart. ring pie

Keep aspect ratio 
constant check box

Controls whether a pie chart has to be perfectly 
circular when drawn. There are cases when a pie 
chart, with depth and a high Tilt value, looks 
better with a non 1:1 width: height aspect ratio.

pie

Overlap slider Changes the degree that bars or columns, within 
each category, overlap each other.

This option is only available for a clustered chart.

This option is not available for bar charts that 
have the True 3D layout.

bar, correlation

Restore All button Restores all slices of the pie to their original 
settings when slices have been detached or 
removed from a pie chart.

pie

Riser Shape list box Changes the shape of the bars or columns.

This field is not available if the Use Depth check 
box is selected.

bar, correlation, 
gantt, 

Rotation slider Rotates the pie chart. pie

Shape list box Changes the shape of markers.

For line and scatter charts, this option is only 
available if Show Markers is selected.

bubble, line, 
scatter

Show line(s) check box Shows or hides the lines in a chart. line

Show Marker(s) check 
box

Shows or hides the markers in a chart.

For line charts, if this control is enabled, a marker 
is drawn on each line at locations representing the 
data values.

For a bubble chart, if the user hides markers and 
does not select Connect Data Points with Lines, the 
scatter chart does not contain any columns 
representing the data values.

line, scatter

Size slider Changes the size of markers.

For bubble charts, if zero is used, the markers 
disappear from the chart.

For scatter charts, this option is only available if 
Show Markers is selected.

bubble, line, 
scatter

Name Description Chart Type
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Layout tab
Changes the default layout. Depending on the chart, you can make the layout type absolute, 
percent, stacked, clustered, or three-dimensional. You can also specify whether data items appear 
on the vertical or horizontal axis. For certain charts, you can also specify dual axes. 

For information about chart-related tasks, see (p. 105). For information about how tasks are done 
differently in this version of Impromptu compared to earlier releases, see (p. 159)

Here is an alphabetical list of the controls in the Layout tab.

Tilt box Tilts the pie chart.

Lesser values make the pie chart flatter facing the 
viewer, whereas, the maximum value tilts the pie 
chart such that only the pie edge is shown.

pie

Name Description Chart Type

2D Circular Pie check 
box

Adds depth to a pie chart. The tilt value is set to 
zero.

pie

Absolute radio button Specifies that absolute data values are used. area, bar, line

Angle box slider Rotates the chart, showing it at different angles. radar

Area radio button Shows the area enclosed by the data points. radar

Circular Data Lines 
check box

Draws the perimeter of a radar chart which is 
circular.

radar

Circular Gridlines 
radio button

Shows circular or value grid lines on a radar chart. 
You can toggle between circular or spider grid 
lines. With circular grid lines, you can also specify 
circular data lines.

radar

Clustered radio button Creates a side-by-side group of columns. This is 
the standard type of column or bar chart.

bar

Dual Axes check box Creates a chart with two numeric axes (Y1 and 
Y2).

To change the data series that are assigned to each 
axis, use the settings in the Dual Y Options tab.

This option is only available for clustered and 
stacked area charts. It is not available for percent 
and 3D charts.

area, bar, bubble, 
line

Horizontal radio 
button

Plots data columns on the numeric or y-axis. area, bar, 
correlation, line

Line radio button Connects the data points in the chart using lines. radar

Percent radio button Creates a column version of a pie chart. Each 
group calculates the percent of the total required 
for each series. The axis goes from zero to 100%.

area, bar, line

Pie radio button Shows data as a percentage of a total. pie

Ring Pie radio button Creates a ring variant of the pie chart. The total of 
all slices is placed in the center.

pie

Name Description Chart Type
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Data Labels tab
Specifies whether to show data labels. If you choose to have data labels appear, you can specify 
the label location and format.

For information about chart-related tasks, see (p. 105). For information about how tasks are done 
differently in this version of Impromptu compared to earlier releases, see (p. 159)

Here is an alphabetical list of the controls in the Data Labels tab.

True 3D radio button Creates a standard three-dimensional chart that 
displays a riser for each value in the data set.

area, bar, line

Show Close Hides or shows the closing value in a HLCO chart. HLCO

Show Open Hides or shows the opening value in a HLCO 
chart.

HLO

Spider Gridlines radio 
button

Draws the circular or value grid lines such that the 
radar chart resembles a spider web.

radar

Split check box Assigns half of the series in the chart to the 
primary numeric axis (Y1) and the other half to 
the secondary numeric axis (Y2). It physically 
splits the chart and shows two separate numeric 
axes.

All columns or bars are drawn from a single 
category axis base line. The series assigned to the 
Y1 and Y2 axes are drawn on opposite sides of the 
chart.

If the Dual Axes check box is not selected, this 
check box is unavailable.

area, bar, line

Stacked check box Arranges the polygons formed by the data points 
such that the polygons are stacked one on top of 
the other.

radar

Stacked radio button Shows stacked groups of columns or bars. Each 
stack is comprised of all the series in the group, 
added up to get a total. The axis is the total value 
of the cumulative points.

area, bar, line

Style list Specifies the layout style in high-low-close-open 
and high-low-close charts.

Data values can be represented using rectangular 
columns or vertical lines.

HLCO, HLO

Vertical radio button Plots data columns on the category or X-Axis. area, bar, 
correlation, line

Name Description Chart Type

Absolute Values radio 
button

Shows absolute data values. Available when you 
select the stacked and percentage chart layout type.

area, bar, line

As Percentage check 
box

Shows the data values in the chart as a percentage 
of the total.

pie

Cumulative Values 
radio button

Shows cumulative data values. Available when you 
select the stacked and percentage chart layout type.

area, bar, line

Name Description Chart Type
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Label Format list box Selects the label format.The user can choose from 
the following options: Value, Label, or Label & 
Value.

This option is enabled when the Show Data Labels 
check box is selected.

If Value is selected, the data values appear at the 
corresponding location on each column.

If Label is selected, the series labels appear.

If Label & Value is selected, the series labels and 
data values appear. 

For bubble charts, you can choose an X and Y 
Value or Label. This selection is not available for 
scatter charts or charts with the True 3D layout.

area, bar, bubble, 
correlation, line, 
HLCO, HLO

Labels Location list 
box

Selects where the data labels appear next to the 
associated column or bar in the chart.

This option is enabled when the Show Data Labels 
check box is selected.

This option is not available when the True 3D 
chart layout is selected.

The data labels location can be one of the 
following: Outside Maximum, Inside Maximum, 
Center, or Base of Chart.

For scatter charts, one of the following label 
locations can be selected: Above Marker, Below 
Marker, or Centered on Marker.

area, bar, bubble, 
correlation, gantt, 
line, HLCO, 
HLO, scatter

Labels on Sides check 
box

Shows the series labels on the sides of the chart. pie

On Slices radio button Shows the data values on each pie slice. Available if 
Show Values is selected.

Do not select this check box to show the absolute 
values for each slice.

pie

On Slices radio button Shows the series labels on each pie slice. Available 
if Show Labels is selected.

pie

Outside Slices radio 
button (data values)

Shows the data values outside each pie slice. 
Available if Show Value is selected.

pie

Outside Slices radio 
button (series labels)

Shows the series labels outside each pie slice. 
Available if Show Labels is selected.

pie

Show as Percentage 
check box

Shows the data values in the chart as a percentage 
of the total.

area, bar

Show Data Labels 
check box

Show or hides data labels for all series in the chart. area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, 
line, radar, scatter

Show Labels check box Shows or hides the series label associated with each 
pie slice.

pie

Name Description Chart Type
176  Cognos Impromptu (R)      



Chapter 27: Impromptu Chart Controls
 
Dual Y Options tab
For charts that have dual y-axes, specifies which data series uses the Y1 axis and which data series 
uses the Y2 axis. This tab is not available for pie, gantt, radar, HLCO, and HLO charts. To add a 
dual axis to a chart, use the Layout tab.

For information about chart-related tasks, see (p. 105). For information about how tasks are done 
differently in this version of Impromptu compared to earlier releases, see (p. 159)

Here is an alphabetical list of the controls in the Dual Y Options tab.

Look tab
Specifies a legend and legend properties for your chart. For example, you can specify where the 
legend is placed in chart.

For information about chart-related tasks, see (p. 105). For information about how tasks are done 
differently in this version of Impromptu compared to earlier releases, see (p. 159)

Show Leader Lines 
check box

Shows or hides the leader lines from each pie slice 
next to the data value or series label. Available if 
the Outside Slices option is selected for values or 
labels.

pie

Show Total radio 
button

For data values, shows totals when you select the 
stacked layout type.

area, bar

Show Values check 
box

Shows or hides data label values for each slice in 
the pie chart.

pie

Name Description Chart Type

Y1 Axis list box Assigns a data series to the Y1 axis.

When the Dual Y Options tab is enabled, the data 
series is divided by two. Half of the series is 
assigned to the Y1 Axis, and the other half is 
assigned to the Y2 Axis.

The Dual Y Options tab is available only if the 
Dual Axes check box is selected in the Layout tab.

area, bar, bubble, 
line

Y2 Axis list box Assigns a data series to the Y2 Axis.

When the Dual Y Options tab is enabled, the data 
series is divided by two. Half of the series is 
assigned to the Y1 Axis, and the other half is 
assigned to the Y2 Axis.

The Dual Y Options tab is available only if the 
Dual Axes check box is selected in the Layout tab.

area, bar, bubble, 
line

Show Axis Split check 
box

Show or hides the dual axes split line.

Only available when the Dual Axes and Split Dual 
Axes check boxes are selected in the Layout tab.

area, bar, line

Split Position slider Selects the location where the chart is split into 
two halves.

Only available when the Dual Axes and Split Dual 
Axes check boxes are selected in the Layout tab.

area, bar, line

Name Description Chart Type
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Here is an alphabetical list of the controls in the Look tab.

Display Status tab
Use this tab to specify certain display options for pie and radar charts and charts with a 
three-dimensional layout.

For information about chart-related tasks, see (p. 105). For information about how tasks are done 
differently in this version of Impromptu compared to earlier releases, see (p. 159)

Here is an alphabetical list of the controls in the Display Status tab.

Name Description Chart Type

Box Style list box Draws a text box around the entire legend area. 
The available options are:
No Frame
Single Line Frame
Double Line Frame
Beveled Frame
Reverse Beveled Frame

area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, 
line, pie, radar, 
scatter 

Layout list box Defines where the legend area markers and text 
appear in the chart. The available options are:
Legend on Right Side
Legend on Left Side
Legend Below Chart

area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, 
line, pie, radar, 
scatter

Markers and Text list 
box

Defines the content and format of the legend area. 
Available only if Show Legend it selected.

The following options are available:
Markers to Left of Text
Markers to Right of Text
Text Centered on Markers
Markers Above Text
Markers Below Text

area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, 
line, pie, radar, 
scatter

Show Legend check 
box

Shows or hides the chart legend.

If this check box is not selected, all other selections 
related to the Legend are unavailable.

area, bar, bubble, 
correlation, gantt, 
HLCO, HLO, 
line, pie, radar, 
scatter

Name Description Chart Type

Floor check box Shows or hides the floor in a three-dimensional 
chart. 

3D area, 3D bar, 
3D line

Left Wall check box Shows or hides the left wall in a three-dimensional 
chart.

3D area, 3D bar, 
3D line

Pie Name check box Shows or hides the pie name, which is the category 
label. The category label appears below the pie 
chart.

pie

Pie Total check box Shows or hides the total value in the center of each 
pie. Available only for ring pie charts.

pie

Right Wall check box Shows or hides the labels for the right wall in a 
three-dimensional chart.

3D area, 3D bar, 
3D line

Show Y-Axis Values on 
the left check box

Hides or shows the Y Axis values on the left-side 
of a radar chart.

radar
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Titles Dialog Box Controls
Here is a list of the controls, in alphabetical order, that you find in the Titles dialog box. Not all 
the controls apply to every chart type or chart configuration. If a control does not apply, either the 
control does not appear in the dialog box, or it appears but is unavailable.

For information about chart-related tasks, see (p. 105). For information about how tasks are done 
differently in this version of Impromptu compared to earlier releases, see (p. 159).

Trendlines Dialog Box Controls
Here is a list of the controls, in alphabetical order, that you find in the Trendlines dialog box. Not 
all of the controls apply to every chart type or chart configuration. If a control does not apply, 
either the control does not appear in the dialog box, or it appears but is unavailable.

Name Description Chart

Category Title check 
box and edit box

Defines a title for the Category Axis. area, bar, gantt, 
HLCO, HLO, 
line, radar, 

Footnote check box 
and edit box

Defines a footnote. By default, the footnote is 
placed at the bottom right corner of the chart.

area, bar, bubble, 
gantt, HLCO, 
HLO, line, pie, 
radar, scatter

Subtitle check box and 
edit box

Defines a subtitle that allows you to provide 
additional information about the chart. By default, 
the subtitle is placed at the top center of the chart 
directly below the chart title.

area, bar, bubble, 
gantt, HLCO, 
HLO, line, pie, 
radar, scatter

Title check box and 
edit box

Defines the main chart title. By default, the chart 
title is placed at the top of the chart.

area, bar, bubble, 
gantt, HLCO, 
HLO, line, pie, 
radar, scatter

Value Title (Y1) check 
box and edit box

Adds a title to the Y1 Axis. area, bar, bubble, 
gantt, HLCO, 
HLO, line, pie, 
radar, scatter

Value Title (Y2) check 
box and edit box

Adds a title to the Y2 Axis. This title is available 
for dual-axes charts, where the chart has both a Y1 
Axis and a Y2 Axis.

area, bar, bubble, 
line, scatter

Series Axis check box 
and edit box

Adds a series axis title to describe the information 
charted on the Series Axis. This title is only 
available for three-dimensional charts where the 
axis labels that are normally displayed in the 
legend area are plotted along a secondary group 
axis. In the default configuration, the series labels 
appear on the lower left side of the 
three-dimensional cube.

area, bar, line

X-Axis check box and 
edit box

Adds a title to the X Axis of the chart. Only bubble 
and scatter charts include an X Axis.

bubble, scatter
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For information about chart-related tasks, see (p. 105). For information about how tasks are done 
differently in this version of Impromptu compared to earlier releases, see (p. 159).

Name Description Chart Type

Order edit box Specifies the degree of linear regression for the 
polynomial trendline. Available only for a 
polynomial trendline.

The Order number must be greater than one but 
no greater than the number of groups in the chart.

area, bar, line, 
scatter

Period edit box Specifies the period over which the moving average 
line should be drawn. Available only for a Moving 
Average trendline.

area, bar, line, 
scatter

Regression Type list 
box

Defines the type of trendline you want to appear. 
Available only if Show Trendlines is selected.

You can choose the following regression types: 
linear, logarithmic, polynomial, exponential, 
moving average. 

area, bar, line, 
scatter

Show Coefficient 
Values check box

Shows or hides the coefficient values that are used 
for the trendline.

Available for linear, logarithmic, polynomial, 
power, or exponential trendlines.

area, bar, line, 
scatter

Show Color Same as 
Series check box

Draws the trendline with the same color as the 
selected series. This option is selected by default.

area, bar, line, 
scatter

Show Equation check 
box

Shows or hides the equation that was used for the 
trendline.

Available for linear, logarithmic, polynomial, 
power, or exponential trendlines.

area, bar, line, 
scatter

Show Trendlines list 
box

Shows or hides a trendline for the selected series. area, bar, line, 
scatter
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Glossary

aggregate
A calculation involving a summary component and a FOR clause indicating for what group the 
aggregate is calculated. An aggregate is calculated independently of its position in a report and of 
its association with a group. You can perform the following aggregates: total, minimum, 
maximum, average, count, rank, percentile, percentage, running-total, running minimum, running 
maximum, running average, running count, and standard deviation. Also called a summary.

alias
An alternative label for a table. Create an alias to relate values in a single table by creating a 
self-join between the table and its alias. For example, you can determine the name of each 
employee’s manager if an employee table contains the employee name, employee number, and 
manager number. You can also use a filter expression on the alias to create a view of part of the 
data from the original table; for example, all those employees who report to a particular manager.

annotations
Descriptive information about the contents of your catalogs. You can develop an application that 
shows the annotations when your users want context-sensitive help about your catalog folders, 
columns, prompts, filters, and calculations.

Architect model
The information required to author a set of Cognos applications, contained in a single file (.rep). 
The Architect model describes an enterprise reporting and querying environment that uses one or 
more metadata sources.

associated data item
A data item linked to the group data item. Associated data items suppress duplicate data values, 
but do not generate a control break. For example, if Customer Number is the grouped data item, 
you can repress Customer Name by declaring it as an associated data item. When Customer 
Number appears in the report, it appears only once for the group. Marking a data item as 
associated can affect how Impromptu calculates summary values.

auditing
The process of recording performance information and using it to find out how changes to your 
reporting environment affect performance times. To audit performance in Impromptu use the 
Audit Configuration and Audit File Processor applications.

automatic association
The group association of a newly created summary. The location of the group where you create 
the summary determines its automatic association. If you create a summary using the Calculate 
button in the Data tab (Query dialog box), the summary appears at the bottom of the Group 
Order box until you run the query. After you run the query, the summary appears under the 
lowest group in the Group Order box. If you move a summary with automatic association to a 
new location in the report, it appears under the group representing the new location.

See also summary.

automation
See OLE automation.
Impromptu User Reference  181



  
 

bitmap
An image that consists of pixels on the screen and, stored as a collection of bits. Windows bitmaps 
have the extension .bmp.

BLOB
A Binary Large Object, or large unstructured object stored in the database. A BLOB can be free 
text, images, digitized images, or audio streams.

boundary line
A line that indicates the extent of a frame as well as names of each report object. You show or hide 
boundary lines by using the Boundary Line command (View menu).

bulk fetch
Retrieval of more than one row of data from your database in a single fetch call. Bulk fetch can 
improve processing time for large queries.

cache query
A temporary cache on your personal computer that Impromptu uses to store report results. You 
set the cache query by clicking Query from the Report menu, and then clicking the Access tab.

calculated data item
A data item that shows the result of an expression that uses stored data. The value recalculates 
each time a value in the expression changes. For example, you can use the string operator (+) to 
combine a data item called Firstname with a data item called Lastname to form a calculated data 
item called Fullname.

cascading prompt
A prompt that uses information from a previous prompt to determine which options to display in 
a picklist.

catalog
A file (with the extension .cat) that contains all the information necessary for Impromptu to access 
and retrieve information from a relational database. A catalog does not store data, but it does 
provide Impromptu with a business view of the data. A catalog also contains information about 
what database to access, where the database is stored, and how the tables in the catalog are 
joined.

See also personal catalog, shared catalog, and secured catalog.

catalog condition
An expression that can be used anywhere you need a true-false value. A catalog condition is stored 
in the catalog. You can use conditions in filters, in conditional formatting, and in calculations. For 
example, you can use a condition to see data for only your sales region.

catalog prompt
A prompt you store in the catalog that you can re-use in different reports.

category axis
The axis that contains category information, for example, product, customer, cost center, or 
country.

For most charts, this axis is considered to be the horizontal, or x-axis, of the chart and appears 
below the chart. In some charts, the category axis can be relocated so that it appears above, to the 
left, or to the right of the chart (for example, a horizontal bar chart).

In some charts, there may be more than one category axis, such as the x-axis and the y-axis, or the 
x-axis and the z-axis. This occurs, for example, when a measure, such as revenue, is charted for 
products per country (say on the x- and y-axis), over time (say on the z-axis).
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cell
The intersection of a column and row that contains a single value.

chart frame
A type of frame that provides a visual image of numeric report data. Charts can be formatted in a 
number of ways, including bar charts, area charts, pie charts, bubble charts, and many other 
popular formats.

See also child frame, parent frame, primary frame, and report object. 

child frame
A frame or report object that is subordinate to a parent frame.

See also primary frame and report object.

CognosScript
A language similar to VISUAL BASIC, that is included with Cognos applications. You can use 
CognosScript to write macros.

Color Dialog Box
Displays a color palette. Use to apply color to report objects, such as fonts, charts, lines, borders 
and grids. The display settings on your computer determine the colors available. 

column
One kind of information in a list frame, it is a vertical list of data that shares the same definition.

column spacer
Enables you to create an empty space between list frame columns.

comma delimited ASCII file
A text file where each column of data is separated from the next by a comma. All data must use 
ASCII standard characters.

command line
The characters used to start an application. For example, you enter command line parameters 
when you start Impromptu by clicking Run from the Start menu and typing a command. 

complex join
A complex join uses an expression to join two tables. You must click the Expression option button 
to create a complex join.

compound join
A compound join is a join containing several columns joining two tables. A compound join can be 
an equi-join, non-equi-join, outer join, self-join, or complex join.

condition
An expression that can be used anywhere you need a true-false value. A condition can be stored in 
the catalog. You can use conditions in filters, in conditional formatting, and in calculations. For 
example, you can use a condition to see only data for your sales region.

See also filter.

conditional format
An instruction to Impromptu to look through data in the selected report objects and format the 
data that meets predefined conditions. Use this format to identify exceptional data in your report. 
For example, retail outlets with quarterly revenues greater than $500,000 could be highlighted in 
green, while retail outlets with quarterly revenues less than $250,000 could be highlighted in red.
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control break
The start of a new group of data, which allows operations such as subtotaling.

Creator
The user class who creates a catalog and usually administers it. By default, the creator has no 
restrictions on using the catalog.

cross-product query
A report that retrieves data from tables that do not have table joins defined for them.

crosstab
Shows summary information from a list report in a compact table of rows and columns. A 
crosstab shows the value for the combination of each row and column, enabling you to gain a 
different perspective on the data and see more without the need to scroll.

For example, you can change a list report that has three columns (Product Type, Sales Channel, 
Total Sale Amount) into a crosstab that has each Product Type as a row, each Sales Channel as a 
column, and the Total Sale Amount for each combination of Product Type and Sales Channel in 
the cells.

crosstab detail filter
Use to filter on the detail columns generated in a crosstab report. For example, if you add the 
Product Type data item to the rows, you can apply a crosstab detail filter to Environmental Line, 
GO Sport Line, or Outdoor Products.

See also detail filter and crosstab summary filter.

crosstab summary filter
Use to filter on the summary columns generated in a crosstab report. For example, you can filter 
on the row totals in a crosstab to show only data items with a total product cost that is over 300.

See also summary filter and crosstab detail filter.

custom condition
An expression that has a true-false value that you use when conditionally formatting report data. 
For example, you can define a condition that highlights sales margins less than 50%.

You create a custom condition in a report.

data item
A column from a database, HotFile table, or a snapshot of a report.

data source
Where Impromptu retrieves information for your query. The data source can be a database, 
HotFile, snapshot, or thumbnail.

data type
One of six data types in Impromptu: character, date, date-time, numeric, time, and interval.

database
A collection of data related to a particular purpose and organized for ease of reference. Depending 
on the type of database you are using, a database can contain tables, views, synonyms, and stored 
procedures.

dataset
An Impromptu report that stores data values you can use when applying a filter. A dataset is 
dynamic, meaning that when you use a dataset in a filter, the report that stores that dataset is 
re-run.
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date_exp
A date constant, a date data item, or any expression resulting in a date value.

datetime_exp
A date constant, a date data item, or any expression resulting in a datetime value.

detail filter
Limits the data retrieved in a report. A detail filter eliminates data from a report by restricting the 
data. For example, you could create a detail filter to specify that only sales over $1000 be included 
in the report. It is the only filter choice if you have not created a summary calculation for a report.

See also summary filter.

Device Independent Bitmap (DIB)
A bitmap that contains a color table describing how the pixel values correspond to RGB color 
values.

directory server
Specialized databases that store user attributes, object classes and other schema-type information 
in a hierarchical format.

distributed catalog
A catalog intended for a workgroup or company where several users need to
• create and edit reports
• change the catalog contents

For example, users can move and rename folders.
• work offline with Impromptu

For example, users can take their copy of the catalog along on a business trip.

When users open a distributed catalog, Impromptu makes a personal distributed catalog on the 
user's personal computer. However, Impromptu maintains a link with the master distributed 
catalog so that if any changes are made to the original, each user's copy is updated automatically.

drill through
An action that enables Impromptu, PowerPlay, and Scenario users to view transaction-level details 
in an Impromptu report. You can set up a drill through for any cell in Impromptu, any value in 
PowerPlay, or any node in Scenario’s tree view.

dynamo
Formats the result of an SQL query against an ODBC data source. You use a dynamo to generate 
HTML controls that are placed on a page of a PowerPrompts application. For example, you can 
create a dynamo that retrieves countries from a data source. The same dynamo may contain 
different countries, depending on what is contained in the data source or as the data source is 
updated.

embed
Inserts information created in one application into another application. Once embedded the 
information, called an object, becomes part of the document in which it is embedded. When you 
double-click an embedded object, you open the application in which the object was created where 
you can edit the object.

You can embed objects in an Impromptu report or you can embed Impromptu report into another 
application.

See also link and OLE (Object Linking and Embedding).

equi-join
A type of join that retrieves all the rows from one table that have matching rows in another table.
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See also non-equi-join, outer join, and self-join.

expression
Any combination of operators, constants, functions, data items, and other components that 
evaluates to a single value.

expression editor
A dialog box or tab where you can create or edit an expression, including the following:
• Calculation Definition dialog box (Data tab Query dialog box)
• Data Definition dialog box (Data tab Query dialog box)
• Edit Calculation dialog box (Folders dialog box)
• Edit Condition dialog box (Folders dialog box)
• Filter tab (Query dialog box)
• New Calculation dialog box (Folders command Catalog menu)
• New Condition dialog box (Folders command Catalog menu)
• User Filter Profile dialog box (Filter tab User Profiles dialog box)

extension
Three characters that follow a file name. The following extensions are used by Impromptu:
• .bmp Windows bitmaps
• .cat Impromptu Catalogs
• .cq Cognos Query file
• .csv Comma delimited ASCII files
• .dat data file used to source PowerPlay reports
• .dbf dBASE files
• .dib Device Independent Bitmaps
• .htm Hypertext Markup Language files
• .icr Impromptu Catalog content reports
• .imr Impromptu Reports
• .ims Impromptu HotFiles
• .imt Impromptu Report Templates
• .iqd Impromptu Query Definition files
• .mac Cognos Macros
• .mcx Compiled Cognos macros
• .pdf Adobe Portable Document Format
• .sql Structured Query Language (SQL) files
• .tmp Temporary files
• .txt Text files
• .wmf Windows metafile graphic
• .xls Microsoft Excel files
• .xml Extensible Markup Language files

filter
A set of criteria used to retrieve a specific subset of records for your report. You can use a filter in 
reports to filter out unnecessary data and highlight the most important information in your 
report. For example, you can use a filter that shows only the data for your sales region.

If you are using Impromptu Administrator Version, you can create a filter for a user class that is 
automatically applied when the user class accesses the table or column specified in the filter. For 
example, you can create a filter on the Salary table so that only the Human Resources department 
can view that table. All other user classes will not see the Salary table.

See also detail filter, summary filter, and condition.
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fixed association
A group association entered into the definition of a summary data item. Unlike an automatic 
association, the fixed association remains the same when you move it to a new location.

See also associated data item.

footer
A free-format area that appears at the bottom of a list frame or below a specific portion of a list 
frame.

See also header.

form frame
A type of frame that serves as a free-format container for other frames and report objects, Forms 
are useful when creating reports that require custom placement of data, text, tables, and other 
report objects. A form frame shows one row, or record, at a time.

See also child frame, parent frame, primary frame, and report object.

format symbol
Tells Impromptu how to show the data value. For example, the numeric format # symbol shows a 
single digit.

Format Toolbar

A bar with buttons and options you can use to format selected report objects. 

See also toolbar and Toolbar button.

frame
A report object that acts as a container for other report objects. Frames are the basic building 
block with which you create Impromptu reports.

See also chart frame, child frame, form frame, list frame, parent frame, picture frame, primary 
frame, and text frame.

function
A function is a predefined calculation that takes one or more values, performs an operation, and 
returns a value. There are three kinds of functions in Impromptu: Impromptu functions, Database 
functions, and User-Defined Functions.

General format
A standard format based on the user’s locale setting that displays data as follows when the locale 
setting is en-us.

Data Format

Numbers Display with no symbols.

Alphabetical/Alphanumeric data Displays the string as retrieved from the database. To 
display data with an initial capital letter, use the "Aa*" 
format.

Dates  M/d/yyyy

Times If cerlocale.xml uses a 12-hour clock, hh:mm am/pm

If cerlocale.xml uses a 24-hour clock, hh:mm

Date-Time M/d/yyyy hh:mm am/pm
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group data item
A control data item that is used to group data in a report.

See also associated data item.

header
A free-format area that appears at the top of a list frame or above a specific portion of a list frame.

See also footer.

HotFile
A separate local data table that can be added to your catalog or used in a report as if it were a 
regular database table. Once you create a HotFile, any report or catalog can use it. You can use a 
HotFile to link to any database. For example, you can use HotFiles to compare this month’s data 
with last month’s data.

HTML
Hypertext Markup Language. HTML is the language used to create documents for the World 
Wide Web.

integer_exp
An integer constant, an integer data item, or any expression (including a numeric_exp) resulting in 
an integer value.

intranet
A computer network found within an organization that provides services similar to those found 
on the Internet but on a smaller scale.

interval_exp
An interval constant, an interval data item, or any expression resulting in an interval value.

join
Defines the relational links between tables in the physical database. These joins enable you to 
relate the data in one table to the data in another table in the same database so that you can 
retrieve data from more than one table at a time. You join tables using columns in tables. For 
example, the Customer table and the Sales table can be joined using the Cust column.

See also equi-join, non-equi-join, outer join, and self-join.

key
Keys are used to uniquely identify each record in a table. Keys are also used to make joins between 
tables. For example, Cust-id is the key of the Customer table because there can only be one 
customer ID for each customer.

Layout Toolbar
A bar with buttons and options you can use to work with report objects. 

See also toolbar and Toolbar button.

LDAP (Lightweight Directory Access Protocol)
A product-independent protocol that is used to locate organizations, individuals, files, and other 
resources on the Internet or a corporate Intranet.

Intervals d hh:mm:ss.sss

Data Format
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link
The connection between a linked object and the application in which it was created. When the 
information changes in the source file, the changes are reflected in the destination file. You can 
choose to update linked information manually or automatically.

See also embed and OLE (Object Linking and Embedding).

list frame
A type of frame that is designed to report tabular data in rows and columns. Each column in a list 
frame shows all the values for a data item in the database or a calculation based on data items in 
the database. 

See also child frame, parent frame, primary frame, and report object.

locked catalog
A locked catalog restricts access to the catalog Creator user class. When a member of the catalog 
Creator user class attempts to open a locked catalog, they must provide password authentication 
to unlock the catalog before opening it. A catalog lock is specified by the administrator and exists 
in addition to the common logon authentication required by Cognos products and the catalog 
logon authentication. If a user, who is not a member of the catalog Creator user class, attempts to 
open a locked catalog, they are prompted for the usual catalog logon credentials only.

macro
A customized sequence of instructions ("macro commands") that Cognos’ applications can carry 
out.

marked for insertion
A data item that appears in the report. This icon appears beside the data in the Data tab item 
(Query dialog box). Data items can be included in the query and not be marked for insertion in 
the report.

master distributed catalog
Intended for a workgroup or company where several users need to create and edit reports by using 
a common source of information. Only the Creator class can modify or change the master 
distributed catalog. 

When users first open a master distributed catalog, Impromptu makes a copy of the master 
distributed catalog on the user’s personal computer. This local copy is called a personal distributed 
catalog, and allows users to move and rename folders, and work off-line with Impromptu.

Impromptu maintains links between master distributed catalogs and personal distributed catalogs, 
and automatically updates these personal distributed catalogs whenever changes are made to the 
master distributed catalog.

See also catalog, personal catalog, shared catalog, secured catalog, and source catalog.

measure
In PowerPlay, the numbers by which you gauge the performance of your organization. For 
example, measures can be Revenue, Revenue/Employee, and Profit Margin %.

metacharacter
A character used in pattern matching, such as asterisk (*), at-sign (@), caret (^), exclamation (!), 
left angle bracket (<), or-bar (|), parentheses ( () ), pound (#), question mark (?), right angle 
bracket (>), or slash (\).

metadata
Information about the catalogs, schemas, tables, and columns in the database.
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metafile
An image that is generated by the calculation of position on the screen. It can produce more 
intricate images than a bitmap. Windows metafiles have the extension .wmf.

namespace
A source of authentication data used by Access Manager that exists as a directory on a directory 
server, or as an entry in a local authentication export (.lae) file, depending on the default security 
server configured in the system registry. 

The security data stored in each namespace, such as signon information for users, user classes, 
application servers and data sources, distinguishes each entry from all other namespaces in the 
repository.

nested crosstab
A crosstab report that contains more than one data item in the rows or columns. For example, 
you can nest Product Type and Product Line beside each other in the rows.

non-equi-join
A type of join that retrieves all the rows from one table that meet the criteria in another table. For 
example, for each product, you can list the active accounts that have not purchased a product 
using the not equal to (<>) operator. 

See also equi-join, outer join, and self-join.

numeric_exp
A numeric constant, a numeric data item, or any expression resulting in a numeric value.

object
Any piece of information that you create and edit, often with an application other than 
Impromptu, and then insert and store in an Impromptu report.

ODBC (Open Database Connectivity)
A Microsoft vendor neutral interface between database management systems (DBMS) from 
multiple vendors. It is based on existing standards from the SQL Access Group (SAG), X\Open, 
and ANSI.

ODBC driver
A dynamic-link library (DLL) that an ODBC-enabled application, such as Impromptu, can use to 
gain access to a particular data source. Each database management system (DBMS), such as 
dBASE, requires a different driver.

OLE (Object Linking and Embedding)
A Microsoft Windows facility that enables applications to share data. When you use OLE, two 
applications can share data through a connection that you establish.

See also link and embed.

OLE automation
An industry standard that allows applications to expose OLE objects to development tools, macro 
languages, and other applications that support the standard. With OLE automation, you can 
work in one application from within another application.

ownership collection
A collection whose elements (objects) are dependent on the collection's parent. For example, the 
Column objects in the Columns collection are dependent on the parent Table object. If the Table 
object is deleted, the Column objects in the Columns collection are also deleted.

See also reference collection.
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operator
Specifies what happens to the values on either side of the operator. 

There are four types of operators:
• Logical: defines relationships between two parts of the expression.
• Arithmetic: performs arithmetic operations on two parts of an expression.
• String: concatenates two character strings.
• Comparison: compares one or more values that you enter against the values in the database.

outer join
A type of join that retrieves rows from one table even if the rows in another table do not match. 
You can use the following kinds of outer joins:
• A left outer join includes all rows from Table A, matched or not, plus the matching values 

from Table B.
• A right outer join includes all rows from Table B, matched or not, plus the matching values 

from Table A.
• A full outer join includes all rows from both tables, merged where matches were found.

See also equi-join, non-equi-join, and self-join.

parent filter
A filter created for the parent user class of the selected user class. For example, a user class called 
Employees is based on the user class called Managers. In this case, the Managers user class is the 
parent user class. If you create a filter for Managers, it is automatically applied to Employees. The 
filter for Managers is a parent filter for Employees. 

parent frame
A frame that contains one or more subordinate frames or report objects.

See also child frame, primary frame, and report object.

percentile
The value on a scale of one hundred that indicates the percent of a distribution that is equal to or 
below it.

personal catalog
Intended for the small business owner who wants to maintain data such as personal information, 
customer lists, and product pricing. Use a personal catalog if you are the only person using the 
catalog and you are using the Administrator Version of Impromptu. 

See also catalog, distributed catalog, shared catalog, and secured catalog.

personal distributed catalog
Personal distributed catalogs exist on the user's personal computer, and are copies of the master 
distributed catalog. They are created the first time the user attempts to use a master distributed 
catalog. Users can work off-line with their personal distributed catalogs. They can also modify 
their personal distributed catalogs by moving and renaming folders. However, they cannot change 
the tables, columns, or joins that are defined for the distributed catalog.

Impromptu maintains links between the master distributed catalogs and personal distributed 
catalogs, and automatically updates the personal distributed catalogs whenever changes are made 
to the master distributed catalog.

See also catalog, personal catalog, shared catalog, secured catalog, and source catalog.

picture
Any Windows bitmap file (.bmp) or Device Independent Bitmap (DIB) file that is stored in a 
location your computer can access.
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picture frame
A frame that you can use to show a bitmap (.bmp) or Device Independent Bitmap (DIB).  You can 
enhance the appearance of your reports by adding images such as a company logo. In addition, 
you can show pictures, such as your company’s products or employees, that change based on the 
content for the items.

See also child frame, parent frame, primary frame, and report object.

pivot
A quick way to change a list report into a crosstab report. Pivot by dragging and dropping one or 
more columns into the row titles area.

placeholder
A representation of what data should appear in place of the placeholder. Placeholders determine 
where and how the data and calculations will be positioned and shown in reports that use the 
template. Placeholders can be defined as optional or required. Placeholders can also be defined to 
accept one column or many columns. For example, you can add placeholders to a template that 
represent the customer’s address in a report. This helps other users understand how to complete 
the report.

PowerCube
A file that contains data that is structured to provide for fast retrieval and exploration in 
PowerPlay.

PowerPrompts
A series of HTML forms that Impromptu Web Reports consumers use to customize a report 
before they run it. The Impromptu report author creates a PowerPrompts application using the 
PowerPrompts Developer Studio, then delivers the application along with the report to the 
Impromptu Web Reports administrator.

prompt
A dialog box that asks the user to enter information when a report is opened. A report can contain 
several prompts which it uses to filter so you only get the data you want. Prompts can require the 
user to type in information, or select items from a picklist. A picklist can include data items from 
the catalog, data items from another report, or data from a file in delimited ASCII format.

See also Prompt Manager.

Prompt Manager
The dialog box you use to create, edit, delete, and store prompts for the currently active report.

prompt references
Prompt references are expressions such as detail filters, summary filters, calculations, and 
conditional format expressions that reference a prompt.

primary frame
A frame that serves as the default object into which Impromptu inserts report objects such as 
placeholders and data. The first form frame or list frame that is created in a report or template is 
automatically designated as the primary frame.

See also chart frame, child frame, form frame, list frame, parent frame, picture frame, report 
object, and text frame.

property
A named attribute of an object.
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query
A question to the database, snapshot, or HotFile that defines what data you want to retrieve from 
the data source.

record
Composed of one data value from each column in the dataset. Also known as a row.

reference collection
A collection whose elements (objects) are not dependent on the collection's parent, they are only 
referenced from a collection that the objects are depended on. For example, the Table objects in 
the FilteredTables collection are not dependent on the parent UserClass object. If the UserClass 
object is deleted, the Table objects in the FilteredTables do not cease to exist because the collection 
that the Table objects depend on still exists.

An object cannot only belong to a reference collection, although it can belong to more than one 
reference collection. It must also belong to an ownership collection.

See also ownership collection.

relational database
A collection of information that is organized into tables.

report 
A view of the current data in your company database that is organized and formatted the way you 
want it. The data you see in your report depends on the data you can access from your catalog. A 
report can be based on a template.

See also template.

report author
An Impromptu user who creates complex reports and has an in-depth knowledge of the powerful 
features in Impromptu. The Mastering Impromptu Reports online help file is intended for report 
authors.

report creator
An Impromptu user who creates basic reports using the Report Wizard or a template, and applies 
essential skills, such as sorting, grouping, formatting, and basic filtering. Report creators can find 
the information they need in the Impromptu online Help.

report definition
A definition of the data in the report and how the data is shown and formatted. The report 
definition is static; it does not change when the report data changes. The database provides you 
with access to the most current data in the database. Therefore, when you save a report, you are 
not saving the actual data in your report, only the report itself. To save the report data, create a 
snapshot, create a HotFile, or use the Save As command to move the data to an external file in a 
specified format (for example, Microsoft Excel). You can also print the report using the Print 
command to save a copy of its current data.

Report Navigator
An optional control in a HyperText Markup Language (HTML) and PDF report that enables you 
to jump to a grouped column value. In an HTML report you can also jump to a specific page 
number.

report object
An object in a report. Report objects include text, pictures, frames, data items, report variables 
such as Date and Page Number, and so on. You can format report objects using the Format menu 
commands.
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report variable
A value that is supplied by your computer or by Impromptu. Report variables are inserted into 
reports using the More Objects command from the Insert menu.

report viewer
An Impromptu user who views reports, prints reports, or exports information found in existing 
reports. Report viewers can find the information they need in the Impromptu online Help and the 
Discovering PowerPlay book.

result set
A copy of the data retrieved by a report. A result set can be stored locally on a personal computer, 
or remotely on a server. 

row
Composed of one data value from each column in the database. Also known as a record.

running-average
A summary that displays a new average for each additional value in a selected data item.

running-count
A summary that counts each value in a selected data item one by one.

running-maximum
A summary that displays a new maximum for each additional value in a selected data item.

running-minimum
A summary that displays a new minimum for each additional value in a selected data item.

running-total
A summary that displays a new total for each additional value in a selected data item.

scope of data
A property of form frames that determines what data they can show. A form frame can show a 
single row of data, all rows associated with the grouped data item, or all data the form frame can 
access.

secured catalog
Intended for users who do not need or want to create or edit their own reports. The users cannot 
change the catalog in any way. They can run, export, and print reports that the administrator has 
created. This type of catalog is useful for users who are not familiar with Impromptu and just 
want to analyze the data in the pre-defined reports. 

See also catalog, distributed catalog, personal catalog, and shared catalog.

self-join
A type of join that enables you to add two copies of the same table to a catalog so that you can 
relate values within a single table. 

See also equi-join, outer join, and non-equi-join.

shared catalog
Intended for a workgroup or company where several users need to create and edit their own 
reports. A shared catalog is ideal in a LAN environment where the catalog can be stored in a 
shared drive and directory that everyone can access.

See also catalog, personal catalog, distributed catalog, and secured catalog.
194  Cognos Impromptu (R)      



 

signon
A User ID and password that is used to identify individual users and govern their access to 
resources.

snapshot
A permanent local copy of the report and the data retrieved by a report. The data on your 
personal computer can be shown and even manipulated at a later date without having to connect 
it to the original database.

source catalog
A distributed catalog on the LAN that is maintained by the administrator. When users open a 
distributed catalog, Impromptu makes a copy of the catalog on the user’s personal computer. 
Impromptu maintains a link with the original source catalog so that if any changes are made to 
the original, each user’s copy is updated automatically. Also called a master distributed catalog.

SQL (Structured Query Language)
The structured query language for accessing relational database information. You do not need to 
know SQL to use Impromptu; Impromptu automatically generates the SQL needed to retrieve the 
data for your report.

standard deviation
A measure of how much the data varies from the mean, expressed in the same units as the data 
(for example, inches, seconds, days). The square root of the variance is standard deviation.

Standard Toolbar
A bar with buttons and options you can use to create new reports, open existing reports, cut, 
paste, and copy report objects, and perform many other routine commands while you work with 
Impromptu reports.

See also toolbar and Toolbar button.

status line
A bar that appears at the bottom of the report window. The status line is a source of 
context-sensitive help. The status line is continually updated to provide you with information as 
you are working. It tells you what is happening, where you are, and what your options are. If your 
pointer is over a Toolbar button or if you have highlighted a command, the status line tells you 
what the command does.

The status line is divided into three sections:
• the catalog section shows which catalog is currently active.
• the report section shows report information such as progress indicators during saving, 

retrieving, and printing. It also shows coordinates during drag and drop operations.
• the general section provides information about memory, keyboard toggles, and product 

toggles (such as auto-retrieve).

stored procedure
A procedure defined and stored in a host database (such as Oracle or Sybase) that performs 
actions on the database.

string
A character string enclosed in quotation marks. For example: "Cognos."

string_exp
A string constant, a string data item, or any expression resulting in a string value.
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style
A defined group of formatting options that you can apply to selected report objects.

sub-report
A sub-report is a sub-query that is usually associated with a main query. You can include several 
sub-reports in one report. With sub-reports, you can deliver information in one report that would 
otherwise be available only with two or more reports.

summary
A summary component combined with a data item that has either fixed or automatic association.

The association of a summary determines the group for which it is calculated.

For example, if Total (Sales) is located in the Branch footer, then you will see the total sales for 
each branch.

A summary can have either automatic association or fixed association with its location. 

A summary with automatic association changes depending on its location. For example, if you 
move Total (Sales) from the Branch footer to the Country footer, then you will see the total sales 
for each country.

If a summary is explicitly associated, its value will reflect the group to which it is associated, 
regardless of where you put it in the report. For example, if the summary Total (Sales) is 
associated with the Country group and you place it in the City footer, then the summary will still 
reflect the total sales for each country.

summary filter
Limits the data retrieved in a report and can include summary components. A summary filter 
eliminates data from a report based on summary data items. For example, you could create a 
summary filter that eliminates all distributors with sales totaling less than $100,000. Data item 
summary values are calculated after the summary filter is applied. 

See also detail filter.

summary component
An operation that enables you to extract summary information from your data in the following 
ways: total, minimum, maximum, average, count, rank, percentile, percentage, running-total, 
running-minimum, running-maximum, running-average and running-count.

swap
Exchanges the positions of rows and columns in a crosstab report.

synonym
An alternative name for a table, view, alias, or another synonym. A synonym can be used in SQL 
statements wherever a table or view is used. Use a synonym to substitute the value of the synonym 
within the SQL.

syntax
Specific grammatical rules.

table
A portion of the database or HotFile that contains one kind of information organized into rows 
and columns. In Impromptu, a table is a label for the item that points to the database table. A 
catalog identifies the tables from the database that you want to access in Impromptu.

template
A template is a pattern you can use to build reports. By using templates, you can save time and 
effort when you create new reports. If you create the same type of report frequently, the template 
can be your guide. 
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A template can contain placeholders and store formatting information. You can specify 
information about margin settings, page orientation, font choices for different report objects, and 
so on.

text frame
A type of frame that contains text or data. Text frames are useful when creating blocks of static 
text (as in form letters) or dynamic text based on data. All text in Impromptu reports is contained 
in text frames. For example, whenever you see a data cell in a list frame, or a label in a summary 
calculation, you are seeing a text frame.

See also child frame, parent frame, report object, and primary frame.

text object
An object that includes text.

thumbnail
A mode of operation you can set in Impromptu to create a temporary data file with a restricted 
number of rows.

time_exp
A time constant, a time data item, or any expression resulting in a time value.

toolbar
A bar with buttons that perform commands.

See also Standard Toolbar, Format Toolbar, and Layout Toolbar.

Toolbar button
A button that you click to perform an action. Buttons that perform related actions are grouped on 
a toolbar.

type library
A collection of all exposed Impromptu objects, properties, and methods. The type library makes it 
easier for programmers to use Impromptu automation components in their code.

user class
A group of users (or a single user) who need access to the same data in the catalog and who have 
the same access privileges. For example, European salespeople all need data on their customers 
who are in Europe, while North American salespeople need data on their customers who are in 
North America.

user profile
All the information about a user class, such as the name of the user class, password, data access 
privileges, and whether the user class can create reports. 

See also user class.

variable
A value that is supplied by your computer or by Impromptu. Variables are inserted into reports 
using the More Objects command from the Insert menu.
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variance
The amount the individual data points differ from the average. This is calculated as the sum of the 
square of the deviations from the mean, divided by one less than the number of observations. For 
example,

view
A definition stored in a database’s metadata that defines a ‘virtual table‘ that does not exist until 
referenced in an SQL statement, such as a select statement.

Windows Common Logon Server
A server that records information about the users of a Windows-based application so that they 
can log on once and access multiple data sources.

ymdinterval_exp
A year-month-day interval expression.

variance = e1+ e2+ e3

2
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Symbols
.csv files, exporting, 24
.csv files, saving reports as, 21
.dat files, saving reports as, 21
.dbf files, saving reports as, 21
.htm files, saving reports as, 21
.ims files, saving reports as, 21
.iqd files, saving reports as, 21
.pdf files, saving reports as, 21
.sql files, saving reports as, 21
.txt files, saving reports as, 21
.wk1 files, saving reports as, 21
.xls files, saving reports as, 21
.xml files, saving reports as, 21

Numerics
2D Circular Pie check box, 174

A
Absolute radio button, 174
Absolute Values radio button, 175
accessibility

reporting solution overview, 36
adding

borders, 91
chart titles, 110
colors, 91
currency symbols, 88
data to reports, 39
headers and footers, 76, 100
patterns, 91
pictures, 64
Report Navigator, 23
summaries, 58
text, 63
totals to a list report, 60

adjusting margins, 77
aggregates, 57
aligning

parts of a report, 77
text, 86

Alignment list box, 165
Always Include Zero check box, 168
Angle box slider, 174
applying

styles, 93
area charts

description, 105
Area radio button, 174
As Percentage check box, 175
ASC files, 24

associating
data, 43
data with grouped item, 47

Automatic radio button, 169
automatically

upgrade a report or a catalog, 31
axis scale settings

changing, 112
axis titles

formatting, 111

B
bar charts

description, 105
blank template, 33
bookmarks

adding in reports, 23
borders, 91
Box Style list box, 177
bubble charts

description, 106
Bubble size slider, 172
bulk fetch rows limit, 146
burst reports

creating for IWR, 129

C
canceling data retrieval, 37
Cannot access the datasource error message, 155
Cannot find the file’<path><report>.imr’ error message, 157
catalog has no user class error message, 156
catalogs

conditions, 52
editing personal distributed, 142
opening, 30
upgrade, 31

category axis, 182
Category Title check box, 179
century setting, 146
Cer.ini

locations, 138
cerlocale.xml, 90
changing

borders, 91
chart labels, 115
chart scale settings, 112
chart type, 109
colors, 91
column titles, 98
column width, 98
fonts, 92
grids settings in charts, 114
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height, 101
margins, 77
number of instances of Impromptu, 38
order of currency symbols, 88
page breaks, 102
page layout, 11
patterns, 91
report orientation, 15
row height, 99
text formatting, 92
views, 11
width, 98, 101

character formats, 83
chart area

formatting, 112
chart controls

Grids and Scales dialog box, 166
Properties dialog box, 172
Titles dialog box, 179
Trendlines dialog box, 179

chart frames
formatting, 109

chart labels
changing, 115

chart legend
adding, 115

chart legends
formatting, 115

chart properties
formatting, 109

chart titles
adding, 110
formatting, 111

chart type
changing, 109

chart types
choosing, 105
pie, 107

charts
adding trendlines, 117
changing scale settings, 112
choosing type, 105
correlation, 118
creating, 107
creating correlation, 118
fill pattern formatting, 165
font formatting, 165
formatting, 118
formatting chart, plot, legend area, 112
formatting data items individually, 114
formatting text, 165
line formatting, 165
showing data labels, 115

Circular Data Lines check box, 174
Circular Gridlines radio button, 174
Clustered radio button, 174
Cognos Query, 35, 125, 126
Cognos.ini, 138
Color dialog box, 183
Color palette, 165
colors

adding, 91

columns
changing titles, 98
hiding, 70
hiding and showing, 69
moving, 97
printing repeat, 18
selecting, 96
specifying exact widths, 98

comma separated value files, 24
command line startup switches

macro-filename, 135
overview, 135
report-name, 135

conditions, 52
configuring

data formats, 90
Connect Data Points check box, 172
copyright, 2
correlation chart, 118

formatting, 118
creating

a local copy of report data, 122
burst reports, 129
charts, 107
crosstab reports, 32
format symbols, 81
list reports, 31
reports with templates, 33
snapshots, 122
summaries, 58

crosstab reports, 102
setting default column format, 104

crosstabs
creating, 32
creating as sub-reports, 36
filtering, 53
repeating row area, 18

CSV files, 24
Cumulative Values radio button, 175
currency

formatting data, 87
currency data

formatting, 90
currency symbol list

using, 87
currency symbols

using with numeric data, 87
customizing

data formats, 81

D
data

adding, 39
associating, 43
associating with grouped item, 47
creating a local copy, 121
finding, 54
formatting, 81
formatting currency, 90
formatting numeric, 90
grouping, 43, 45
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hiding, 70
in headers and footers, 76
labels, 115
removing, 39, 40
retrieving, 37
sorting, 43, 46

data attributes (Impromptu.ini), 146
data display

enhance, 87
data formats, 90

configuring, 90
data items

formatting in charts, 114
data labels

formatting, 111
databases

disconnecting from, 121
date formats, 83

exporting, 22
dates

inserting, 67
sorting, 46

date-time formats, 85
DB2

troubleshooting database connection, 158
dBASE files, 21, 22
default column format, 104
defaults

directories, 141
delimited ASCII files, 21, 22
delimited ASCII text files, 24
Depth check box, 172
Depth slider

Depth check box, 172
pie charts, 172

Direction slider, 172
directory defaults, 141
disabling

read-only report warning, 142
disconnecting

from the database, 121
Display Series Lines check box, 172
DMS-E-DBACCESS error message, 155
Draw Categories in Reverse Order check box, 166
Draw Custom Line at check box, 170
Draw Series in Reverse Order check box, 166
drill through, 10, 125, 126
Dual Axes check box, 174

E
editing

personal distributed catalogs, 142
email, 24
enhanced file searching, 134
Error 53 dms-e-yv_systemerr error message, 157
error messages

cannot access the datasource, 155
catalog has no user class, 156
DMS-E-DBACCESS, 155
Error 53 dms-e-yv_systemerr, 157
the catalog’s available user classes do not correspond, 156

unable to connect to the database, 158
unexpected windows error (1157), 157

example
creating correlation chart, 118
formatting correlation chart, 118

Excel
exporting reports, 22

Excel files, 21, 22
Excel report output

specifying version, 24
Explode slider, 172
exponenetial trendline, 117
exporting

reports, 21, 22
expression editor, 55

F
file format

csv, 24
file searching, 134
files

different formats, 21, 22
exporting, 21, 22
exporting delimited ASCII, 24
ini, 137
most recently used, 151
MRU, 151
opening, 9
recent file list in .ini file, 151

fill pattern formatting
charts, 165

filtering
using a catalog condition, 52
using crosstab titles, 53
using the Filter Drop-Down button, 51
using the toolbar button, 50

filters
stored, 52
suspending, 52

finding data, 54
fit to page, 17
Floor check box, 178
font formatting

charts, 165
Font list box, 165
fonts, 92
footers, 76

adding, 100
height and width, 101
hiding and showing, 69
keeping with details, 101

Footnote check box, 179
formats

data, 90
ini files, 137

formatting, 66, 82, 83, 84, 85, 86, 102
axis titles, 111
chart area, 112
chart legends, 115
chart properties, 109
chart titles, 111
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charts, 109
data, 81, 87
data items individually, 114
data labels, 111
legend area, 112
legend text, 111
overview, 75
plot area, 112

G
gantt charts

description, 106
Gap Width slider, 172
glossary, 181
graphics, 64
grid, 78
grid lines, 95
Grid Style list, 170
Gridlines per interval box, 170
Grids and Scales dialog box

controls, 166
grids settings

changing, 114
grouping

data, 43, 45
parts of a report, 71

H
headers, 76

adding, 100
height and width, 101
hiding and showing, 69
keeping with details, 101

height, 99, 101
help information, 153
hidden parts of a report, 70
hiding, 70

columns, 69
data labels in charts, 115
grid lines, 95
headers and footers, 69
part of a report, 69

highlowcloseopen charts
description, 106

highlowopen charts
description, 106

Hole Size slider, 172
Horizontal radio button, 174
HotFiles, 121, 129
HTML, 13

I
images, 64

adding to Excel report output, 24
importing queries, 35
Impromptu

running multiple instances, 37, 38
Impromptu Data Directory, 138
Impromptu Web Reports

notifying the report administrator, 130

preparing reports for, 127
using locked catalogs, 128

Impromptu.ini, 139
information about help, 153
INI files

Cer.ini, 138
ini files

Cognos.ini, 138
format, 137
Impromptu.ini, 139
overview, 137

inserting
page breaks, 102
page numbers, 66
pictures, 63, 64
report variables, 63, 67
text, 63

interval formats, 86
IWR

notifying the report administrator, 130
preparing reports for, 127

J
justify data, 86

K
Keep aspect ratio constant check box, 172

L
Label Format list box, 175
labels

changing in charts, 115
Labels Location list box, 175
Labels on Both Sides radio button, 166
Labels on Bottom radio button, 166
Labels on Left radio button, 166
Labels on Right radio button, 166
Labels on Sides check box, 175
Labels on Top radio button, 166
layout, 86
Layout list box, 177
Left Wall check box, 178
left-justified alignment, 86
legend area

formatting, 112
legend text

formatting, 111
legends

adding to charts, 115
line charts

description, 106
line formatting

charts, 165
Line radio button, 174
list frames, 95, 97
list reports

adding totals, 60
creating, 31
printing repeat columns, 18
printing wide reports, 17
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lists, 96
locale

settings, 90
locale settings

configuring, 90
locations

Cer.ini, 138
locked catalogs

in Impromptu Web Reports, 128
locked report warning, 142
logarithmic trendline, 117
Lotus 1-2-3 files, 21, 22

M
macro-filename command line startup switch, 135
Make Logarithmic check box, 168
Make this a Descending Axis check box, 166
margins, 77
Markers and Text list box, 177
marking data items for a report, 39
Mastering Impromptu Reports, 153
Maximum Value check box, 169
minimum free disk space, 146
Minimum Value check box, 169
moving

columns, 97
summaries, 61

moving average trendline
linear trendline, 117

MRU files, 151
multiple instances of Impromptu, 37
multiple versions of Impromptu, 37

N
navigation

adding in reports, 23
Number of categories between labels radio button, 169
numbering pages, 66
numeric data

formatting, 90
numeric formats, 82

O
object attributes (Impromptu.ini), 148
On Slices radio button, 175

series labels, 175
online help information, 153
opening

catalogs, 30
reports, 9

options
query, 146
startup, 142

Order edit box, 179
Outside Slices radio button

data values, 175
series labels, 175

Overlap slider, 172

P
packaging

HotFiles for UNIX, 129
HotFiles for Windows and UNIX, 129

page breaks
inserting, 102
removing, 102

page numbers, 66, 67, 102
page setup, 15
Pattern button, 165
patterns, 91
PDF bookmarks, 23
Percent radio button, 174
Period edit box, 179
picklists

limit, 142
pictures, 63, 64
pie charts, 107

description, 107
Pie Name check box, 178
Pie radio button, 174
Pie Total check box, 178
plot area

formatting, 112
polynomial trendline, 117
positioning part of a report, 78
PowerPlay files, 21, 22
PowerPrompts, 131
preparing reports for IWR, 127
previewing reports, 16
printer setup, 16
printing

repeat columns, 18
reports, 15
wide list reports, 17

Q
queries

importing, 35
removing data, 40
statistics, 150

query options (Impromptu.ini), 146

R
radar charts

description, 107
read-only report warning, 142
refreshing snapshots, 123
Regression Type list box, 179
removing

borders, 91
currency symbols from currency symbol list, 88
data, 39, 40
filters, 50
grouped data, 45
headers and footers, 76
page breaks, 102
snapshots, 124
sorting, 46

rendering
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report in Excel format, 24
report administrator, 130
report navigation

adding, 23
Report Navigator

adding, 23
report objects

hiding, 70
positioning, 78
stacking, 72

report variables, 63
calculation, 67
catalog description, 67
catalog file name, 67
chart frame, 67
column spacer, 67
column titles, 67
data item, 67
database name, 67
database user ID, 67
form frame, 67
list frame, 67
OLE object, 67
page number, 67
picture frame, 67
prompt variable, 67
rectangle, 67
report description, 67
report file name, 67
row numbers, 67
running page totals, 67
snapshot timestamp, 67
system date, 67
system time, 67
text frame, 67
total pages, 67
user class, 67

Report Wizard
creating crosstabs, 32
creating list reports, 31

report wizard, 29
report-name command line startup switch, 135
reports

accessibility, 36
adding data, 39
aligning parts of, 77
aligning text, 86
applying templates, 75
creating, 29, 31, 32, 33
email, 24
filtering using stored filters, 52
formatting, 75, 77, 81, 91, 92, 93
grouping parts of, 71
preparing for IWR, 127
previewing, 16
printing, 15
rendering in Excel format, 24
resizing parts of, 72
reusing, 35
saving in different file formats, 21
See also accessible reports, 36
specifications, 133

unhiding parts of, 70
upgrade, 31
viewing, 9, 10, 11

resetting page numbers, 102
resizing parts of a report, 72
Restore All button, 172
retrieving data, 37
reusing reports, 35
Right Wall check box, 178
right-justified alignment, 86
Ring Pie radio button, 174
Riser Shape list box, 172
Rotation slider, 172
row height, 99
rows

hiding, 70
selecting in a list, 96

S
saving as, 21, 22
scale settings, 112

changing in charts, 112
scatter charts

description, 107
searching for files, 134
select values, 51
selecting

parts of a crosstab report, 102
parts of a list report, 96

Series Axis check box, 179
Set manual number of categories between gridlines radio 

button, 170
Set Maximum Value check box, 168
Set Minimum Value check box, 168
setting

chart spacing, 112
column width, 98
page breaks, 102
row height, 99
up drill through to Cognos Query, 126
up the printer, 16

settings
locale, 90

Shape list box, 172
Show as Percentage check box, 175
Show Axis split check box, 177
Show Close check box, 174
Show Coefficient Values check box, 179
Show Color Same as Series check box, 179
Show Data Labels check box, 175
Show Equation check box, 179
Show Gridlines check box, 170
Show Labels check box, 175
Show Labels for this Axis check box, 169
Show Leader Lines check box, 175
Show Legend check box, 177
Show lines check box, 172
Show Markers check box, 172
Show Open check box, 174
Show the Axis Line on the Chart check box, 166
Show Total radio button, 175
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Show Trendlines list box, 179
Show Values check box, 175
Show Y-Axis Values on the left check box, 178
showing

columns, 69
data labels in charts, 115
grid lines, 95
headers and footers, 69
part of a report, 69, 70

Size list box, 165
Size slider, 172
snap to

column width, 72
grid, 78
parent size, 72

snapshots
compared to HotFiles, 121
creating, 122
overview, 121
refreshing, 123
removing, 124
saving, 122

sorting
data, 43, 46
removing, 46

specifications
reports, 133

Spider Gridlines radio button, 174
Split check box, 174
Split Position slider, 177
SQL, 21, 22
Stacked check box, 174
Stacked radio button, 174
stacking parts of a report, 72
Stagger Labels radio button, 169
startup options (Impromptu.ini), 142
static charts

adding to Excel report output, 24
statistics

query, 150
Style buttons, 165
Style list, 174
Style list box, 165
styles, 148

applying, 93
sub-reports

creating crosstab, 36
Subtitle check box, 179
summaries, 58

association, 57
creating, 58
moving, 61
overview, 57
total, 60

summary expressions
adding to Excel report output, 24

Sybase Adaptive Server Enterprise
troubleshooting database connection, 158

symbols
character, 83
currency, 87
dates, 83

date-time, 85
interval, 86
numeric, 82
time, 84

T
Tail Shape radio buttons, 172
templates

applying to reports, 75
blank, 33
creating reports with, 33

Teradata
troubleshooting database connection, 158

text
files, 21, 22
formatting, 92
frames, 63
inserting, 63
justification, 86
wrapping, 86

text frames
adding to Excel report output, 24

the catalog’s available user classes do not correspond error 
message, 156

Thickness list box, 165
Tilt box, 172
time formats, 84
Title check box, 179
titles

adding to charts, 110
formatting in charts, 111

toolbars
ini files, 150

total page numbers, 67
totals

adding to a list report, 60
generating automatically, 58
number of pages, 67
running, 67

Transformer files, 21, 22
Transparent button, 165
trendlines

adding in charts, 117
exponential, 117
linear, 117
logarithmic, 117
moving average, 117
polynomial, 117

troubleshooting
cannot access the database, 155
catalog has no user class, 156
DMS-E-DBACCESS, 155
Error 53 dms-e-yv_systemerr, 157
the catalog’s available user classes do not correspond, 156
unable to connect to database, 158
unexpected windows error (1157), 157

True 3D radio button, 174
type libraries, 151

U
unexpected windows error (1157) error message, 157
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ungrouping
data, 45
parts of a report, 71

unhiding parts of a report, 69, 70
upgrading

catalogs, 31
reports, 31

Use manual grid interval value check box, 170
Use Manual Number of Series radio button, 168, 169
using

a report as a data source, 35
type libraries, 151

V
Value Axis Crossed Between Categories check box, 166
Value Title (Y1) check box, 179
Value Title (Y2) check box, 179
values

finding, 54
selecting in a list, 96

version of document, 2
Vertical radio button, 174
viewing

headers and footers, 76
reports, 9, 10, 11
reports in HTML, 13

W
Web browsers, 13
width, 98, 101
working offline, 122

X
X-Axis check box, 179

Y
Y1 Axis list box, 177
Y2 Axis list box, 177
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